Linksys WRT54G Setup want a password

Where was I…

Er, right. So your built-in ethernet network card should be working again at this point.

What we need to do now is copy the Internet settings from your USB connection properties (Local Connection 3) to your Ethernet connection properties (Local Connection).

  1. Go back to Control panel > Network Connections
  2. Right-click Local Area Connection 3 and select [b]Properties from the shortcut menu.
  3. In the Local Area Connection 3 Properties dialog box, select the Internet Protocol (TCP/IP) list item.
  4. Click Properties
  5. Write down all the settings that you see on this properites page, as you will have to duplicate these.

Now, to configure your ethernet card with the same settings…

  1. Go back to Control panel > Network Connections
  2. This time, right-click Local Area Connection and view its TCP/IP properties
  3. Enter in the same values that you copied previously.

Here is where you now require a leap of faith, as we’re going to disable your USB network connection, unplug the USB cable, and connect your cable modem to the network card using an ethernet cable. At the end of this, we’re going to hope you have a working Internet connection.

Disable the USB connection

  1. Go to Control Panel > Network Connections
  2. Right-click Local Area Connection 3 and select disable from the shortcut menu.

Note: If you need to re-enable this USB connection for whatever reason, you again have to go to the Device Manager listing to turn it back on.

Do the switchover

  1. Unplug the USB cable from your computer and from the cable modem.
  2. Connect the ethernet cable from your computer to the cable modem.
  3. Remove the power source from your cable modem for 15 seconds.
  4. Restore power to your cable modem and wait for it to sync up.

Test the connection
Launch in a web browser

Are you still with us, Crypt?

I’m afraid not. I think I need to actually reinstall or reconfigure the modem somehow.

Actually, wait a second. I’m currently on my Macbook Pro. I just basically unplugged the ethernet from the computer into it to get back online.

So it appears there’s a bit of a pain with the PC connecting to the router. But what if I just set-up the router with the laptop? I only need the wifi for the laptop. Maybe that will work.

Okay, the good news: I’m now supposedly connected to the wifi. Great! I did this by basically just ignoring my desktop and configuring it all from my MBP via Windows XP bootcamp.

The bad news is it says it can’t reach the internet. I can only guess this is because I’m not supplying the right password or settings, so I’ll call tomorrow and see what they say.

Can you reach the router config page with your web browser?

Try bridging all of your network connections (if you haven’t yet).

Since the topic of Linksys WRT54G routers came up, just put a new one in to replace an old router that stopped working. Most things work just fine, except for whatever reason, the wired and wireless machines can’t see each other. I upgraded the firmware, and I can ping the machines just fine, so this might just be a Windows Networking problem. I’m curious because the only thing that changed recently was the router. Any ideas on what to try next?

  • Alan

Nothing elegant, no, but you could run a VPN.

I called up eircom and they supplied me with the correct username and password. Despite this, the Linksys still can’t reach the internet, and I know the username and password to be correct, having plugged them into my modem as well to test.

Any other ideas? I’m really starting to think this thing actually is broken.

Crypt, were you able to get your modem working over the ethernet cable? Because, until you can pass that milestone, your Linksys router has no purpose to serve.

It’s been on the ethernet cable for quite a while.

So, after connecting the Linksys router as an intermediary between your DSL modem and your computer, can you access the linksys configuration pages at ?

In the Setup page, are you able to set the internet connection type to “PPPoE” and populate the “Username” and “Password” fields with your DSL account information?

Having set up your account and saved, can you go to the Status page and click the “DHCP Release” and “DHCP Renew” buttons?

Sorry I keep on spending so much time between replies… I don’t find myself having a lot of time to try to troubleshoot this.

Anyway, I tried checking that just now, Roger, but it’s asking me for a username and password to even see the page. I have no idea what this would be. admin:admin, [blank]:admin, admin:[my password], brownlee:[my password] and anything else I can think of aren’t working. Any ideas?

Weird; a hard reset should return the login to the default [empty]:admin. Do you have an option to return the unit and get a new one?

Also, for my problem, partial solution for the workgroup problem by resetting everything (machines and router), although there’s still something odd going on with the share directory on one of the machines. However, at this point I’m satisfied it isn’t a hardware issue.

  • Alan

What Wong said, have you confirmed that if you take the router out of the loop, your line is working straight to the PC?


The ethernet cable from the modem to the computer works. What I really need now is a way to log-in to the backend of the router.

I’ve tried doing a hard reset, but I’m not sure I’m doing it right. Can anyone confirm that the proper way to do a hard reset is by holding down the reset button for thirty seconds, unplugging the router, then letting go of the reset and plugging it back in?

Nope – unplug, press and hold reset, plug it in, wait 10 seconds (or so), then release the reset button. IE, the reset button needs to be down when power is applied. (at least, that’s how I do it)

Okay, excellent, I’ve connected. But even in the Linksys router page, I can’t connect… it says it can’t establish an IP address or somesuch.

Here’s the current settings in there:

Connection Type: PPPoE
Username: eircom
Password: broadband1
Router Name: WRT54G
Host Name: Blank
Domain Name: Blank
MTU: Auto
Local IP Address:
Subnet Mask:
DHCP Server: Enable
Starting IP Address:
Max Num of DHCP Users: 100
Client Lease Time: 0
Static DNS 1,2,3: All
Timezone: GMT (England)

Here’s the Eircom page with my broadband settings:

Anyone got any idea where to go from here? Thanks again for all the help.

  1. DNS values

Enter those values for the topmost “Static DNS” entries and see what happens.

  1. Go to the “Status” tab of the Linksys configuration and type in what you see there. That will tell us if your linksys router is communicating with the DSL modem properly. The modem is supposed to get an Internet IP address from EIRCOM, and then pass than IP address to the router. The “Status” page is where that is visible.

  2. Is the DSL modem one of those Netopia thingies?

Because if it is, what you effecitvely have is two routers in-line with each other; those Netopia modems are secretly also routers.

You may need to go into the modem’s configuration and change it to work in bridge mode instead of router mode.

At least, that’s what these folk are saying in this thread:

Let us know if you have a similar modem, and we’ll try to figure out how you’re supposed to do it.