Linksys WRT54G Setup want a password

I’m a little bit worried about doing this, because of this line: “When the modem is set up in Bridge mode, it doesn’t have an IP address for you to ping. Log into your Linksys, and look at it’s WAN address.” Which looks to mean that if it all fucks up, I can’t change it back.

Can you guys confirm that these would be the instructions I should follow? http://www.netopia.com/support/technotes/hardware/CQG_020.html I have a Netopia 3341, and it looks correct, but I definitely want to make sure I’ve got all bases covered before I try this.

Thanks, Roger, you’re a star.

Actually, it looks like it might still be accessible at 192.168.1.254

Caution! At this stage we strongly suggest that you assign the ethernet (LAN) IP address the default value of 192.168.1.254. This way, if you ever need to get back into the router for configuration changes or to add feature keys, you can just connect a workstation directly to the four-port ethernet switch. With the computer set at an address on the same subnet and a default gateway of 192.168.1.254, subnet mask 255.255.255.0, you’ll be able to easily browse or telnet into the router.

So I just have to connect to it directly when I’m in bridge mode, I guess, as opposed to through the router.

Ha ha ha ha ha ha ha ha ha ha ha ha! Yes! Success! I’m now wireless! Bridge mode was the trick.

Roger, I really can’t thank you enough. Thanks for sniffing it all out for me!

Actually, I have one more question. Now that the WRT54G is up and running, how do I give the connection a password so my upstairs neighbor can’t use it to download child porn?

You set a WEP key password in the router configuration page. You type in a passphrase, and the router generates a long-ass key that looks something like this:

00F0AB3327CCD380239DC98EF03497H087A9373499E97H97234D

From that point on, any computer that attempts to connect to your Linksys router via wireless has to supply that WEP key when it attempts to establish a wireless connection. In other words, you have to type that long-ass key into your laptop when you are prompted for a WEP key. Once the correct key is supplied, though, the wireless computer will remember the key for next time and you won’t have to type it in again.

More importantly, though, you should change the password of your router to something other than “admin”

You’d be surprised how many people don’t even bother with this step, or even change the SSID to something other than the default “Linksys”.

Adding WEP encryption is a good second step (after changing the password). If you want to get more advanced, you can also turn on Wireless MAC Filtering from the Wireless configuration screen. Set the radio button to “permit only” and add your machine(s) to the permission list.

  • Alan

Unless there’s some really compelling reason to set a WEP, I set a WPA Personal Password. All I really want is for it not to be totally open… it doesn’t have to have crazy security. I have no interest in trying to remember some crazy, arbitrary cryptopasskey ever… the only goal here is really to keep my upstairs neighbor from freeloading, and a regular password ought to do that just fine.

Anyway, thanks again for all the help. Wifi is just so cool.

WPA > WEP

You’re safe.

Well done, DrCrypt!

So side story, semi related. I set up my wireless network a long time ago, then promptly forgot about it. We don’t really use it, the router I bought was on sale and also had wireless. It’s set with WEP 128 bit encryption so I just leave it on.

Anyway, like I said I pretty much forgot about it. Well my wife’s family came to visit a few weeks ago and her brother brought his laptop. So we’re all sitting on the couch and he whips out his laptop and tries to find wireless connections in the area. I casually say “Oh, we have one, I think it’s on.” Keep in mind all my in laws are sitting right there.

Well, when I set this thing up, I put in a weird name so I’d remember it when I saw it and I was sure it was mine. So he starts calling out names of the dozen or so in our area. I look at his screen and tell him “oh, it’s that one called linksys right there”. Of course he tells me I should rename it, because linksys is the default. I have to feign idiocy and go “oh, ok”.

What I didn’t tell them of course, was the real name of the network appearing in the list.

Yeah, so later after they left that night I changed it to “ournetwork”, something innoculous. From “dirtysanchez”.