LOTRO to relaunch as free to play?

I think LOTRO has been going for closer to 14 years. I say this because I logged in yesterday and found I had a gift for playing for 13 years. It is a cosmetic pet pig who hauls around a cute little wagon full of fireworks that shoot skyward from time to time.

I seem to recall the game had already been out for 9 months or so before I enlisted.

LOTRO celebrated its 13th birthday a few weeks ago. Launch from beta was April 24, 2007.

Taking my Warden through the Minas Morgul expansion content assuming that will go away at some point because it isn’t a quest pack.

I feel like my DPS is really low as it takes multiple gambit chains to take down a single common enemy. Like at least 6+ high damaging gambit chains with stacked bleeds. I feel it should only take 3 or 4 at most.

I can still take on around 3 enemies at once but I gotta go full life-tap, evasion, heal chain to keep my health up while slowly whittling them down with the occasional AOE light-damage blast.

And I have arrived

That place looks so nice.

Really crisp picture, even if it is blurred. I kinda like this “sort of pixelated” look.

It’s like Minas Tirith…but full of enemies. I’ve only gone up to the second tier of Minas Morgul but it got spooky. The first tier is just orcs. I am not sure if I was suppose to just storm passed the elite troll gate wardens to enter the city though. I feel like there should be another way in because fighting them will likely result in quick death.

I wanted to return there but I cant find the way, haha…

I’m in The Dale-Lands now.

This Carry all is so good…


Really is a shame the API can not access it thought, since the addon DAILY TASK is a must-have for anyone serious about tasks.

If I move the item outside the carry all I can use this addon.
image

Relaxing from the grind in the Dale-Lands.

Somehow LOTROs weather/water looks so much better than the rest of the game :)

Have tried multiple options to stop the pseudo-crashes - lowering to 32 bit client, adjusting lots of graphics settings including the resolution, lowering to dx9 from dx11, and always within 2-3 minutes of loading the game, and sometimes while at the character screen, it does a pseudoi-crash, where the system appears to sleep. It turns itself off and when I turn it back on everything is still running, including lotro. Very strange and I can’t figure it out. The fan runs like mad from the initial splashscreen, which is why I was thinking about heat, but at the lowesr graphics settings, the crashes still happen and the fan still runs like mad. Very odd.

Is it a mac running windows? My buddy had that problem playing lotro on his mac…fans would run like crazy. I think his was a desktop and I don’t think it went to sleep or anything, but he was always concerned about it.

It’s an Asus gaming laptop. Fans dont run like this in elder scrolls, conan exiles, the division 2, kingdom under fire 2, etc. Just LOTRO.

That is a strange problem for sure. I initially thought some kind of driver problem but I’d expect switching from DX9 to DX11 would have made some difference. Perhaps it’s some kind of conflict with another app that you have running in the background. Try disabling any and all background processes (anti-virus, mouse applications). As a hail mary perhaps update graphics drivers too?

Have you tried anything under Troubleshoot option?

image

Anyone else going through the Minas Morgul expansion? (free until Aug 31st but you need/should be lvl 120 to start)

I’ve finally replaced all my gear with Minas Morgul tier stuff which is nice. (minus my shield and LIs)

So I’ve cleared the first tier of Minas Morgul which is actually…a pain in the ass. Just super high density orc camp gauntlets. The saving grace is you get more activity in the zone since it is new and other players occasionally help clear out sections for you from time to time which makes it easier to progress but that is total luck.

The second tier is mostly spirit/ghost-shit which is actually a lot easier because the density is much lower, but there is an annoying bug. Once you exit the loading screen from the safe haven, enemies are already on top of you…my toon’s animations are static, there is no sound, but I can still actually attack and take damage, and still fight. This happens 100%; 10 for 10 every time exiting from the second tier camp…how did they let this happen?

Moreover they shouldn’t put enemies in the location where you spawn after a loading screen. WTF!

So, I’ve kind of jumped in with both feet in the last day or two, and am doing a little bit of relearning to play. (Virtues? Traits??) I’ve managed to get a Warden leveled to 17 in a pretty short amount of time, so they’ve definitely relaxed the leveling curve a lot. It’s also nice to not have to loot bodies anymore!

I’ve also kind of jumped in on Middle Earth lore again, too. It’s been maybe 25 years since I’ve re-read LOTR, so I’m doing that, too!

At any rate, the 99 LOTRO point expansions and FREELOTROQUESTS deal between now and the end of August is a seriously freakish amount of free good MMO gaming that’s just become available.

Yay! So glad to hear you’re enjoying it!

I love this game, and have sunk probably close to a 1000 hours into it, over the years, with my lifetime membership. I always do get bogged down in the same two areas - not being able to focus on ONE character, and doing waayyy too much crafting, which takes an insame amount of time.

Do any of you guys do a lot of crafting? If so, how do you avoid burning out on it?

If I can piggyback onto Razgon’s question: what crafting professions would be a good match for a Warden? Explorer for the leatherwork/armor and/or Woodcraft for the spears/javelins?

Are the 99 LOTRO point expansions and instance clusters live in the store yet? I was having all sorts of issues getting the store to even load over the weekend, and when I finally did manage to get it to appear last night there were no available expansions or instance clusters. It could just be that I already own them all, as I purchased the retail versions of Moria, Mirkwood, Isengard and Rohan when they came out. But I’m not sure if I own the Helm’s Deep content. There doesn’t seem to be an easy way to check what you own either.

They are!

And you’re right, there’s not an easy way to see what you own already. But per some guidance I found on Reddit and on the LOTRO forums themselves:

  1. Log in a character, even if it means creating one because all your fershlugginer characters are on a closed server and you may never get them back. (Grrr. Some day, hopefully!)

  2. Enter the game. Go to the LOTRO store in game.

  3. Start with going straight to the “Redeem a code” tab. Type FREELOTROQUESTS and it’ll give you every quest pack you don’t already own.

  4. Now go to Account and Content on the left side. Choose Expansions.

  5. It will show you the main expansion packs that you do not already own that are 99 LOTRO points to buy.