Medieval 2 : Total Frustration

I bought and loaded this game over the Christmas holiday. My system exceeds recommended specs, and it’s a clean machine, no spyware, junk apps and other stuff gumming up the works. I do this stuff (computer admin) for a living, so I know how to troubleshoot tech issues.

That said, Medieval 2 : Total War has got to be the most technically frustrating game released in a long time, even moreso than Oblivion. The first issue, right off the bat, was the copy protection not even allowing me to play the game. After install, any attempt to run the game, no matter what DVD was in the drive, resulted in “Please place the correct DVD in the drive”. According to the forums, this problem is widespread. I tried a couple of ideas found there, including updating the driver for my fairly new DVD-RW drive, and had no luck. I can only run the game with a cracked EXE, which means no online play for me for the time being.

Next issue to crop up was freezing/crashing in the very first battle screen. World map was fine, but shortly after starting any battle the game would lock up and not allow me to flip back to Windows. When I did manage to get an error message to appear finally, it talked about a graphics issue and reducing the levels on my graphics detail. My graphics settings had been pre-selected by using the “optimize for my card” choice in the Video Options menu, so these were what Creative Assembly recommeded for my very common graphics adaptor (6600GT). Still, I tried dialing back, to no avail. I updated the graphics drivers on my system, then updated the sound drivers on my system based on a tip in the TW forums, still no dice. Finally I set everything to LOW details and turned off all options, and it worked. I slowly moved everything up to MEDIUM and turned back on a couple of features, and discovered it was most likely either V-Sync or Vertex Shaders 2 causing the problem, with Vertex Shaders set to 1 and no Vsync I can now play in the battle screens without crashing.

Both of these technical issues came in addition to the usual “beta retail” complaints of shoddy AI and horrific unit pathing that are now standard fare on so many strategy games these days. Up until now, Creative Assembly had seemed to avoid these types of things, both the original Medieval and Rome Total War were relatively painless to install and play. It’s a real dissapointment to see this game so plagued with technical issues, many of which seem unsolveable for the average gamer (many folks on the forums are still complaining of CTDs and battle lock ups despite playing on lowest settings). I myself have not been able to fix the “insert correct DVD” problem without resorting to a cracked EXE.

It’s a shame, because otherwise Medieval 2:TW is a fine game, every bit as good as Rome:TW and it’s predecessors. I’m really enjoying it now that I can run it, even with the bad unit pathing and brain-dead AI. Add this game to the list of recent releases like NWN2 and Dar Messiah of M&M that should have been QA tested a bit harder before release.

Got mine off Steam, had no problems.

Vertex Shaders crashing might be a sign of your card going bad rather than the game.

Domed!

(Yup, I said it again.)

I’ve had technical issues with every Total War game I’ve ever bought. I always run into goofy incompatibilities with hardware or software. Shogun would have issues if I had WinDVD installed, etc.

That’s the insidious part. A full 50% or more of the posters to the Total War forums related no problems at all, including people with lower end systems (as far as recommended specs go). The other half have reported everything from the DVD not present glitch, to the battle freeze ups that I experienced, to black screen lockups during play, to random CTDs in both strategy and battle screens. It’s not enough that the game will get routinely dinged by reviewers for being buggy, but it is too many people to dismiss with simple “we can’t test on every platform” excuses.

That said, from looking at various forums I’ve gathered that the game seems to have consistant problems on systems using Geforce 6600 series cards (like mine), so it could be something in the way instructions are coded that the 6600 chip simply doesn’t like.

Well, also consider 6600s have the instructions to run 3.0 Shader but not the horsepower and Medieval 2 is more graphically complex than Rome.

This isn’t necessarily the answer, but it’s my suspicion.

hmm dont know, every total war game did run on my three different pc´s over time right out of the box…

The only bugs that i ever did encounter where ingame bugs (like inf getting killed from missile fire without response)

Your suspicion is most likely correct, as that seemed to be the solution to my problems (dialing back the shaders). The game still looks fantastic, even on Medium settings and lower shaders. My issue with the DVD copy protection remains though, and it appears there is no current workaround for most folks who are also expriencing it aside from a cracked EXE.

My real point in venting (aside from feeling better) was to highlight that yet again a mainstream game hits the market that has a significant number of people who experience technical issues installing and playing the game (ala Dark Messiah, NWN2, Oblivion, etc.). The average Joe isn’t going to know to dial back shaders, hit GameCopyWorld for a cracked EXE or do anything besides maybe look for updated graphics drivers. I know PC Gaming will never be “out of the box” like console gaming is, but as long as it’s this challenging to get mainstream games to run on the average system, it’s going to turn a lot of people off Games for Windows.

Speaking as an Average Joe, Jimmy and Jane Sixpack, and the rest of us slackjawed troglodytes out here…I agree. I haven’t bought a new PC for 5 years and do my home computing on a used Mac laptop.

I love PC gaming, but I cant keep up with the cost - $2,000 for a new(soon to be obsolete) PC vs $400 for a 3sexy - then slap some technical difficulties on top of that…fuggitaboutit.

That being said Medieval:TW (the last one I was able to play) was the shit.

Strange question:

In one (and only one) of my saved games the campaign map UI has been “disconnected” or no longer responds to my clicks. What i mean is that in every other saved game, or in a new game, everything works as usual, i can mouse over the “End Turn” or “Finances” buttons, which are then highlighted, and click them as usual.

In one game however, the UI no longer responds to clicks. I can select and move units in the map, but i cannot click the End Turn/Diplomacy/Finances buttons. I can mouse over them, they are labelled but NOT highlighted, and no amount of left or right clicking will activate them. I can’t end the turn, because there is no end turn hotkey…

I must have accidentally hit some strange combination of keys that disabled it somehow. Anyone have any knoweldge of this strange occurance?

Try hitting Enter.

It ends the turn on Shogun and Medieval 1, I’m positive.

If you can find a machine for $2000 that obsoletes quickly then you’re just wasting your money, not seeing the true state of the PC market. I’ve never had a gaming PC that didn’t last four years.

So, that’s you. I used to make my Windows boxes last four years, by updating the gfx card or expanding the RAM, but the last year of that term was pretty ugly with me needing to dial back graphics options and put up with lousy framerates. Added to which, every single Windows install I ever had would start to bog down after a year or so, and the best thing to do with it was wipe the drive and start over.

  1. I’m not interested in doing any maintenance at all - I don’t want to have to crack the case and fuck about with the innards. (My law of home repair is Appliances With Moveable Bits Will Trap Your Fingers.) I don’t want to go on a driver hunt every time I install a new game, or prowl message boards trying to decode some impenetrable error report.
  2. I feel like ‘wasting my money’ was paying 2k for a Windows machine and then paying $50-$70 (CDN) for games that don’t work as I expect them to out of the box.

I too, love PC games, and have had almost all of my most transporting and memorable gaming moments sitting beside a Windows box, but I dumped it because, for me, the cost/bugs/maintenance headaches far outweighed the gaming goodness.

Partly I was spoiled by the NDS, which was my first Non-PC system in 20 years. After a few months of popping in a game cart, just playing, and knowing I was getting the exact same graphical experience as everybody else, I wondered what the hell I was doing, giving myself migraines, trying to get TOEE to, you know, run.

Six months after we got a couple of NDS systems, we bought an Xbox 360 and that was that. We donated our Windows boxes to a local youth group (leaving us with our Apple desktop systems, which we’d been using for a decade) and haven’t looked back.

Everytime I find myself staring longingly at a PC game - like M2:TW, or NWN2, or Dark Messiah of Might & Magic - I bump into a thread detailing all the nightmares people have had trying to get a decent experience out of those games. Ugh. It’s not for me anymore.

You’re not missing much on multiplayer ;)

Slainthe, if you want you can probably get away with creating an image of the cd with alcohol and mounting that. Then you wouldn’t need a cracked exe.

I remember something about the registry key… didn’t have this problem myself, but a friend did and this worked:

>>>
Quote:
You’re getting the error message:
“Login failed - invalid CD-key”

Right this is how to resolve (with thanks to various posters)
You cannot change the cd-key ingame anymore (most likely for the protection against illegal games), so you have to do other things.

Open Start
Click Run
Type: regedit
Now go to this: “HKEY_LOCAL_MACHINE/SOFTWARE/SEGA/Medieval II Total War”

Now you’ll see a value representing the CD-key. Change it to what it should be. You could have done the following wrong:
-Don’t type spaces
-Do type the "-"s
-Don’t use "o"s use "0"s
-Type everything (except for the numbers obviously) in capital letters


Anyway, Medieval 2 is a badass game… keep plugging away. I assume of course you’ve patched it to the latest, very playable version?

I disagree with Wisefool, multiplayer is a blast. Tactical, tense but perfectly short games. For a nice change try an all gunpowder game.

Tried it, doesn’t work.

Have tried holding various combiantions of Alt, Ctrl, Shift and hitting every key on the keyboard without success.

Metta,

Understand the frustration with PC gaming. I just purchased Jade Empire:SE, and find that it’s completely bogged down at unplayable framerates. This despite a beefed up system with a GeForce 8800 GTS that runs Oblivion like butter. Worse, when I posted to the Technical Support forums at Bioware, there has been no response for weeks.

So that’s my “I feel your pain, brother” story.

However, PC gaming (when it works) still provides amazing gaming like nothing I’ve ever experienced on a console.

Case in point - I’m just coming off 2-3 days of “gamelock” playing Medieval 2 using the 1.2 patch, the Lands To Conquer 2.3 mod with Klink’s garrison script. This has been the most intense and consistently challenging strategy gaming I’ve played in a long time. I’m playing as the Byzantines and finding it both an extraordinary strategic challenge (in a good way!), and also beautiful and mesmerizing to watch the real-time battles using the updated graphics engine. I was really frustrated with M2TW when it first came out with all the bugs and the poor gameplay choices by Creative Assembly in their initial vanilla product. However, the 1.2 patch and the use of a few key mods has completely transformed the game and made it a great experience.

That’s why I keep coming back to PC gaming, despite the occasional frustration like Jade Empire that makes me dream of switching to consoles for good. ;>

Chris

But that’s shitty ports, not a PC problem. PCs are surviving longer than ever these days because engines are becoming more scalable and FPS games, typically the most demanding PC games, have been few and far between. I’ve been gaming on a Radeon 9800 Pro and equal tech since it came out, and I’ve had no problems.

The only reason you’re upgrading is because you want to, not because you need to.

Can we post some recommendations on which mods should be good to download seeing as how people seem to be very happy about patch 1.2?

I stopped buying Total War games after Medieval 1, which I couldn’t get to run on either computer I owned, and after Shogun refused to run with WinDVD installed on my computer. The company has no clue how to get decent compatability out of their games.