Memory woes

Doing a bit of a budget upgrade to take the XP 2000 up to an XP 3200 and the 512mb fo 2100 memory up to 1gb (2x 512mb) DDR400.

CPU is fine and individually the two DDR400 modules seem stable. However when I run them both together either in single or dual channel mode Windows gets to the splash screen on startup and then reboots.

The Geil site (the memory I’m running) has the following suggestion for this:

Q: Windows recognizes both modules separately but not together.
A: In windows select the start menu, select run, type MSCONFIG, hit ok, select the advanced tab at the lower right corner. Now find the option that states “Limit memory to” and uncheck it. Reboot and the system will reflect the proper amount of memory.
However this option doesn’t seem to appear on the Windows XP msconfig.

I’m running on an Asus A7N8X issue 1.04 with Bios version 7 which should work as far as I can see.

I’m not trying to overclock and am running stock “auto” settings on the Mobo. The only thing I have set differently is to up the voltage on the memory to 2.8v as suggested by Geil.

Any suggestions?

[edit] found the option it is referring to (boot.ini) and that option isn’t/wasn’t set.

AFAIK, auto just reads whatever they programmed on those chips. Sometimes the chips are just marginal. You could up voltage a bit (don’t recommend).

I’d recommend running the 2.8v, and more relaxed timings than the defaults. Run memtest86 a few hours and test stability.

hmmm, it’s not looking good for the memory. both lockups and failures running memtest. Stuck the old memory back in and it checks out fine so I think I can eliminate the Mobo as a possible problem unless I’m being wildly optimistic expect a 3 year old (but compatible) Mobo to step up from 133 to 200mhz (shouldn’t DDR400 be detected as running at 400mhz?)

200mhz is the correct answer, which is what I run the DDR Ram in my A7N8X mobo at.

Nuts, looks like I have a gig of knackered memory then.

Do the timings differ on the seperate sticks? Can you loosen the timings and check it then?

I have an nforce2 box where its fine with one stick in, but I have to loosen the timings before the second one goes in or it won’t even boot.

Is that the 2.5-6-6-3 bit on the dimms? They’re a matched pair of 512mb DDR400 from Geil. I’ve not touched those settings at all, and forgive the question, how would I loosen the timings? The Mobo is an Nforce2 board.

My concern at the moment is that neither module on it’s own passes a memtest sweep, it either crashes or reports errors. the package they arrive in had been resealed by the courier company so I’m wondering whether it got played football with in transit.

They’re also second hand from a friend who’s offered to refund for the memory so at least I shouldn’t be out of pocket.

In the BIOS there should be options to change those, depending on the board
and yes, those are the timings.

ok, I know where those settings are and how to change them, but is there any preferable method to loosening the timings?

ie do I change one thing first from 3 to say, 4, reboot and see what happens or do I need to change the whole lot in one go to keep things “in sync”?

Don’t know the technical stuff but I think the CAS (2.0, 2.5 or 3.0) seems independent of the others. You could try upping CAS first. if that doesn’t work then increase each delay by a notch. I think if you look around you’ll find the delays tend to go in patterns.

  1. Normally, only matched pairs work well at high speeds. Unmatched pairs should work too, but even in your quasi-dual-channel-mode, may need reduced speed.
  2. Some generations of motherboard chipsets (and CPUs, for Athlon64), can only support a single module at 400 MHz; with more than that, 333 is the max.
  3. Double-sided and single-sided dimms are different for these calculations.

In any case, the more modules you have, the less identical they are, and the more sides they have, the lower your top clockspeed will be. You may want to check your motherboard chipset information to see if it even supports multiple dimms at top speed, and if so, which configurations are allowed. Otherwise, try at low speed with manually-set low timings to see if that works.

No generations of Ath64 only support one stick at 400. I have the first generation…

It’s single SIDED modules. Recommended is to only use one double sided module at 400 (I use two double sided at 400, myself, so it’s not a hard and fast rule, just a recommendation.)

If you’re going to use multiple sticks, they’re supposed to be single sided. But they can all be 400mhz.

(Maybe you meant what I said, but you confused me so hey.)

Yes, those are the memory timings. Here’s an article running down memory timings. I had an A7N8X Deluxe myself at one point. I would recommend going into your BIOS, looking for the memory timings section, and changing your memory timings to, say, 3-7-7-3: i.e., increase the timing numbers.

You might also have a bad DIMM slot: try running MEMtest with a single DIMM to test the first slot, then move it to a different slot and retest, then again to test the third.