Mic problems

When I use my mic in vista 64 I can here myself talk and I can’t find a way to get it to stop. The only mic controls I can find is on, off and volume, oh and concert hall sound effects. This becomes very annoying because not only do I hear myself but every other damn noise that is being made. My current sound card is a USB2 X-Fi 5.1. I like the card overall but this mic thing drives me crazy. Any ideas on how to get it to stop.

  1. click the volume icon on the task bar
  2. click options, then properties
  3. find the box for microphone and check it
  4. close that window
  5. find microphone in that window
  6. press “mute”

If this fixes it, you owe me $0.05.

  1. Right-click the speaker icon in the Windows Notification Area
  2. Click Playback Devices.
  3. Right-click Speakers as click Properties from the shortcut menu.
  4. Click Levels tab.
  5. Locate the Mic or Microphone slider, and then click the Mute icon next to the slider.
  6. Click OK.
  7. Click OK.

My $0.02

  1. To the extreme, rock a mic like a vandal.
  2. Light up the stage.
  3. Wax a chump like a candle.
  4. ??
  5. Profit!