Monitor won't wake when PC does from sleep?

OK, I’ve never run into this one. Basically, if I let the (desktop) PC sleep, when I come back and wake it via the space bar, I hear the PC come on, the power light goes solid and all that, but the monitor doesn’t get a video signal. Weirdly, what will actually turn it on is pressing the PC’s reset button for just an instant, at which point suddenly the monitor shows the lockscreen immediately. The PC has clearly not restarted because it hasn’t had time to, I haven’t seen the “Press Del or F2 for setup” message etc.

Things that have recently changed and not changed:

NOT changed: Nvidia drivers – sleep and wake were working fine after last update of those.


  • Updated BIOS to latest one for my ASUS Z170-A motherboard.
  • Swapped out a smaller data HDD for a larger one and cloned the old volumes to the newer HDD, creating a large extra NTFS volume with the remaining space. Used GPartEd Live CD for all that.
  • Installed latest Windows 10 updates of this week for build 1909.

Any ideas?

I’ve got a dual-monitor setup and recently upgraded to a 2070super. Ever since I’ve had sporadic problems with one of the signals as well (displayport). A work around seems to be to unplug the monitor, wait 1-2min and then plug it in again. Then the PC IDs the monitor again and the signal comes through.

A few others mentioned similar problems @YakAttack & @marquac - not sure if they found a solution yet?

I think that’s a driver issue, it actually happens all the time to me at work, but the monitors at work are generic and I can’t find an updated driver for them. It’s something about Windows 10 sleep state compatibility, but I’m afraid I never really dug around for a good solution yet. I just unplug power to the monitor, wait a beat, and plug it back and it comes right back up for me. Annoying, but nothing I really think about more than once or twice a week when it happens.

The problems I was having occurred after a cold boot. Sleep and restart did not exhibit any issues.

I think I solved the problem by switching from DVI to HDMI, although I gave the PC away and have barely used the machine in months.


I think I swapped the PSU too. Not sure.

Mine is connected via Display Port since it’s a 144+ FPS one.

Changing the default Hybrid Sleep to regular sleep in the advanced power options seems to have fixed it. With as many people as boot off SSDs these days (myself included), I’m rather surprised that Hybrid Sleep is the default, honestly.

I spoke, err, wrote too soon. The problem is still happening even though it never happened before the recent BIOS update. Very briefly hitting the PC’s reset button seems to fix it though. Don’t ask me how that works. I thought touching that meant reboot in all cases, and clearly the PC is not being fully rebooted.

Do you only have the one monitor hooked up to your PC, or more than one?

Just the one. Guess I could see if the card has more than one Display Port, in case that’s the problem.

Are you using onboard video or an external card? If you have both you could swap them temporarily.

I’m using my installed graphics card, not the onboard video (which my processor does support). Honestly the problem is easily resolved enough (via that strange reset button hack) to not want to be unhooking the cable from the back of the PC, especially since the onboard graphics suck for games.

I just can’t figure out why replacing an HDD and updating my BIOS could have changed the normal “wake from sleep” behavior. Maybe the monitor is starting to go south. Or it could just be an Nvidia driver issue-- that seems unlikely, though, because I last changed those before replacing the HDD or updating the BIOS, and never observed this.