msvcr120d.dll not found

Trying to do a little Rome 2 modding and the editor is giving me this message, “msvcr120d.dll not found”. I know it probably comes from a vbasic redist, but which one, and is there anything special I need to do after a manual install if that’s even it?


That’s maybe a bit too specific for someone here to be of help - have you tried some sort of of Rome 2 tech support?

I googled “Rome 2 msvcr120d.dll” and came up with this:

Generally, in my experience, missing .dlls just need to be placed in the relevant directory, nothing additional is needed afterwards. I don’t know about this specific dll though, it’s possible that it’s being missing is just the tip of the iceberg of missing dependencies. There’s really no way to know until you try though.

I had done all of that and it didn’t fix the issue. Surprisingly, even after following MS’s MSDN notes, it still wasn’t installed anywhere on my PC. The other solution the Internet had provided was to download the dll off some random website. No way!

However I got lucky! I asked one of the few remaining modders of Rome2 on one of his updated mods and he told me all I needed to do was copy the msvcr120.dll and add a "d’ to it (SYSWOW64 dir). It worked!

That’s terrible. The ‘d’ is for the debug build. I mean, it’ll work as the entry points are identical, but it’s much slower and it makes me wonder why they shipped debug libraries with the game.


Beware that link. A post in broken English by a new account that read 6 posts in 3 minutes and then posted a link to a suspicious looking site that looks like it was put together in 10 minutes? Yeah, totally not a bot / scammer.