My PC goes to hell (help!)

In the past ~2 months, my comp has experienced every kind of crash in existence (except, ironically, BSODs). From the top:

occasional, random restarts during POST at startup

Errors at bootup (at the blackscreen during POST):
"CMOS/GPNV checksum bad

  1. Run Setup
  2. Load defaults" (or something like this)
    -and-
    “CMOS Battery Low
    CMOS Memory Size Wrong” (these two errors may have appeared together during POST - can’t remember)

Random restarts while using Windows XP. These have occured while clearing web browser history, when using web browser (Slim Browser), and at other times. I’m sure the restarts have also occured during game usage, but I can’t remember any specific incidents. Even occurs when scanning with Adaware.

Freezes. The screen will freeze right up when I’m playing Guild Wars after ~1 hour (or, once, as soon as I logged my character into town). It consistently freezes up after playing Neverwinter Nights Platinum for ~15-20 min (every single time I play the game. requires ctrl alt dlt to quit with the following Event Log error: “Faulting application nwmain.exe, version 1.6.5.0, faulting module nvoglnt.dll, version 6.14.10.7189, fault address 0x001f9a48.”). It also freezes when I play Unreal Tournament 2k4. The comp has also freezed once or twice when I’ve been using Slim Browser. Additionally, the comp apparently freezed when I was running Advanced Scan with Hitachi Drive Fitness test in DOS mode booting from floppy (testing my IBM Deskstar hard drive - Hitachi handles support now). This happened just a few hours ago. More incidents that I can’t remember have probably occured.

Quitting with a memory error (you know, "this program quit with memory error at location 0x000005 whatever hex address - send error report/don’t send error report). This happens consistently with Slim Browser after ~30 min - 1 hour (Event Log: “Faulting application sbrowser.exe, version 3.9.1.0, faulting module sbrowser.exe, version 3.9.1.0, fault address 0x00061851.”) Warcraft 3 after ~10-15 min, and Guild Wars (very occasionally) anywhere from ~5 min - 1hour 15 min (most Guild Wars probs are freezes that require ctrl-alt-dlt). The error says something about a problem at memory location 0x0500000 or some such hex address. Interestingly, I get this same error frequently when I quit Slim Browser manually. As soon as the app has closed, I get the box with the memory error and the typical options of sending or not sending an error report to MS (like that does any good). Halo PC will quit after an hour or so of multiplayer with its own, unique quitting errors (found in the event log, presumably some variant of the memory error box quitting:

“Fault bucket 200202694.”
-and-
“Faulting application halo.exe, version 1.0.7.613, faulting module halo.exe, version 1.0.7.613, fault address 0x000f1271.”

Whew. That’s all the shit I can think of for now. I’ve done many things to try to deal with this. I recently replaced my 2 year old 512 MB Mushkin PC 2700 stick with 2x Crucial 512 MB sticks. I did this because Memtest 86 indicated an error with test 5. The error went away, but the problems persist. Scandisk, defrag, diskcleanup, Adaware, AVG scan, Spybot, etc. Interestingly, Defrag takes freaking forever. I let it go for several hours, and it didn’t move beyond 11% or so, so I canceled it. Heat/electricity is not an issue, at least according to my BIOS heat monitor and Hardware Doctor, the software heat/voltage monitor I use. I reformatted and reinstalled 2 weeks after the probs began. Didn’t help much at all. Replaced the CMOS battery when I got the relevant POST error mentioned above. Cleared CMOS multiple times. Both of these helped temporarily… Scanned and attempted fix using my HD diagnositcs utility (Hitachi Drive Fitness). Freeze at 50% advanced scan. Found a bad sector. Not yet able to fix b/c of freeze. Somehow I don’ think this is the cause of my woes, but I think it is a symptom.

I’m just not sure what to do. Bottom Line: the time I spend on my computer is dictated by the crashes. Can’t play NWN/WC3 ever for more than 15 minutes due to the crashes. Guild Wars is doable but unpredicatable. Same with internet/Slim Browser. I don’t decide how long I use application XYZ on my system, the crashes do.

My best idea at this point is to replace my mobo and video card. Seems like memory controller on mobo is faulty or something.

System specs: (this thing was built in summer 2k3)

Abit SR7-8X mobo
Pentium 4 2.4GHz Northwood processor (533 mhz FSB)
2x512 MB PC 2700 DDR SDRAM (Crucial)
40 GB IDE hard drive - 7200 RPM (IBM Desktar)
MSI GF4 Ti 4600 8x w/ latest NVidia drivers (interestingly, my machine thinks it’s a Ti 4800. Maybe I got the wrong part when I ordered, never checked)
onboard sound
onboard NIC
Windows XP Home SP2 and all other updates from Windows update
latest BIOS and mobo driver updates installed from sis and Realtek sites.
Am I missing anything?

This is a whopper of a post. A bit sloppy, too. Most grateful to anyone who reads all this and responds.[/list]

When I have odd hard to diagnose problems like this, I start troubleshooting by opening the case and methodically taking every part off and then putting it back on. Everything: memory, cpu, fans, video cards, all the power molexes, hard disk connectors, the main plug from p/s to motherboard, just everything. Sometimes something just works itself loose. I had one of those Slot 1 motherboards with a celeron and an adapter dohickey come loose just enough to give me tons of random screen freezes and the occasional reboot during start up. Reseated it and all my problems were solved. It’s as good a place as any to start.

When I have problems like this, I use it as an excuse to buy me a new rig.

It definitely sounds most like a memory error of some kind. If you have free slots, I would suggest vacating the slots the memory is in now and using the others. You might have to cut your memory in half if you only have a 3 slot board (pretty sure that’s going to be 4 slots, though). Frankly, other than that there’s not a whole lot that’s jumping out. It could be a fucked up cache on your processor, but your errors would probably happen more frequently than what you’re describing.

I recently had a memory error situation in which Memtest86 passed everything, but the issue was one with my chipset (it’s an NForce 2) – you can only run in dual channel mode if you have the FSB set to 333 (or a little higher, but 400 causes errors)… The pentium board shouldn’t have any strange issues like that, but you might want to check around on Abit’s forums for issues with that model of memory with that board.

Yeah it’s probably with the motherboard, loose solder somewhere. Just buy a dell, they’re crazy cheap. Not worth the time debugging.

It’s probably just that you’re a bad user. Get a new person to use the computer.

I’ve found that a bad power supply can cause all kinds of errors you wouldn’t normally think could be attributed to it. If you’ve already tried swapping mem sticks, maybe try a different PS?

I try to use this sort of logic in all my affairs. You are a bad wife/son/daughter and if you don’t soon straighten up, I’m going to have to look for a new wife/son/daughter/girlfriend.