Nasty .Net problem

I had a strange BSOD where upon rebooting Windows I recieved an error dialogue box “CLI.exe .Net framework initialization error” . After investigating the problem it turns out everything that relies on .Net Framework isn’t working, namely my ATI drivers.

I’ve tried uninstalling the .Net Framework and reinstalling it through both the Windows online update and the WinXP CD itself but both methods failed. I also tried a System Restore but that didn’t resolve the problem either.

Any ideas?

Running Windows XP SP2.

There are 2 versions of the framework, 1.x and 2.x. You may just be missing one or the other. Are both installed?

AFAIK I had both versions installed but I was able to repair the problem by runnin dotnetfx.exe on the WinXP CD. Everything seems fine right now knock on wood


CLI.exe is just the Catalyst Control Center doohickey part. The main drivers themselves should be working fine.

Maybe redownload and reinstall the ATI drivers, with an uninstall (add/remove programs works well) first? Have you tried any other .net apps?

Yeah I tried uninstalling/reinstalling the ATI drivers but it didn’t work and I don’t know of any other programs installed on my machine that use .Net. I started sweating bullets for a bit as I never encountered this problem before but my machine has been running fine since I ran Dotnetfix.exe and followed up with a reinstall of .Net v1.x and v2.x