NIC not responding

Dell XPS 1710 notebook. Posted this on their support forum, but it is less than responsive.

For some reason the internal network card seems to not respond when an ethernet connection is plugged in. The little icon in the systray is there, with the red x, saying a network cable is unplugged, the Broadcomm test says the hardware is funtioning, but it acts as if it has been put into sleep mode.

Another piece of data - the utility that comes with the Dell (Quickset) has a power management option that will turn off the internal NIC when on battery power if you set it that way. So I’m used to a little message coming up saying “battery power - internal ethernet card disabled” or some such when I unplug the notebook. Then it comes back on when you plug it into the power cable. It was giving me that message yesterday, then stopped at the same time the problem cropped up. When I bring up that utility, it shows the NIC status as “Off”. I’ve tried disabling the utility, reinstalling drivers, etc. but it is just as if the board has been powered down and I can’t get it back on.

Any wild ideas on what else to try?


To rule out naughty software, perhaps you can see if this same thing happens when you reboot the laptop into safe mode with networking support?

Sorry - XP.

Wireless works fine, fwiw. But I have a need for ethernet wired connectivity

the notebookreview forum is very active.

Can you re-enable the NIC in the quickset utility?

Failing that, safe mode with networking support seems the best way to test the function of the NIC without actually reinstalling the OS.

Type the following into a command prompt:

netsh int ip reset c:\resetlog.txt

This command resets your tcp/ip to default. I have been running into this exact problem a lot lately on the newer Lenovo laptops and this has fixed it every time. The resetlog.txt is just an export file of what it did.

If this still does not correct the problem, MS has a very long KB article for such issues here..

I assume you’ve tried updating the driver and uninstalling and reinstalling the device in Device Mangler, right?

I TOTALLY thought it was going to be the “turn NIC off when on battery power” problem, because I’ve seen that SO many times, and nobody knows it’s there…but you were up on that one.

The above suggestions sound promising. Let us know.

Tried what Cat Master suggested, and no help.

I thought.

The next morning (and I’d rebooted two or three times after running the CMD line) it was working fine. So I’m not sure exactly what the problem was, but it seems to be working fine now.

Thanks for the help guys.

That’s… odd. Unless you use a docking station, reinstalling the adapter would be my only suggestion if it happens again, assuming the Event Viewer doesn’t tell you anything.

It was odd - no docking station. It’s almost as if the power management turned it off, then never turned it back on. Even though I did all the standard steps - updated the driver, uninstalled it in the device manager and let Windows reinstall, etc.

I’ve been talking with a client who has had this problem lately on his PC and the above command fixes it, but it pops up again after he installs Skype. Anyone here with Skype and an IBM laptop run into this sort of thing?