My MP3 player is also a plug-and-play USB 2.0 hard drive, but as of very recently it crashes my computer when I plug it into a USB 2.0 port. A USB icon appears in the system tray and lingers there for a few seconds, and then the computer blue-screens with a message about NO_MORE_IRP_STACK_LOCATIONS_AVAILABLE for a few seconds, and then the computer restarts. If I don’t unplug the MP3 player, the same crash occurs as soon as the restart is finished. I tried all four of my 2.0 ports, with the same result.

If I plug the MP3 player into a USB 1.1 port, however, the USB icon appears in the system tray and lingers, which isn’t normal, but then the drive mounts and everything works fine, other than being 1.1 slow. Operation of the player is normal in all other respects.

I also have another plug-and-play hard drive, and it still works fine, in the 2.0
and 1.1 ports alike. I tried using the USB cable from that drive with my MP3 player — no dice.

I Googled the error message, and the message board discussions that resulted were all among programmers — nuts-and-bolts stuff about higher - and lower-level drivers (not specifically for hard drives) appropriating the wrong number of input/output stacks, or something like that. Here’s one where someone had the same error with a printer. He fixed it by eliminating (?) a “filter” from the registry…I don’t have the knowledge to really follow the explanation, but I was hoping someone here might.

[edit]Oh, I also tried updating drivers for USB 2–related things in the Device Manager. In all but one cases no better driver was available, and the one case didn’t seem to make any difference.[/edit]

Recent changes to my computer include: running CrapCleaner (which I know messes with the registry), uninstalling Norton AntiVirus, installing and uninstalling Avast, and upgrading to ZoneAlarm Security Suite.

I’d appreciate any help y’all can offer.

Yeah, that’s messed up.

  1. If you got software with the MP3 player, load it again.
  2. Go to windowsupdate.com and add anything it says you need.
  3. Go to windowsupdate.com and look at the stuff you’ve installed already, and reinstall anything that has to do with USB 2.0

Thanks for replying, Tim. No software with the player — strictly plug and play. Nothing USB 2–related in my installation history. The only thing Windows Update wants me to install is Service Pack 2, which seems unlikely to help…?

This morning one of the USB 2 ports is working with the player, but it’s only functioning as a USB 1.1 port. I got a warning when I plugged it in that I really ought to use one of my USB 2 ports (sigh). [edit]And I tried my other USB HD again, and this time it got the error, so I guess I was just lucky the first time I tried, and the problem isn’t specific to the player at all.[/edit]

Anyone have any ideas about the registry/filter thing described behind the link above?

Ok, check if there are any updates for your motherboard. If Microsoft doesn’t have anything for you, maybe the people who manufactured your motherboard can help.

SP2 can’t hurt.

Sounds like a buggy device driver. Here’s what Microsoft has to say about it (geared towards driver developers, but hey).

I’d make sure you have the latest USB drivers for your motherboard.

Sounds good; I have a Soyo Dragon Ultra Black mobo, and here is a USB driver for it. Should I be concerned that it says Windows 98SE?

[edit]On the download page itself, it says Win98SE/Me/2000. I’m thinking 2000 probably means it’s fine for XP Home?

Actually, looks like you want the ALI integrated driver from Soyo (SY-K8USA drivers page).

Specifically, this guy.

If you’re using Serial ATA RAID, I’d grab the latest one o’ those also. Heck, same with the audio and LAN drivers :)

I clicked your link, and it looks like it’s talking about a different board; double-check the actual model number (rather than just the “Dragon Ultra Black” moniker) before you try any of 'em.

And I’d go with the stuff from Soyo before I’d hit the 3rd party driver sites.

I think the SY-K8USA Dragon Ultra Black is the successor to my mobo, the SY-KT333 Dragon Ultra Black (kinda dumb of them to change the number and keep the name). The Soyo file for USB matches the one I got off DriversGuide, so that’s a confidence booster. I’ll try it when I get home. Thanks! :)

If you haven’t, make absolutely sure to install the VIA 4-in-1 driver at the top of that list. That may take care of your problems all by itself, as it’s the base driver for the motherboard’s core chipset.

No good. Tried the USB driver first, then the 4-in-1, then SP2 and reapplied the USB and 4-in-1 just in case they’d work better under SP2. Same insta-crash when I plug in a USB 2 device.

Any other ideas, from anyone?

Well, here is an old Indian trick I know…

Use Device Manager to uninstall all the crap under the Universal Serial Bus controllers node. Restart your computer. The computer ought to automatically reinstall all the USB stuff. Hopefully whatever driver file is corrupt will get replaced with a working version during the reinstall.

It’s desperate, but if it doesn’t work, it looks like a reinstall of Windows is in your future anyhow.

Just to check before I try this, Tim — the Indians would uninstall the devices themselves, or just the drivers for the devices?

OK, after poking around the XP help files a bit I realized that uninstalling the device and uninstalling the drivers were the same thing (there are two ways to uninstall the drivers in the Device Manager, and only one says “Drivers”; also, I’m a dumb-ass), so I implemented Tim’s old Indian trick and it worked. Thanks to Tim and Andrew fo’ yo’ he’p.


To get that tip, I had to listen to a lot of cowboy and indian jokes where the cowboys never made out too good. :)

Tim gets the points though, since his tip was what won it :)

Post made for information’s sake, in case anyone has this problem in the future and Googles this discussion:

It turns out to have been a temporary fix. I lived with the problem for a few more days, and then closed my eyes, sank my ch’i down into my t’ang t’ien, and meditated upon the problem. After some time, a still, small voice seemed to say, “It gots to be th’ ZoneAlarm upgrade, bitch!” So, without leaving my trance, I Googled “zonealarm irp stack” instead of the entire error name, and found that different antivirus software has caused this problem occasionally with my mobo, and that it can supposedly be fixed by editing IRPStackSize in the registry. I followed MS’s recommendation to increase that variable in increments of 3, and I made it to 24 before I got bored and just uninstalled ZoneAlarm. Problem solved. Then I installed Avast and reinstalled ZoneAlarm, patching it up to the point just before antivirus capabilities were added and the USB problem introduced.

Maybe over the long weekend I’ll see if I can switch off the antivirus function and thus have a fully functional ZAP without screwing my USB; if not, I guess I’ll just switch to the free version.

Tim gets to keep his prize points, though, as long as he uses them only for good.

Crap, I just applied all my prize points toward a lap dance at the local BurgerMaster, which has to be more evil than good.