Noob with soundcard and ventrilo problems

I just rebuilt my computer to put in a new cpu and increase the RAM. The current system is as follows:
[INDENT]Gigabyte GA-965P-DS3 rev.3
4 G G-Skill RAM
Creative Audigy Xtremegamer sound card
Windows 7 Home
Sennheiser wired headset + mic (non-USB)
[/INDENT]The problem is with Ventrilo, though I think I may also have less issues in TeamSpeak 3. I hope the collective wisdom of q23 can help.

If I am playing a game and using Ventrilo, I can hear others, but others can’t hear me. If I alt-tab out of the game so that Ventrilo is on top, then they can. They can then hear me for about 2 minutes once I get back into the game.

I have a similar weirdness using TeamSpeak 3. Instead of others not hearing me, the actual ingame sounds start to fade away. However, I can talk with other people without any problems.

I’d used both programs under WinXP. For this build, I used Win7 Home. Also, this is the first time I’ve used a soundcard, and I wonder if there is any weirdness with the particular model. I bought this card about 2.5 years ago, and never installed it. I know that people complain about Creative cards, and perhaps in my ignorance I got a buggy model. I wouldn’t know.

Anyway, any ideas? I’ve tried to set all programs to run as administrator. When I test my mic in Ventrilo, the mic test sounds fine, so I know the mic is working. From my perspective, it is as if something in hardware or software is trying to regulate the priority of voice v. game, and failing miserably.

You probably have some incredibly stupid soundcard ‘utility’ interfering there.

Is the input in Ventrilo set to the mic? I know you can use the “default” input but you can also explicitly pick the device you want to use.

Also, I’ve had issues in the past where my Windows microphone setting (one of those vertical slider bar thingies) was set to 0%. I would tell you how to get there but I can never remember - I have to open up all sorts of control panels and sub panels and eventually I usually find it.

Just get a USB headset. So much easier.

I’ve checked to see if the mic is the input device. It is. Also, the mic is selected as the recording device on Win7, so I think all is good there. Some research on teh interwebz suggests that I fiddle about with default device or specific sound card. Since the default didn’t work, I’m now trying the specific device.

I did find a setting under the Sound section of the Win7 control panel which governs “communications.” The default in Win7 is to mute other sounds 80%, and I suspect that this is why my game sounds when using TeamSpeak start to fade. At any rate, I’ve changed it to the “do nothing” option.

I can’t be the only one with this problem, but the Vent forums are unhelpful, and the posts I’ve seen of people with this issue were working with early Win7 beta drivers.

Still no luck with the soundcard issues, though I’ve seen others with the same complaints–and no resolution.

I’m wondering if it’s an issue with the hardware/drivers and Win7 64. The soundcard is older, and maybe the drivers just aren’t quite compatible with Windows 7 when it comes to voice communications. I will say the games sound a whole lot better than they did previously. Wish the voice were working, too.

Would another, newer, sound card be the next bet? I mean, other than going back to onboard.

The best fix is what I said earlier, to use a USB headset. This is why. USB just works.

USB is cheaper than sound card, so I’ll give it a shot and let you know!

And now I look at the back of the sound card and gosh! No rear USB port on the sound card. Sure hope the front audio works with a mic. It’s a coolermaster Centurion 5 case, and I’d heard that sometimes the front audio can be a bit wonky.

Guess I’ll check out the USB headset with a cheaper headset. If it works, I’ll get a better headset and take the cheaper one to work, where I use Skype to make my long distance calls.

Why would your sound card have a USB port?

People are telling you to get a USB headset which has a ‘built-in sound device’ via USB.



I know there’s a front audio connector, which does hook up to the front USB. The problem is that, as far as I remember, front sound on this case can be odd. The front connector is for HD Audio, which is what I’ve got plugged into it.

At issue is headset price. I am not an audiophile, but I like decent sound, and I like headset comfort. Also, my current headset, a set of Sennheisers I’ve had for over 2 years, has not yet broken. This, in my experience, is a minor miracle. Nearly every other set I’ve owned has broken in under 1 year, the exception being a set of Plantronics from about 5 years ago.

It seems the best bet for me would be to play around with the USB audio by getting a lower-priced headset and seeing if that front port does work with the mic (apparently the issue is that that sound will come through, but voice typically doesn’t). If it works, I can get a better headset and then toss this very cheap headset I have at work.

Okay, I have a USB headset, but I can’t get the mic to work. Oh, I can hear sounds just dandy, but I can’t talk worth a dang. After some fiddling, the only playback I got was when working in the configure settings for the part of Windows that deals with speech recognition.

In XP, I could get to a microphone setting to set boost, etc. I’m not able to find the microphone’s advanced properties in Win 7. I’d like to see if the mic is muted, if there’s a setting for front usb, etc. I know the usb jack is working, since I can hear sounds. It’s just the mic, and there must be some way to enable it.

Any suggestions?