Not the Ignored Power Supply, random reboots driving me nuts

So yesterday afternoon I’m getting finished surfing the intarweb and I close down Firefox, and my machine reboots.

And when it comes up again I get a black screen, or it recursively reboots forever before startup (sometimes during WinXP loading, sometimes earlier). When it finally stops I get a brand new BSOD (never before seen in WinXP by these eyes) that says Windows has stopped with something like IRQ_NOT_LESS_OR_EQUAL.

I can’t get into safe mode, I can’t get anything except recursive boots, or this occasional screen, which also says it may be because I’ve installed some new hardware or software. I haven’t done either for at least a week (installed some software last weekend-- specifically some UT2004 mods).

So I get out the laptop and look up this strange error and I find that it could be out of date mouse drivers, out of date video drivers, bad RAM, underpowered power supply, or a host of other things, mostly hardware related, but since I can’t even start the machine, I certainly can’t update drivers.

So maybe a memory stick went bad. I pull out one, and now I can get in the repair console using WinXP (and I’m running WinXP Pro SP2) install CD. Hmm. I check the integrity of the hard drive, check the boot record, everything is A-OK on the hard drive. I try to get back to safe mode and get BSOD.

I swap out the memory for the other memory stick. I can get back to repair console but no safe mode.

Okay, time to reinstall WinXP. It won’t let me. As it’s initializing the install process from the CD and gives me a new error: “your windows\sytem32\config\system file is either missing or corrupt, repair this using the repair console.”

Hmmm.

So I look that one up and actually get a helpful knowledgebase entry that tells me to back up the registry in a tmp directory that I make, copy over original registry files, get into safe mode and use system restore to go back to an earlier working config. This works and my machine works again. Yay!

So I put back in the other memory stick, everything is fine. I put all the other non-essential peripherals back on and everything is fine. I check for the latest logitech mouse drivers and I have them. I upgrade video drivers. The only thing that seems to have been lost in the whole ordeal is my Firefox profile. All my bookmarks and history are gone.

So, did Firefox hose my registry? Did one of the recent Windows updates from last week or the week before burp on older video drivers? We were also having a snowstorm at the time and it’s possible the power might have flickered or spiked, could that be it?

This ate my Saturday night, and I’m curious as to what caused it, other than gremlins.

Could be a power gremlin, could be numerous things. Do you have a good surge protector or some sort of UPS that you’ve got your PC plugged into?

I’ve got a decent ($30 at Staples) surge protector, not a UPS. It has kicked off in the past, mostly during the summer when the AC is sucking power hard. It didn’t kick yesterday.

Well tonight, exactly one week later, at roughly the same time (5pmish) my machine did exactly what it did last week. It rebooted for no reason and hosed the registry.

That started me thinking virus. I’ve now gotten it back, kind of. I got it back, went to McAfee and started running their free virus scan. It’s running and it takes awhile, so I’m doing other things on the laptop and the desktop box reboots again. But I’m involved and I don’t really want to rebuild the registry for the third time tonight, so I just kind of ignore it. It attempts to reboot a couple of times (it gets so far and just starts over) but I go get something to drink and I come back and lo and behold, I’ve got a desktop.

So the registry isn’t really hosed, or it might have been before, but this time it isn’t. So I go back and start running McAfee again and it’s chugging away, and it reboots again.

So I’m thinking the power supply is giving up the ghost. This power supply has been in this box since it was a P3-500 (and the P3’s had just come out). I’ve upgraded everything else in the box since, but the power supply just keeps on chugging.

Or not.

So now I’m over at Newegg looking at power supplies, and I realize I have no idea. The special of the weekend is this which looks fine to me, but I don’t know about the numbers.

I’ve got an Athlon 2100+ on an M7NCD motherboard, plus a USB scanner (which I assume draws on the power supply) and the usual peripherals. What do I need in terms of wattage or voltage or whatever? I looked through my old docs but can’t find anything about the old power supply. I suppose I could just look on it, but I don’t feel like taking the box apart tonight.

Help?

Okay, since no one else seems to know what’s going on (or is willing to venture a guess) here’s what happened today–

After just turning the whole thing off last night to “let it rest” I powered up today to a normal computer. I go to McAfee.com to once again try to get a complete virus scan. It’s a long scan and about 45 minutes to an hour in (I was reading a book), the system reboots.

wlogon.exe and some dll’s are hosed, but this has happened before, so I replace the files out of the repair directory and reboot. It’s working again, but something is obviously going to keep happening. I start thinking about power supplies and how many old computers I have lying around the house. I go pull a power supply out of an old HP that has a dead mobo. It’s a 200W power supply. I open up my case and see that I’ve got a 235W power supply. Hmmm.

A bit of snooping around online and I find this power supply calculator. It might not be exact, but I can get a feeling for what kind of power supply I need, and after putting everything in, I find that I need a minimum of 278 watts.

So how has this 235 watt power supply been working for over a year? No clue.

So I head to CompUSA and get a 500 Watt power supply for $100, and a battery backup UPS for $30. I can get an equivalent power supply from Newegg for half that, but it’ll take a week. I’m considering ordering anyway and returning the CompUSA power supply when it comes in.

Everything’s installed, I’ve run the virus scan (and I’m clean, what a surprise), and I’ve now been running an hour straight without a reboot.

Probably problem solved until next Saturday at 5pm.

So let this be a cautionary tale for those of you who build your own machines but don’t pay attention to power supplies.

Weird; I had this exact same problem at work a few months ago, with the same symptoms. But I wasn’t on the project long enough to know how or if it was fixed.

Most devices in your PC aren’t drawing 100% power 100% of the time, so it’s easy to see how a 235 watt power supply could handle your system. And a bigger one may or may not be the problem. According to that calculator, I used to need a 430 watt PS, yet my high-quality 380W PS was fine. It’s more about quality, not just quantity.

Having said that, rebooting your system at random times shouldn’t consistently screw up files or the registry. I’d guess that you have some other issue–failing hard drive, or hard drive controller. Or maybe bad drivers for your hard drive controller.

As I understand that IRQL message, it’s more that some device sharing interrupts is causing a problem. I’d never heard it being a power issue; when I’ve seen power issues, the machine just rebooted. There was no blue screen.

Well after an hour it’s starting to happen again.

(sigh)

Here’s another possibility that I see flash by when posting that may back you up, Steve.

Primary IDE controller No 80 conductor cable installed.

Which when I looked it up yesterday said it’s most likely a misconfigured BIOS setting and not system critical unless you were concerned with optimizing your hard drive throughput.

More checking just now and it turns out it’s just telling me the truth, I had a 40 conductor cable installed, not an 80. So I found the 80 and installed that. It’s no longer giving me the error.

I’m now stuck in recursive rebooting again. One in 5 times I get a desktop and then it could crap out at any second. Ugh. I have a project to get done for tomorrow and I’m at the end of my rope.

Can you reliably boot into Safe mode? Can you access the Event Viewer? It might have some info in there.

There are so many possibilities here. The corruption may have been due to the IDE cable issue, so maybe that’s solved and the reboots are totally unrelated. In which case, you’re now at the “bad RAM, bad power supply, bad card” issue.

Try removing non-critical items. Unplug all USB devices that are unusued. Unplug any extra hard drives or optical drives. See if it’s reliable with fewer devices; if that’s the case, maybe it is the power supply.

Download Prime95 (you can google it) and run it in Torture Test mode for a few minutes. See if it generates rounding errors or reboots your system. That might imply RAM (or could also be the PS, since it really strains your CPU and RAM).

the first thing is to download and run memtest86. If your memory is fucked, then everything else you do is questionable.

Thanks guys, last night I had to quit screwing with the thing and get the work done on the less than optimal, but at least functional laptop.

Now I’m at work. I’ve downloaded and made a disk of memtest86 and I’ll grab Prime95 and run those tests.

Just leaving it alone last night it stayed on all night with no problems, but it ran all week last week before crapping out again over the weekend.

Maybe my box just wants weekends off.

I just had the same thing happen to me starting about three weeks ago. At first I thought it might be my hard drive going out. It is 4 - 5 years old and when the computer first booted up the motherboard bios would take a long time to recognize it. So I replaced it and the bios would see the new drive normally but, I couldn’t install windows xp without installing linux first. Finally I decided to flash my bios just in case it was corrupt. It worked and I was able to install windows xp without linux. The computer worked for about 2 days then started the routine all over again. Then my investigations led me to my power supply. I had just bought a 480 watt supply for around $50 in Jan. So I replaced it with a high quality 600 watt one. The power supply worked but that did not solve the problem, so I replaced my motherboard. It’s been working for a week and a half now and I’ve had no problems so far. My recommendation is to flash your bios in case it got corrupt and if it happens again then it could be your motherboard. Actually if you have any old parts it could be any one of them going out.

I have been noticing a lot of people having this problem lately, I’m wondering if there’s something happening in the atmosphere that causing these problems to happen all over the globe or it just happens to a lot of people and I haven’t noticed it before.

The box has now been on since Sunday night without rebooting. I ran the Prime95 Torture Test for 14 hours 30 minutes with 0 errors and 0 warnings.

So memory seems like it’s okay. PS is okay because it’s got the brand spanking new Antec 500W PS in it still.

I’m inclined to think it’s some sort of IDE problem now, because the reboots were pretty predictable while doing the virus scan, which is disk intensive. I’m not sure where to go to diagnose or fix that sort of thing, though.

Oh, and I ran both Adaware and Spybot just for good measure, and aside from some tracker cookies, nothing came up, and no reboots despite thrashing the drive a bit.

I have a lot less hardware experience than other posters; I’ve built my own systems for 5-7 years, but never worked as a repair tech or anything. With that caveat, I’d try the following in your situation (in order of ease/importance):

  • swapping the IDE channel used for your hard drive to secondary (assuming it’s on primary now) to rule out one channel being hosed
  • checking your case & CPU temperatures during average use. I use SpeedFan for real-time testing of power & temps. I doubt this is the issue, but you may as well rule it out
  • backing up all your important files and reformatting the entire hard drive; this has cleared a few situations up for me that didn’t get resolved by a simple Windows re-install

Did you run MemTest?

Other possible though unlikely problems are an intermittently bad cable or socket, or a cracked motherboard that is opening a trace when it’s heating up. You won’t be able to see the crack if it is indeed cracked. Pretty unlikely, though.

Did you run MemTest?[/quote]

Not yet, since it takes a reboot to run and I’m scared to reboot.

:oops:

Well…until you do, you can’t say whether the RAM or memory controller are good to go or not.

Slightly off topic, but I thought that Prime95 and MemTest are both pretty good at detecting RAM errors. Is MemTest really superior, & does anyone know of a site that actually compared the two in real-world tests?

MemTest actually tests RAM and reports exactly when/where RAM is dying. Prime95 is a “test” only in that it stresses a system pretty thoroughly and thus if you have bad RAM there’s a better chance it blows up under Prime95 than day to day activity, at least that’s the theory.

But for real memory testing, MemTest86 is the way to go. Crucial allows users to quote MemTest logs for evidence of bad RAM.