NWN2 on XP 64-bit: 1.02 patch killed it

I just upgraded NWN2 to 1.02 via the updater, and now the game doesn’t start when I hit “Play”. It has a pair of 32-bit processes running – nwn2main.exe and nwn2.exe – but no game actually comes up. I’m running XP 64-bit – any thoughts from the pros?

Play Gears of War until patch 1.03? ducks thrown object

not a big stop-and-pop guy – I kinda like my elf simulators. :(

try hard rebooting your system?

You just got this? Or is the the original 1.02 that they pulled to fix?

Nevermind. Just saw that they released the 1.02 again. Sorry.

I rebooted several times, to no avail. Man, I’d really like to get back to playing it. :(

That’s terrible. Is there anything keeping you from reinstalling?

I’m gonna tonight, but I’d like, y’know, the bugs fixed

Darren Monahan - Executive Producer, Obsidian Entertainment:
[i]"Windox x64 while not technically supported should run just fine. I suspect you’re having the same issue people are having with it on startup. Take a look at this thread and we’ll see if we can help.

Some folks have reported that they are experiencing crashes on startup with the new patch, and I’d like to use this thread to help troubleshoot.

One thing I know that happened with this patch is that Atari consolidated it’s copy protection so that it would support CD, DVD and Direct2Drive versions with one set of executables.

I suspect it’s a newer version of said copy protection, and that there are problems with it reading from certain CD or DVD drives. Since the crash has been reported to be immediately on startup, I really tend to think that that’s the issue.

So… I had released the patch to a couple people earlier in the week who previously had crashes on startup, and we were able to get them playing again. Here’s what we learned:

  1. Update your CD/DVD Firmware. One person updated their DVD-ROM drives firmware, and the game stopped crashing on startup.

  2. If you have it, try another CD/DVD drive. One person had a DVD drive and a burner, and tried putting the disc in the burner instead of his DVD drive and that worked.

  3. Make sure you don’t have drive virtualization software installed and/or running. If you’re running Daemon Tools, Alcohol 120%, CloneCD, Nero, or any other software that allows you to create “fake” CD drives on your computer, this may crash. Uninstalling Daemon Tools fixed this issue for a couple people. This thread also helped confirm that."[/i]

Bastards… I should get the crack already. So annoying they felt the need to cd/dvd check the damn game. I was hoping we were moving away from that.

Thanks! I’ll try the firmware update, although I might just buy a plane-jane ol’ DVD-ROM drive and shovel it in for edge cases like this. Is there a known model of DVD drive that WORKS for 1.02? My current drive is a Lite-On DVD burner; should be pretty standard.

I have no drive virtualization software installed.

Is 1.02 the patch that was available a few days ago? Or is it a new one?

Also: Good to see this game is another hallmark of copy protection awesomeness. Go ahead consumer, risk turning your dvd drive in to a brick! Better you than us!

1.01 was available on launch. 1.02.807 was released and then pulled shortly afterwards. 1.02.809 is the latest patch.

Doesn’t answer my question. I got a patch a few days ago. If it’s the latest patch, then I can tell Doug that the patch works on my DVD drive. If it’s not, then I won’t. Get it?

I can’t read the number on the screen for you.

Anyone playing on (32-bit) Vista RC2? I’m getting absolutely horrible sound-stuttering issues. :( Video framerate is ok, even with most of the options set to high, but this audio problem is really ruining my enjoyment of the game. I suspect that it may be a problem with my nForce4 on-board sound driver, but none of the other apps or games (WoW) that I’ve tried have shown any kind of audio problem at all.

1.02.809 is the latest patch, and the one I have installed. 1.02.807 is an apparently older release from a couple days ago.

So no one can tell me when this latest patch was released? That’s… interesting.

I can’t read the number on the screen for you.

I can’t read the number either, since I’m not at home.

It was released yesterday? I think.