Odd Windows 10 Issue: Store Can No Longer See Hard Drive

Hey y’all, I’m having a really weird issue. I have an SD drive solely for games. I install everything there. The drive itself is running fine, as I run games from it using Steam and Origin ALL THE TIME, for example, but lately, I ran into this when trying to run Forza Horizon 3:


WTF? I went to the store, and was given an option to reinstall, which showed me this:


Completely missing my D drive upon which all my games reside. I went to disk management, which shows the drive as healthy, and did an error check, and it found nothing:

So I’m completely perplexed, and doing lots of Googling has found no solutions. I’m therefore hoping someone here maybe has run into the same issue and has a solution or an idea? Thanks so much in advance for your help.


The first thing that comes to mind is a drive letter conflict, like if your optical drive decided to grab D before that drive, but those haven’t happened to me in a long time. Certainly not since W10.

Edit - Nevermind - Saw you already ran the chkdsk. Huh.

Definitely try moving to another drive letter then and see if anything is left on D.

Sorry, moving to another drive? Like installing FH3 to another drive?

In disk manager, if you right click on it you should see an option to change drive letters. It’s a pretty safe operation for a game install disc like that, though you may have to reboot, and it will break any installations you have done. But you can always change it back - the point is just to see if you have a conflict for now.

OOHHHHH! I get it. Okay, I’ll try that after today’s Stream. Thanks!

Okay I have to admit that I’ve not done it because I’m terrified. If I change it from D, and then back again, will all my current games still work afterwards? I’ve never done this before.

Yes, they should. Windows will warn you that it will break programs when you initially do it, but if you change it back then everything should work again.

By all means wait for somebody else to weigh in if that makes you more comfortable - I don’t treat my game installs with any respect. So if it did bork things, I wouldn’t care, whereas it sounds like you very much would.

SO IT GETS WEIRDER. After the latest Win10 update, the windows store now finally sees my gaming hard drive (D) but can’t install anything to it. I also can’t uninstall and reinstall the game! It’s so weeeeeeirrrrd.

Well that’s that. I hope you like those games because those are the games you will be playing FOR THE REST OF YOUR LIFE!

Sounds like the WpSystem and WindowsApps folders have gotten corrupted.

Indeed. I ran across this issue when I upgraded my hard drive last week. Windows Store games are invisible to explorer and are installed into their own virtual drives (looks very strange to see them show up in a cloning program like Macrium). Any irregularities (drive letter change, bad/ inadequate copying) will kill the install, and the only sure fix is a reinstall.

Reinstall of what? Windows itself?

Nah, just the app/game.

Sadly that didn’t work, as I keep getting some kind of installation error.

Hm. I’ll tell you what happened in my case. I just did a regular old file copy from the original 3tb drive to the new 8tb drive. Any WS programs I did not move to another drive did not copy, nor could I install any new WS programs or move any to that drive letter. Whatever allowed the installation in the first place was gone and could not be restored by Windows. Which is fine, I was farting around anyway so I could learn stuff.

Only sector cloning the 3tb worked (and then expanding the partition). I’m guessing that whatever partitioning/ hidden file magic that MS uses for its WS program installs is broken as heck on your hard drive and that drive is not going to be a candidate for new MS store installs unless it’s reformatted or re-partitioned. That may or may not be worth your time.

Wait a pain, I was really enjoying Forza Horizon 3.

Sooo…now Forza Horizon 4 works! And after uninstalling FH3 it seems to be reinstalling normally. Yay? So confused.

Aaannnd now they don’t work again. I went through the Windows Update thing and the PC did some long and massive update. So much so that I can now install the Xbox app, which I couldn’t do before.

So now, the Store doesn’t see my D drive. The Xbox app DOES see my D drive, but I get an error whenever I try to install anything to it. SO WEIRD.

It’s not a hard drive issue, is it?

Nope, did a check of the disk and no errors were found. It’s less than a year old so that’s what I’d hope. Games via Steam, Origin, Epic and Uplay all play and download just fine. So confused.