Paradox strategy games: slower than pig shit to load?

I’ve excepted most of my game installation folders from scanning to speed up my old system. Seems to have helped quite a bit.

I don’t have anything extra for security just Win10z

If you mean getting to the menu when you get to pick multiplayer or single player, scenarios and etc, that’s like 35 seconds for me. I have the 2700X, my C drive is WD Black NVMe but it’s installed on a Samsung 860.

Wow… I wonder if it is specific to their implementation with GamePass.

Straight uncomplicated google search revealed other people with problem since September but no consensus on root cause. I won’t sweat it or move their games back to SSD full time since SSD installs are reserved for my huge 3D games that require full time streaming off it like RDR2, Control, Jedi Fallen Order etc. I’ll just put up with initial load time.

Moved Imperator: Rome to SATA SSD. Timed load again and it still took 3-3.5 minutes to get to main menu.

30-45 seconds of the loading screen art before the quote appears, then the text cycles a few times for 2min then 30-45 seconds of the progress spinner frozen not animating until the main menu comes up.

I loaded all my other Paradox games and they all load slow too but Imperator Rome is the slowest.

That is extremely abnormal… Have you tried running without internet? Have you tried shutting down as many background apps as possible? Run a spyware scan lately? Sorry, not sure what else to suggest.

I am completely clean of startup items having purged them recently in the “16GB RAM is not enough” thread.

Have you ever installed a mod? An outdated mod can cause problems (especially in I:R since it’s not entirely intuitive on how to disable them properly.) You might also have a corrupt saved game file, or even a corrupt install. For reference, prior to upgrading my old, outdated PC took around a minute or so to load EU/CK2. 3 minutes is well beyond the scope of ‘normal.’

And where is your Steam directory? If you have Windows 10 Pro give yourself full rights to program files. But from the sound of the behavior, I’m guessing the game files are getting scanned by an AV or possibly a firewall program.

This is the Xbox GamePass PC version. No corrupt save or mods, reinstalled thrice over to different 3 different drives. Windows is newly reinstalled from just after Christmas–I literally just redownloaded my entire 15 TB+ Steam, Origin, GOG, Epic games. No AV. Nothing extra at startup. Everything is disabled in the Startup tab of task manager except for Xbox App Services, Logitech, NVIDIA, Realtek drivers and Windows Security notification icon.

I will just put this on Paradox since all of the other Paradox games (Xbox GamePass PC and Steam) are slow to load as well. This is a PC built only in June.

Don’t they encrypt their data? It could add a tax to every file read. Could you compare it to the steam version?

Thanks for the suggestions all.

I don’t have/nor plan to buy the Steam versions of Age of Wonders Planetfall, HOI4, EU4, Imperator Rome. It could be whatever UWP wrapper the games have in being bundled for GamePass PC but my system loads/runs other non-Paradox AAA games quite fast (RDR2, Control, Jedi Fallen Order etc.)

By commenting that Steam versions of Paradox games are also slow, I am referring to ones that have the Paradox launcher before loading the main game like Stellaris, Crusader Kings II and are not 3D powerhouse games–these all appear to use the Clauswitz engine like EU4, HOI4 and Imperator Rome. While slower than other games, these take 1-2 minutes tops to load.

I own almost all the games of the non-strategy type from their brands page (Battlefield, Magicka, Surviving Mars) etc and my system has never run into anything that takes this long to load which is weird and off-putting.

Looks like the Clauswitz engine these games use and UWP file system encryption? Who knows?

Yeah my guess would be that they keep reloading small files, or that they have more small files than average. If the file encryption system can’t easily locate and jump to small files and decompress them, it may have to decompress some huge container file over and over again just to get to a small file the game was looking for, then dump that huge file out of memory, and then decompress the huge file again just to get to yet another small file.

You people don’t read posts? :P

I already tested it, with Gamepass, and the load was fast. So that’s not it.


Good for your PC but doesn’t address my weird issue so I’ll just leave it.

Could you guys compare specs? Specifically RAM and CPU.

I think he was trying to help you by pointing out that you buying or moving to a Steam version might not actually help since at least one version of UWP doesn’t have this very long load time you’re speaking of. Even if one or more of our launchers are slower than the other, what you’re describing is pretty extreme. It’s either hardware or third party, not the launcher, software. If it were a driver issue, again I wouldn’t think it would be specific to those games. Even a HDD should never, never take that long.

If it was hardware based, I would expect you to have problems with other not related to UWP games.

How saves do you have? Paradox games autosave in a weird way, and I think it tracks your save folder at some point. I never keep all those saves, but over the years because of the way they like to save it can get very, very large.

No saves as I am starting up these games for the first time without starting a new game yet. No mods or save games or any baggage/detritus.

Oh, to clarify, I wasn’t being snarky at @Bluddy

Potentially, file decryption might need extra RAM on top of what the game itself requires to load the files. If you run out of RAM while decrypting, you’re going to start swapping to the drive, which would cause extreme slowdown.

I am not asking you if you are loading a saved game. I am asking you how many games do you have in your saved game folder. You’re saying none?