Paradox strategy games: slower than pig shit to load?

This is the Xbox GamePass PC version. No corrupt save or mods, reinstalled thrice over to different 3 different drives. Windows is newly reinstalled from just after Christmas–I literally just redownloaded my entire 15 TB+ Steam, Origin, GOG, Epic games. No AV. Nothing extra at startup. Everything is disabled in the Startup tab of task manager except for Xbox App Services, Logitech, NVIDIA, Realtek drivers and Windows Security notification icon.

I will just put this on Paradox since all of the other Paradox games (Xbox GamePass PC and Steam) are slow to load as well. This is a PC built only in June.

Don’t they encrypt their data? It could add a tax to every file read. Could you compare it to the steam version?

Thanks for the suggestions all.

I don’t have/nor plan to buy the Steam versions of Age of Wonders Planetfall, HOI4, EU4, Imperator Rome. It could be whatever UWP wrapper the games have in being bundled for GamePass PC but my system loads/runs other non-Paradox AAA games quite fast (RDR2, Control, Jedi Fallen Order etc.)

By commenting that Steam versions of Paradox games are also slow, I am referring to ones that have the Paradox launcher before loading the main game like Stellaris, Crusader Kings II and are not 3D powerhouse games–these all appear to use the Clauswitz engine like EU4, HOI4 and Imperator Rome. While slower than other games, these take 1-2 minutes tops to load.

I own almost all the games of the non-strategy type from their brands page (Battlefield, Magicka, Surviving Mars) etc and my system has never run into anything that takes this long to load which is weird and off-putting.

Looks like the Clauswitz engine these games use and UWP file system encryption? Who knows?

Yeah my guess would be that they keep reloading small files, or that they have more small files than average. If the file encryption system can’t easily locate and jump to small files and decompress them, it may have to decompress some huge container file over and over again just to get to a small file the game was looking for, then dump that huge file out of memory, and then decompress the huge file again just to get to yet another small file.

You people don’t read posts? :P

I already tested it, with Gamepass, and the load was fast. So that’s not it.


Good for your PC but doesn’t address my weird issue so I’ll just leave it.

Could you guys compare specs? Specifically RAM and CPU.

I think he was trying to help you by pointing out that you buying or moving to a Steam version might not actually help since at least one version of UWP doesn’t have this very long load time you’re speaking of. Even if one or more of our launchers are slower than the other, what you’re describing is pretty extreme. It’s either hardware or third party, not the launcher, software. If it were a driver issue, again I wouldn’t think it would be specific to those games. Even a HDD should never, never take that long.

If it was hardware based, I would expect you to have problems with other not related to UWP games.

How saves do you have? Paradox games autosave in a weird way, and I think it tracks your save folder at some point. I never keep all those saves, but over the years because of the way they like to save it can get very, very large.

No saves as I am starting up these games for the first time without starting a new game yet. No mods or save games or any baggage/detritus.

Oh, to clarify, I wasn’t being snarky at @Bluddy

Potentially, file decryption might need extra RAM on top of what the game itself requires to load the files. If you run out of RAM while decrypting, you’re going to start swapping to the drive, which would cause extreme slowdown.

I am not asking you if you are loading a saved game. I am asking you how many games do you have in your saved game folder. You’re saying none?

Yep. Zip, zilch!


AMD Ryzen 7 2700 w/ 16GB Corsair Vengeance PC4-3200 DDR4 RAM running @ 3200 MHz
ASUS ROG Strix B540-I GAMING mobo
WD Black NVMe 512GB SSD for Windows and some games
WD Black 7200rpm 5TB HDD
Intel NVMe 660p 2TB SSD
NVIDIA Geforce GTX 1080 Ti 11GB GPU with v441.87 drivers
Windows 10 64-bit build 1909

Who knows?

At one point I was up to ~5 minutes from launch to playing, too, most of which was spent on the “Loading databases” screen.

I put it down to an ancient processor and 16GB of slow RAM, but in my case it was due to 2GB of savegames. Moving them cut the time to a much more reasonable 30s.

Yeah that is why I asked him about that. I heard this can happen with Paradox games. I don’t save the way Paradox suggests I should save, so I never really run into that.

Not unless it’s parsing the whole friggin’ “My Documents” structure under my user profile for other games as well. This is me literally running it for the first time (repeatedly, on different drives) without any save game baggage and wondering why only the Paradox Clauswitz games are so slow compared to every other game.

If it was doing that, I am pretty sure we would all have problems. Since you have no saved games in the folder it’s looking at, the most logical conclusion is it must be something else.

The other thing these Paradox games do is login to the Paradox account. It’s usually one of the first things they have you do when you install new. Assuming you remember your password, have you tried logging out of one of those to see if bypassing that part helps? It’s not required, or at least it isn’t in the games I have.

Hmm… definitely no RAM shortage.

You may want to run the awesome diskmon to monitor what the process is reading on the disk at any time. You can filter by application to only monitor what the game is doing.

Also check to see how much CPU percentage is being used by the process using task manager, or the far better Process Explorer.

I’m just not going to play them. Thanks–already an old hand with the SysInternals Suite stuff.

(already tried with logged in vs not logged in w/o difference)

@rei , can you take a look at your CPU running speed?

I had an extremely weird issue once with a customer’s laptop where the CPU was throttled to extremely low speed because the board or chip’s heat sensor part was faulty. A 2.4GHz machine was throttled to run at 300Mhz! It was one of the strangest things, everything became super slow to load.