Pathfinder - Wrath of the Righteous; A Kingmaker follow-up that supports turn-based gameplay now!

Trickster can have sex with her, lol.

Quality roleplaying options right there. lol

The long convo you have between Iomidae and Nocticula almost makes me feel guilty keeping my Angel powers the way it’s written. I’m guessing lvl 10 spells don’t become available until M10 though, right?

If you’re not merged. If you’re merged (and you better be) I think they come a lot sooner.

Don’t feel guilty about staying Angel because of Iomedae. The Angel mythic path is the best one for a lot of reasons, not the least of which is that you can change Iomedae’s opinion.

I"m merged, cleric lvl 17 and M8 now, but no 10th level Angel spells yet. But glad they come sooner than the very end of the game.

I think so? I might be wrong. I’ve only gone Angel with a merged spellbook once. Most of my Angels are Paladins.

I think my next play has to be an evil toon, something like a witch who goes Lich. And at some point I need to experiment with the Demon path, which I"ve yet to do. I do have a Cavalier of the Paw in Act 4 who went Trickster, but that’s from last fall and last time I loaded her up her build was terrible (no teamwork feats at all).

New survey up about what would make a good new DLC:

They state ‘at a price of $12.99’ so I’m assuming that’s USD. Some of those ideas would have to be bundled to be worth that cost.

For me, DLC that integrates with the main story in some way, gives new areas to explore, and expands replayability (new classes, new mythic paths) are where I’d go.

Pretty much the same for me too.

Owlcat rep said they might do a season 3 of DLC. Not sure how I feel about that.

My cleric hit 18/M8 and still not level 10 spells. My Google-fu says it takes caster level 28 to get them and suggests hitting level 20 in Act 5 as quickly as possible. I did one quest in Act 5 and hit 18 so no idea if there’s enough XP for me to enjoy the spells before the final dungeon, but we’ll see.

I’ve played the Island roguelike a bit, and its pretty fun.

Some of the islands has some…undertows I think its called, special modifiers, which is a great idea. BUT…wild magic I think its called is REALLY rough - Met a conjurer that turned invisible at ones, then proceeded to summon 2 massively large monsters I’ve never seen before , looking kinda like Mindflyers, that just obliterated my level 4 party :-D
Reloaded, and then they just summoned wolves, which I am sure was the invisible conjurers original intent, but the wild magic made the spell some other, random spell, which just happened to be a high level summoning spell.

Yeah, the wild magic undertow is hard. Especially since I usually don’t notice it until I try to cast mage armor or something and accidentally wave of fatigue my whole party instead.

The other one that really gives me trouble is the Earth one which creates a huge greased area, basically, where every melee attack can cause you to fall prone, all the while spawning an infinite number of earth elementals. So it’s really difficult to get in range, and destroy the pillar with a melee focused party.

Thought I’d use the Midnight Isles DLC for party xp to make level 20 as early as possible in Act 5, but so far it’s negligible since it’s so much trash mobs and then I hit the bug on island 9 of the miniboss not spawning, so I can’t get his treasure and progress.

Edit: a little Googling showed how to spawn this particular boss in via Toybox, which I didn’t have installed. DLC3_CR15_DemodandStringy_level8_MiniBoss_Integration is the string you search and pick under All for and when it’s found click Spawn1 and it’ll appear in the middle of your party. In case anyone else has run into this bug.

I’ve run into a game stopping bug. I’m in Iz and my party is unable to enter the temple. Every time I select the zone transition at the stairs my party clusters around or send a couple off to the left where the chest is and the zone transition never triggers. I’ve tried going without any buffs in case that was messing with thing. Tried having Seelah off her horse. Even tried reloading a save from before I entered Iz and it still happens. I entered a bug report and will cross my fingers Owlcat does something. This is my first play though and it’s a bummer to be stuck so near the end.

Try using toybox to teleport your party on top of the door icon and then try clicking on it again.

My last few runs I gave the Lexicon to the Queen, so she’s outside the temple and will bring you inside with her.

I gave it to her also. Where should she be?

Top left corner.

I’m thinking that might be my problem. She is supposed to be there but is not. Which would explains why I can’t enter the temple normally.

Ha, it’s part of the Humble Bundle and I have had my eye on ti for a while and thought now’s my chance, order it and nowhere does it say they key is currently unavailable so I have all the other games but not this one I was planning on playing tonight …Grrrrr

Did you contact Humble and ask them where your key is?