PC restarts after shutdown/sleep/anything (a hardware mystery)


Alrighty, fellow hardware folks, I have a doozy for you. Starting about an hour ago, five seconds after I turn my desktop off by almost any means—sleep, shutdown, tap the power button during POST—it turns back on. I can 1) unplug it from the wall and plug it back in, 2) turn it on, and 3) tap the power button to turn it off, and in about five seconds, it’ll turn back on. The only way to get it to turn off and stay off is by holding the power button for five seconds to do the for realsies I mean it this time hard power off, or by flipping the power supply switch to off.

As far as I can tell, it isn’t caused by any peripheral: I’ve reproduced the issue with nothing more than the power supply cable plugged into the back. All of the Windows 10 settings are correct (wake-on-LAN off, no devices allowed to wake the computer from sleep), but I don’t think they play into it anyway, given how it doesn’t seem to require Win10 to boot to happen.

I was messing around with a mostly-dead graphics card earlier, verifying that it was almost dead, and the failed-boot protection in my motherboard’s BIOS reset the CMOS, but between loading the preset I was using immediately before and verifying the common BIOS culprits weren’t the cause (BIOS wake on LAN, restart-after-power-outage), I’m pretty sure it isn’t a BIOS problem, either.

Onward to more esoteric possibilities. Could it be noise in the power button cable from the other front panel cables? Nope, it happens with all the other front-panel cables unplugged. Could it be noise from the power supply cables? They run pretty close together, but it’s never caused trouble before tonight, and I’d expect it to happen a little less like clockwork if that were so. Could it be a short in the power button? It seems unlikely, since I turned the computer off, pulled the power button cable connector off of the motherboard, and still saw the PC reboot. Could it be ghosts? I’m not ruling it out.

I can’t help but think it has something to do with the CMOS reset, but I’ve been over every setting, and I don’t see what it could possibly be. Do you have any ideas?


Mine actually does the same, at least from sleep. Sometimes. It started happening after going to Win10, as far as I know.


This is just a shot in the dark but have you tried disabling fast startup? (See screenshots)
It might be causing an invalid power state.


Hibernation is off, so no fast startup option.


It’s just me, but with Win 10 sleep option, I don’t use power off anymore. Sleep is your friend, then you just click your mouse & it wakes up. Awesome. I was a power nazi and always turned my PC off, but this is really amazing how low power the pc is on sleep.


Hmm, I’m still betting on an errant “wake” feature or an invalid power state caused by software. I think I would start investigation there. Have you tried going through the driver power options in the device manager?
Perhaps try disabling any related wake/power options in there? (e.g. wake on LAN, charge this device etc)

Do you have any software running that came with your motherboard?
Any kind of utility that has power management capability?


powercfg -lastwake in Windows after sleep/wake shows nothing. I’ve been through every entry in the device manager with a ‘power management’ tab, and only the keyboard is allowed to wake.

No motherboard software, no power management utilities.

Come to do a little more testing, it looks like I’m running into some sort of power switch/power supply fault—when it comes back on after sleeping, it comes back on through a full reboot, rather than waking from sleep.


Stupid question: Are you using a USB or PS2 keyboard/mouse?
I know you mentioned testing without peripherals but did that include every USB device?

Sorry, I’m probably just suggesting things you’ve already tried but this is an intriguing problem :)


USB everything. I’ve tried with only the power cable plugged in.

No worries on suggesting things I may have tried—I’m sufficiently at my wit’s end that I’m just glad someone else is also intrigued. :P


So, I’ve ruled out the power switch to my satisfaction, which means I probably have a power supply problem. Potentially. I’ve also seen someone suggest that a failing video card can cause it, which would be bad. (My No. 2 HD 6970 just failed, as I alluded to in the first post, so I’m down to the No. 1.) I’m going to mess around with putting it in the other PCIe slot in a little bit, and then I’ll report back.


Currently attached to the motherboard:

  1. CPU
  2. One stick of RAM

Not even any of the case items—I’m using the switch on the motherboard for power on/off. And still it shows the issue. I’m thinking either power supply or motherboard now.


Did you recently update your BIOS or do anything (replace BIOS battery, etc.) that could have reset your BIOS settings? My BIOS has a “what to do after losing power” setting that will automatically turn the machine back on if it detects that the computer is shut down and it has power. That’s great for a server, but it bedeviled me on my desktop when I first set it up.


Thanks for the update Fishbreath. Please let us know whatever the cause is if you figure it out! :)
It might be worth reinstalling Windows to try to verify that it’s not a software problem?


I do have one of those settings, but it defaults off for me.

I’m pretty sure it isn’t software–while I had everything out, I also pulled the CMOS battery, and after putting it back in and leaving everything else out, I still had the problem.

I borrowed a power supply tester, and the power supply is fine, so the only remaining component is the motherboard. I may have toasted something (or maybe the bad card did, when I was testing). I’m not inclined to worry too much about it until my next upgrade, though. Seems to work fine besides this.


I know you said you didn’t think it was software, but I found another thread with people complaining of the same crap. There’s a registry tweak that might help out. Also, people were reporting USB devices caused the problem sometimes – perhaps disconnect all USB other than mouse/keyboard and try from there?


I’ll give the registry tweak a try. As for USB, I’ve reproduced the problem with a pretty absolute minimum configuration: the only things attached to the motherboard were the CPU, the CPU fan, the CPU power connector, the 24-pin power connector, and one stick of RAM. Everything else, including the case power button and all the things connected to the back panel except the power cable, were unplugged.


Not the registry setting, unfortunately. I’m pretty settled on the diagnosis of ‘something is wrong with the motherboard’. Short of taking it out of the PC entirely, making sure there isn’t anything that could be causing a short, and putting it back in, I think I’m out of options.


I think you mentioned trying without any peripherals plugged in, but did this include the keyboard?
For instance, a stuck key could turn it back on, but only if it’s set that way, and I believe you already covered that aspect.
I only mention it because I didn’t see anything specifically regarding the keyboard.

Edit: nevermind. Re-reading the thread more closely, I see you did in fact already try that. Sorry.
I am, in fact, stumped, but following along anyway.


Is maybe the switch behind your PC case power button stuck in the depressed/ON state?


Sometimes I wonder if there’s a switch on the back of me stuck in the depressed state. . .