Planescape Torment: Graphics Problems!

I was hoping someone else had run into this problem and found a solution to it. I’m trying to play Torment on my Dual-Core, WinXP SP2, GeForce 7800 GTX machine. I’ve got the newest drivers for everything.

If I leave hardware acceleration on full, all the spell graphics are screwed up (specifically, they’re replaced by black boxes the size of the sprites). No amount of playing with the in-game graphical options fixes that.

I can turn down the hardware acceleration in the control panel three notches and spell graphics will start to work. However, then the mouse cursor begins leaving artifact trails on any static part of the screen - like, say, dialog. Or the inventory.

Has anyone figured out a way to play this game on a modern machine (with an nVidia card) and avoid both issues?

Nope. That is an unavoidable conflict with XP.

Really? I could swear I got it to work at least passably towards the end of last year… I’m on a different machine now though, and so can’t check my settings. :-/


Wish I had known this in advance, I would have stayed a Fighter.

I think it may be a dual core issue not an XP issue:

I had a similar problem with System Shock 2, playing it on a dual core system, I learned that if I set the exe to only run on one core it ran perfectly. Two? Crashed before I even began the training routine.

It couldn’t be a dual-core issue because:

-It’s already set to use only one core by default.
-Graphical acceleration changes fix the problem (but introduce another one).

There’s some graphics-related compatibility switches buried way down in the game options submenus. Try those.

I tried, they didn’t seem to have any effect, aside from the one that made the game unplayably slow, but then, everything seemed to work too!

I had it working fine last year on that same exact video card, but I don’t recall what I did to it (was on a single core cpu though, athlon64 4000+).

Too bad I’m in the middle of assembling new pc parts or I’d dig the discs up and test it out. Once I get my stuff put together I’ll see what happens (I’m sure I’ll run across the discs while I’m packing stuff to move here).

This gives me an excuse to play it again at least, not that I really needed one. :)

I played it in XP and had no problems…seems like I fixed something though…where’s Charles? I think he’s the one who told me what to do. It was in the graphics settings. Turn off 3d acceleration maybe?

Have you tried turning the acceleration to none?

Yeah. The game (and pretty much anything else) refuses to load thanks to some nVidia cockblock focus-stealing warning about acceleration being off (despite the fact that I turned it off).

Turn hardware mouse cursor off instead?

I don’t see that option in the control panel… and Torment doesn’t have an option like that (unless it’s a command line switch?)

Just kill the process.

Check the INI file?

Nope, nothing there, unless I’m really missing it.

I mean, have you done this fix before or are you just giving suggestions? I’m confused.

I’m just giving a general suggestion since it sounds like a hardware cursor issue. The cursor is buffered in video memory and it sounds like the layer below it isn’t being repainted properly.

Have you tried using the Compatibility tab and setting it to Windows 95/98 ?

This game is on GameTap. Has anyone tried it on there? Does it work right?