Pocket Heroes--Is that an async co-op iOS dungeon crawl in you pocket or

So in an attempt to not water down the iOS gaming thread, I thought maybe it would be considerate to move the conversation here.

Pocket Heroes recently came out and the jury is very much out on it (possible bugs and implementation), but it has potential. It is a multiplayer only (no AI and no single player), asynchronous, co-operative dungeon crawler that looks like an early Final Fantasy title where you control one hero in a 3 man party while pushing turns to your allies. It seems designed for iPhone, but will play on an iPad set to 1x or 2x. So far my interest is very much centered on the idea that this could be more like a tactical dungeon crawl board game in electronic format than some kind of retro RPG. I don’t know if this will play out.

If anyone is interested, there are some things that you might want to know as you plunk down your 99cents. There is no random player finder so you need to bring your own friends. In order to start a game you must:

  1. Have a Game Center account
  2. Have two other friends in Game Center that also have copies of Pocket Heroes (you must be friended in GC before starting a Pocket Heroes game)
  3. Register for an account inside of the Pocket Heroes app (this does not need to be the same information as your GC account) in order to use the developer’s servers that will push turns
  4. One of the 3 members of your party should now create a character inside Pocket Heroes then invite friends to the game (remember you must already be friends in GC before this step)
  5. The other 2 members of the party accept the invite when it comes in through Game Center.
  6. If all is well you should see a red “10” near the Pocket Heroes icon for the invited players
  7. Start the app and follow the prompts (keep in mind everyone starts apart at first)

I hope this helps as there was quite a confusion curve as Tylertoo, Dreamshadow, Shellfishguy, and I all tried to get something going. Now the turn waiting is the hold up on further feedback.

Oh, I have no idea of the scope of the game (such as game length, quest options, etc). There are four classes though: Paladin, Rogue, Warrior, and Mage. I can’t speak to their abilities, by my Pally seems to have party buffs, a heal, and some holy direct damage-- like you wouldn’t have guessed that.

While there is a Debut Trailer out, I think this alpha footage video gives a better taste of what the game seems to offer:

Good synopsis, and good idea for a separate thread. It’ll be interesting to see if the three of us can keep our game going… and whether crashes muck up the works.

Conceptually this sounds great, and the 99c price makes it worth a try even if further patching is needed.

I think the tutorial portion should have been made SP, so a new game would start with all players together in the tavern. As it is, I am still solo-ing through the tutorial and need to wait for others to take their turns to advance. Not a great design decision. Hopefully it isn’t like this for all PH games.

But, at some point soon the three of us will meet up. Unless my rogue dies before the tutorial ends…

Keep us updated. I’m very interested.

If anyone interested in teaming up send me an invite, my game center ID is is Juntei_ (note the underscore)

I’ll start a second game with one or two others. Anyone?

EDIT: Juntei beat me to the punch, another game underway!

Wow, it looks like you have to go through the tutorial each and every game. Silly.

I just had an invite to a juntei game and am playing as the priestess Chaplyn. If juntei and Tyler want to make another I could go for another as the mechdorf or rogue.

Tylertoo, I agree about the tutorial thing so far it is a lot of hoops to jump through just to spend turns waiting to do anything other than stumble through poorly timed pop up training screens (my first one told me it was time to learn combat and that I should fight the wolf, but he was already dead and in my rear view mirror by then). About the “if I live part”, yeah even as the pally I have no heal yet and due to oddly timed positioning I have been forced to let them hit me first since I have no range.

I think I just ran my into my first bug. After killing the Wolf and ending my turn standing on it, next turn it stood back up and attacked even though it could not be selected. It was animated and could attack but it could not move or be attacked. Yeah for undead wolf turret!

And who name their hero “new hero”?!?

Oops never mind, “new hero” is the default name for turn 1.

Has anyone figured out what the red number means? Sometimes I have seen 10, 4, and 6 but I don’t know the meaning. Also is the game supposed to make a beep when it is my turn?

I’m up for this if anyone wants to play. Just downloaded it. Josemas99 on gamecenter.

No, those numbers don’t make a lot of sense.

No, the game notifications options have only banners and alerts, not sounds.

Arg… would be nice for an alert. Oh well, there is a lot of compulsive checking of the iPad today.

So… this is reminding of why I don’t like asynchronous games. None of the games are out of the tutorial.

Yea, two days in and in both my games I’m waiting for turns to get through a tutorial that teaches controls which are not at all difficult. As I said before, the tutorial should be either SP, optional or at least done in one turn.

That said, I’m looking forward to getting the real MP portion going, and optimistic the game will begin to come near the potential of its concept.

Tavern door! A party has reached the tavern door!!!

Both games seem to be progressing today. Is there a time that might be good to pound out some turns? We are about to be at the multiplayer part. =)

Game 1: Tylertoo, Dream?

Game 2: Juntei, Dream?

I will toss out 6:30 Pacific Standard Time just in case that works. If not another time would be fine. Thoughts?

So… what a piece of shit this game is.

In our Game 1, the three of us made it to the tavern. I could find no way to actually enter the tavern. So I hit end turn, prompting this message:

Fuck.

At which point I hit restart and then get this:

And now that’s all I get. A black screen.

If I screwed up our game, I apologize. But this is not even worth 99cents. Avoid.

What the…? I saw us in the tavern, even though I never went in there and saw an option to start quest 2. Now I see us three on the road and the turn is waiting?

Now what?

I just saw this on F5 blog:

Nasty Bug Warning!!

There is one particularly nasty bug that I want to let you all know about so that you can hopefully avoid it. I’ve had a few people tell me that upon returning to a game they are presented with a ‘The Party has Perished’ popup when there doesn’t seem to be any reason for the party to be dead. On this popup the only option is to hit ‘Restart’ and, if this happens to you, I highly advise that you DO NOT hit restart. If you were in combat, and you see a replay where the monsters killed the last player in the party then, obviously, your party really did perish and you can safely hit restart to jump back to the last campsite you had visited. However, if this appears out of the blue it appears to be a network error and hitting restart will likely take your party back to the very first level!

If you do run into this bug, try the following. Instead of hitting restart, tap on the menu button in the upper left and tap either back or resync. Because we believe that this is a network issue I believe that re-syncing with the server will fix it and allow you to continue playing the game. If you do run into this bug please let me know! If you try the resync solution please let me know if it worked for you or not. This is definitely something that we are working to fix but it is probably going to require an update through the app store and I don’t want anyone to lose their quest progress in the mean time.

We can restart and get there pretty quick if we play at the same time. It was only like 4 or 5 turns.

Thanks, Chaplin, glad to know the ‘perished’ message is a bug and not a fuckup on my part.

That said, I don’t recall if I hit restart or not. I do know that I rebooted the iPhone, and now both games I’m in seem fine. Onward (with skepticism)!

For what it is worth when I read this I checked and I had a turn waiting but nothing was different and I could not do anything. I hit the “resync” option and saw you move then I could take my turn.

Hope to see folks for a 6:30 run. I have heal on both characters and some rings, but I don’t know what they do.

I’m looking and standing by. I am also leaving messages in the in game chat. It looks like Tylertoo might be there but not sure about Dream.

I’ll be interested in hearing further experiences. I want to get it but the feedback overall on sites are all over the place and the lack of randomization worries me.