Qt3 Classic Game Club #2: STAR WARS: JEDI KNIGHT (Dark Forces II)

Yeah, there was a level in JK where you were standing on a moving platform over this abyss, and you had to jump to another moving platform as it passed by. OMG did that twinge my fear of heights.

Tom’s Jedi Knight retrospective at IGN. I’ve never heard Tom speak so fondly of the Star Wars universe.

Well, on Win8.1 x64 I had to cross some hurdles to get this to run properly.

First, installing the game wouldn’t work - I used this tutorial to do a manual installation.
I also installed the mods I linked to above, and then added a never version of the unofficial patch I found here.

At this point the game ran, but I got a black screen with only UI like Vesper explained above. Maxing out screensize resolved the black screen, but removed the UI. Toggling on the crosshair brought the black screen issue back.
However, I found I missed that there are 32bit modes beyond the 16bit modes in the resolution selection screen, and switching to 1920x1080x32 made the graphics appear and run both with and without crosshair. Hooray.

Then I shot some enemies and rounded some corners, fell from a ledge and the game crashed upon me. Let’s hope this was an outlier.


I just remember grinding my way through that endless sniper level.

Don’t remember that. I remember being frustrated by snipers in Jedi Outcast.

Also why didn’t the team behind Jedi Knight make another game? I remember they were supposed to do StarCraft Ghost before it fell through.

That was my first thought too–Nar Shadaa, but I was mistakenly thinking of Dark Forces: Jedi Outcast

So, I made it through the first level finding ONE louse secret of six. I’m no longer used to this shit. :p
Promptly replayed the level and found all but one. We’ll see how it goes next level.

The one I found in my first playthrough was one I actually remembered back from when I played the game for the first time - the one on the lift.
I also remembered I thought it was so cool to see that freighter from TIE Fighter docked and trying to jump over. I tried again (unsuccessful, of course) for old times sake.

From todays point of view, I find myself longing for a LOT more detail in the levels - with the minimalistic early 3D architecture, the cantina looks like the dockyard which looks exactly like the living quarters, barring a few textures that still do little to give away the purpose of an area.
But gameplay is fast and blazing through the levels guns blazing makes for a great retro experience - you don’t get that in the modern MW-clones.
It was only the first level so far, though - we’ll see how it goes. I’ll continue on tomorrow.


Glad you’re enjoying it! I’m having great fun with it so far.

Heh, I found only one secret in the first level too. Surprised how badly I’m sucking, in fact. I’m going to try again tonight.

After the fourth death on the first level (on easy mode), I remembered why I hate FPS games. You guys enjoy.

I loved Dark Forces, and I loved Jedi Outcast, but I remember not being too fond of this one. My memories of this one are frustration with the level design and being underwhelmed by the lightsaber and force power feel. It has been almost 20 years now I guess, so maybe I’ll be more forgiving this time around. Or maybe I was just being a sourpuss at the time.

On one hand, I’m loving that the game doesn’t hold my hand as I work my way through Nar Shadaa. On the other hand, the game isn’t holding my hand as I work my way through Nar Shadaa!

And 1997 looks really rough. The audio is doing all the heavy lifting. I’m going to have to try those texture and character mods rezaf linked.


It is holding your hand – there’s autoaim! (Though I found it got in the way when trying to shoot vertically downards at people).

Oh, I have no problem killing dudes. I just have a problem knowing where the heck I’m supposed to go. Years of Call of Duty have conditioned me to just walk forward and the next set of dudes will appear. What’s all this exploration nonsense? Hey, there’s a guy way up there shooting at me! How am I supposed to get up there? Am I supposed to get up there? Where’s my waypoint marker?


I thought the pacing in the first level was alright. It definitely kept me going in the right direction. There were always enemies in the direction you needed to go. (Of course there were some rooms packed full of enemies in the direction you didn’t need to go… but I shot them all anyway).

The only thing it didn’t help me out on was pressing a button and running through a tunnel out of a hole that was closing. I thought it wasn’t possible at first, but that’s only because the dumb civilian AI kept getting in the way!

I’ve gone crazy and recorded my first 30 minutes with the game. If you like bad commentary, technical problems, and awkward pauses, check it out.

Tried getting it running for about 20 minutes and then decided I’ll sit this one out. I never much cared for JK in the first place, and I’m not about to downgrade my video drivers by half a year just to get it running.

You all have fun now!

Going to try and fit a few hours of this in on the plane, or perhaps in a hotel room. I remember this was one of the first games to ever give me a serious sense of vertigo. Will be interesting to see if it still has that effect.

Enjoying your stream, kentdog! Man, do you ever save your game? I die a lot more than you do. :)

Though I never have had any motion sickness issues playing them when they came out, when I go back to play them now I get super queasy and can’t really play for too long in one sitting.

I finished the first mission! I was pretty lost for a while, but figured out which buttons to push and which doors to go through. I found 3/6 secrets, but apparently earned no stars. How do you earn stars? Anyway, I was rewarded for finishing the mission with another painfully bad FMV. When do I get my lightsaber??

All in all, better than Bioshock Infinite :P