Rebel Galaxy Outlaw

Two very minor complaints:

The sound mix appears overall too loud. Beeps, notifications etc. Played with both 2.0 (Gigaworks T20 speakers), monitor built in speakers (that has always been low volume even when maxed out for everything else including Windows system sounds, Anthem and The Division 2) and Logitech G933 in virtual surround 7.1 mode.

The monitor speakers have never been so loud with anything else ever than with this game.

#2 minor annoyance is when I go to the launch pad from the concourse I don’t expect pressing B to launch me into space since there’s a button right next for that. I expected it to take me back to the station. Granted I got conditioned quickly because I played for 4 whole hours but did anyone else have this expectation that pressing B would go back/cancel our of launch pad?

Nope. It’s great. You’re in the bar or the commodities menu or whatever, and you want to get to space quick? Just hammer on the B button.

I tried with my Xbox 360 controller but I just can’t. It’s too heavy and I just don’t have any control over anything. Has anyone tried it with teh PS4 one? I always preferred the PS controllers since I only own PS consoles throughout the years. Does it work on PC? If it does I may buy one to try it.

I played a bit with mouse but got reamed mostly because I have no idea what’s happening. “Shields down, hull breached” is my theme song.

I did figure out another issue I had though. I felt that the protagonists voice sounded tinny, even in RG. I figured out it’s my Dolby Digital Surround thing. When I turn it on voices get tinny and it’s super noticeable for the Female Voice but it’s actually all of them. Without Dolby I don’t have good 3d Sound though and it’s a bit flat. Will have to tinker some.

Happens to me all the time and annoys me greatly too. That’s not how it behaves in other screens, is it?

Yes, I just did this exact thing, set off before I’d finished looking at missions. First time in space, no idea what to do, hit autopilot which took me… somewhere, and then died during a pirate attack. I wasn’t really concentrating admittedly, trying to figure out how to control ship speed and where the speed indicators are. Time to watch Travis’ Welcome video.

Performance is pretty poor on my rig. I haven’t updated the nvidia driver for a few months so I’ll start there, otherwise time to start turning things down!

I like that the game just throws you right into the mix. Granted, it took me a bit of trial and error to figure some things out, but most of what you need to know can be found in the various menus.

For a game this combat heavy, autopursuit is a stroke of genius.

The mission waypoints could use some color variation, as a quicker way to distinguish between pirate/kill missions, trade missions, and probe missions. But thats a super minor complaint. After a few hours the navigation susses itself out.

My main motivator so far has been the upgrade path. Very eager to grab one of those other ships. ATM i’m kitted out with two combat lasers and a power generator. I can get 17 seconds of uninterrupted linked fire. More than enough to deal with these early low to moderate risk missions.

Everyone should join the various guilds. Opens up way more well paying missions.

Kudos to DD! This one is lookin like a winner.

Oh, and count me as a huge fan of the CRT effects. Inspired!

Or order this 'Amazon Basics’ X-Box One Controller. It’s half the price and works great. I’ve been using it for RGO.

I’ve been having lots of problems getting this to run smoothly, finally dropped it to 1080p (my monitor is 1440p) and pulled down shadow and blur quality to medium / normal, and used windowed fullscreen and I’m finally getting a consistent framerate at what appears to be 60 fps. Before that it felt sticky; doing a roll, the stars didn’t rotate smoothly, but about 4-5 times a second there was a slight pause, enough to throw the feel right off.

However, I’ve yet to eliminate another problem which often crops up in some games, and that’s a dramatic pause (1/4 second or so) immediately before any vocal sample plays. As you can imagine, in the middle of a firefight with lots of chatter going on, it becomes a slideshow until it resolves itself. Unity does this all the time, but I thought this was a custom engine? It drives me absolutely nuts and I’d pay good money to figure out how to fix it!

Also, as if that wasn’t enough, I keep getting cloud sync errors from Epic. Perhaps because I’m launching and quitting frequently trying out different graphic configs. I turned off cloud sync and, for good measure, used -EpicPortal on the shortcut, and that has certainly fixed it!

Anyway, not a great first impression, but hopefully once I get into it I’ll forget my woes. The controller still feels weird to use, but I tried the mouse and, well let’s just say I switched back.

Those audio issues raise a red flag. Might be worth a try disabling your audio device in Device Manager and see if anything changes on the performance front. Aside from that, what video card do you have?

The first thing I’d check when audio issues start appearing is if your CPU is being choked (100% usage spikes)

I’ll check those things. @KevinC GPU is a 1060, cpu is an i7-6700HQ (it’s a laptop), 16 Gb RAM. It has a 1080p screen so while a 1440p monitor is well within its capability, I tend to be more realistic when it comes to more demanding games. Regardless, the audio pausing happens whether it’s running on its native screen or not. Could it be throttling? Possibly, but it’s certainly not consistent, and even undemanding looking titles will do it (usually those running Unity).

No CPU spikes from what I can tell, not even close to 100% utilisation when I got a pause. It feels like it’s caching something in and pausing to catch up. Some Unity games will pause when there’s a new sound effect, but will play that same sound again afterwards without trouble. This feels like it’s doing the same thing, but I’m not sure really.

Ssd or regular drive?

I’ve got it installed on a mechanical drive with no problems at all. Loads fast, runs fast.

Yeah, that was my biggest issue last night. Overload (aka Descent 4 in everything but name) was a much easier transition for me. In that one I started on the joystick, but discovered the controller was so intuitive a switch that I didn’t look back. In Rebel Galaxy Outlaw, it’s obvious that the controller is going to have quite the learning curve. Pressing Left Stick in for afterburner I’m used to now after playing enough last night. I’m also getting used to rolling with the right stick now. I’m still not sure how to maintain my vector while turning the ship, but I figure that’s a more advanced lesson for another day. Until then I’m trying to get used to holding the left trigger down to auto-follow.

I’m not sure auto-follow is a good crutch at the beginning of the game though, I feel like I should be getting used to the controller by adjusting the speed of the ship myself.

I think tonight what I’ll try is:

  1. Plug in my Sidewinder Precision Pro, and try out HOKAS. (Hands on Keyboard and Stick). That used to be my favorite setup for space sims historically.
  2. Depending on what happens with 1, go back to the controller and try disabling auto-pursuit and try manually adjusting speed, and learning how to maintain momentum (is it a button press that does that, like in the Wing Commander games?)

Glad to see you got this sorted my friend.

Btw, I found the post above in this fast moving thread where Scott posted Travis’ video on drifting.

Edit: Aha, I missed this the first time I saw the video since Travis only mentions it once, and if you blink you’ll miss it. He said you hold down the Throttle down key. That’s what lets you drift. And then he used his afterburners to maneuver while holding down the throttle down key.

I think when I try the HOKAS setup tonight, I’ll probably go back to my old Wing Commander/Freespace setup:

Tab: Afterburner
A: Throttle Up
Z: Throttle Down

Everything else was changeable between different space sims. I think the command menu is important enough I might assign it to the Shift key.

Gamepad works pretty well in space for me but I do find some of the bindings awkward. Left bumper plus up to lock nearest enemy isn’t great, and I wish auto follow was a toggle so I didn’t have to hold down the left trigger 100% of the time.

Also dumping power to shields is in the radial menu but I do it all the time; would like that on the down directional pad rather than third person view which I never use.

Gamepad is awful playing pool, doesn’t have sufficient precision.

According to a post on Reset Era (which is weirdly down on the game*), if you hold B, it kills the engine without losing momentum. Haven’t had a chance to try it out myself.

  • Travis, judging from the comments there you may want to make that tutorial video prominently available in game. Or at the very least prompt people early on to press Start (or equivalent) so as to bring up the controls (you could disguise it as a prompt to look at the mission log I suppose). I’m always amazed that people don’t press the pause button straight away in games like this to look at the controls, but apparently they don’t.

Controls really are very poorly tutorialized. The game would benefit from a short “sim” teaching all the controls. You can figure it out on your own obviously but we expect more hand holding these days.

Left stick push for afterburners is awkward too.

I mean, even in “the old days” there was hand holding. It just was printed on paper.

So yeah, if there’s no manual (at least on PDF), the game needs to teach itself. 42-minute videos, however good they might be, are not solving the problem!

I want to say that Left Trigger for afterburners would be so much more satisfying, but I guess the autofollow is such a big part of the controls, that had to go somewhere. They still could have switched the two if they made autofollow a toggle instead of a permanent press.