Red Dead Redemption 2 - For a Few Redemptions More


#1385

When I ran into the big circle of them of I just stood there and watched for a few seconds before thinking ‘fuck this’ and tossed a stick of dynamite into the middle. First time I ever used a stick outside of a mandatory mission. Just always seemed like overkill.

Turns out those robes are rather inflammable.


#1386

Ok, I can’t get this to work. If I hitch Grace and use the horse station at camp then it fades to black and it swaps Grace with Ed. I can’t get both Grace and Ed out of the stable at the same time. I have a 3rd horse that is kinda shite that I use for hauling, but I wanted a lvl 4 bonded horse for the whistle range and those are both stabled.


#1387

I came across an O’Driscoll camp and as I geared and buffed up for the fight I imagined myself flowing in all John Wick-like. What ensued instead was more akin to a scene out of the Three Amigos. But it was fun!


#1388

Well I had myself all ready to go get more lumber for the house under construction, but as I rode up toward it I saw that the house looked fully complete. So I talked to the guy who verified they had finished and sold the place, and he paid me for my assistance. I guess the earlier request for more wood may have been a glitch?

Anyway, I only had one more mission in that chapter, so now I’m on to chapter three! Who knows what trouble I’ll get into.


#1389

I happened across a camp for another gang who apparently are hillbilly cannibals. Killed everyone in the camp. Then, while riding around at night 30 minutes later or so, I hear “That’s the guy!” and was ambushed by 15 hillbillies running out of the wood with tomahawks and lanterns.

I also chased a magical dwarf around the woods for awhile. I feel like I’ve started to find the weird part of the game.


#1390

This game really needs a safety for the guns and my fists. Also people should really lock their horses up, because god dammit some of them look identical to mine and I can’t be held accountable if I jump on the wrong one.

So I keep laughing every time Arthur laments being a bad guy. I can’t seem to break 75% good because of unintentionally shooting, beating, and stealing.


#1391

I was going to do that, but then they set themselves on fire and all ran away. So all I had left was the Grand Wizard. He didn’t live very long.


#1392

I’m guessing you don’t use the mini-map, because it always shows you your horse.


#1393

Playing poker around a table, randomly seated with Uncle and John Marsten. During the second round of poker, after Uncle busted out going all in on round one, Arthur goes, “Why don’t we make it interesting? Loser has to strip and jump into the pond? Oh, that’s right, Marsten can’t swim!”

I laughed.


#1394

The Drinking with Lenny-quest is just the best quest EVER! I enjoyed it so much I replayed it right afterwards. No idea how you can ever avoid getting captured though…


#1395

You mean at the very end? I didn’t get captured, woke up in a field miles away from Valentine.


#1396

Well done! I managed to flee for about 20 meters the first time. Second time I ran into the first possible post… :-).

Sheriff is real nice about it though.


#1397

Wasn’t bragging, it actually didn’t occur to me that you could get caught by the cops at the end. I assume you wake up in jail?


#1398

Yeah, for me, I failed to climb a fence, and fell in the mud, and woke up in jail with Lenny.


#1399

As I understand it, you have to run down the alley w/o running into anything, then successfully turn right and jump over the fence. I failed at that part (hit ‘A’ instead of ‘X’ (XBOne).

Quick question - I don’t know if this is a ‘bug’ or ‘feature’ (or both) - I used the index on the map page to find where the nearest trapper was after taking down the legendary bison up north. Since then, even though I turned it off, every time I go to the map, the index pops up. It’s annoying to have to close it all the time, and the only way I can get the map to go back to ‘normal’ is to completely restart the game (ie, home, quit game, launch). Does anyone know if it’s possible to turn that damn index off and have it stay off until I need it again?


#1400

Didn’t see it as bragging, no worries. Truly impressed you somehow managed to run away.

You do indeed wake up in jail, and have to pay a small fine (that Lenny takes care of). Then you get to have a nice conversation with Lenny afterwards.


#1401

Yep, this happened to me as well. Someone upthread mentioned it as well, just a bit after the game launched, and my Google fu has failed me. It’s super annoying to have to close it every time I open the map. Probably a bug, would be my guess.


#1402

That may have been me that mentioned it. I’ve gotten used to it now. I didn’t know that closing out the game temporarily fixes it, though.

I also managed to complete that mission without getting arrested but was surprised that Lenny escaped the hoosegow because I totally saw him get busted before I ran off shouting “you’ll never take me alive!”


#1403

You have to use the minimap for the horses if you travel around with more than one horse, because one is constantly getting left behind. Go play around with 2 or more horses and the stables - it completely removes the other horse from the world.

I haven’t figured a way to actually remove more than one horse from the stable. That’s the issue. Once it’s in the stable it seems to be one horse at a time.


#1404

Maybe Rockstar will patch in packmules or wagons we can rent or buy from stables. And warpaint for our horses!