Rise of Legends, patched manual?

I just bought ($10) and installed Rise of Legends. The autoupdater promptly installed 12(!) updates.
I assume some of these patches has changed the game and units quite a lot since when the manual was printed.

Is there a patched manual somewhere?

No, but just know that anything you really need to know is outlined in the first few levels of the Campaign, and subsequently each race is explored in the same vein; a brief opening level or two that gives the basic rundowns of the race’s strength.

I bought it for 10 dollars too, from Gogamer.com I really enjoy it.

If it’s balance changes you’re worried about, the verbose tooltips will show you all the numbers.

I really wish the game would have gotten a much larger following. I really enjoyed it, but the online play was a tad bit wonky. Is the Qt3 clan still in existence?

I’d be more inclined to bet on the existence of MechaHitler. It has been more than three weeks, ya know.

I love playing this online with a few of my buddies who I’ve convinced into buying it.

If we could get a group together, hey, who knows?

If I wasn’t drowning in new releases, I’d be on this in a New York minute. I log on every now and then to despair at how few people are playing.

I’ve had a few good Shoot Club games over the last several months, and I’ll eventually come back to this. It’s an excellent game and Big Huge at their best. I recently revisited Rise of Nations and was pretty surprised at how much better Rise of Legends is. I loved Nations, but if you’re not in it for the subject matter (history and modern-day units), Legends is so much better in so many way.

Single player campaigns excepted. I wonder if anyone ever modded a free-form Conquer the World campaign for Legends.


I thought Shoot Club was fiction!

Is the single player campign really that bad? Given my current family status (Al Bundy, but younger kids) I doubt I’ll enjoy any multiplayer anytime soon. Plus, I suck mightily without a pause-button.

Sounds awesome, I’d really like to know if this exists. Sounds like something I’d pay for.

Singleplayer was all I played. I loved it mightily. Okay, so the story’s not very good, but that didn’t make that much difference really. (And I’m normally a big storyphile, for what it’s worth.) A full, unrestricted Conquer the World mode would rock, though.

I found the campaign rather boring. Playing on the generic battlefields became really annoying because the build-up phase is rather slow, and characters and story didn’t get me really excited either. The upgrade system was nice though and kept me playing.


It’s pretty hard to play Rise of Nations with it’s 8-bit sound effects now.

Is the game still being supported patch wise by BHG,or have they moved on?

I thought it was a tiny bit slow, but overall I really enjoyed the campaign. I just wish I’d played it on hard mode instead of medium, since medium level had some constraints on the AI.

I like the campaign. I"m slowly plugging through it, and I’m not getting into BFME (1). But yeah, since no one plays the Multiplayer anymore, singleplayer is where it is at, and the campaign is fun as well.

I played it through on Hard Mode earlier this year-it was very challenging at times and required some definite “out of the box” thinking by the time you get to the Cuotl area, but you can never really “screw” yourself since if you lose a fight you still get income for upgrades from your provinces.

By random chance, I was playing it earlier this week.

It’s not that it’s bad, but Rise of Nations’ campaign(s) were better and more open-ended.

Rise of Legends’ campaign is basically a bunch of campaign missions that you can do in pretty much any order (beads-on-a-string style), with the meta-map stuff having relatively little effect on the per-instance RTS battles.

RISE! :o

So, I was hankering for some Alin-ci-uotl action and reinstalled this but keep getting an error - INVALID PATCH - when I try to update. I get to patch 9/12 and it kicks me out to an error message.

MS support tells me to uninstall, update drivers, blah blah, reinstall and I did that but still no joy. I tried deleting the patch folder and updating via connecting to the multiplayer server and had no luck.

I can’t find the patches for download anywhere so I thought I’d try the hivemind.


I had the same problem last time I installed. There is definitely something wrong with the patcher or the files that are being hosted. I’ve seen other reports of this.

I ended up finding a zip on the internets that included all of the patch files. Although, it’s been a while, so I don’t remember where I found them. Google for them.

EDIT: Found them. I got this from http://rol.heavengames.com/cgi-bin/forums/display.cgi?action=ct&f=2,864,0,all

Patch files:


Just unpack everything into your RoL-directory, leaving the structure intact. The *.rtp-files should go to a folder called “patches”, and batch-file should be placed in the main-directory. Double-click on it und the fun starts.

Awesomeness! Thanks muchly MMcGlumphy! Take the rest of the day off :)