RoN. Why Don't You Work Any More?

EDIT: I’m using XP

Ok. Put me in the “RoN doesn’t play category”. After a solid month-and-a-half of RoN being a fine and upstanding program on my hard drive… now RoN does one of two things: Either it works and then crashes, hard, when I try and exit. Or it works and then crashes soft to desktop during the game. Pisser.

The only difference is Nvidia drivers. I’m a fiend about stability so I’m loathe to change drivers unless absolutely necessary. I was running the late 30. whatever series and all was well. I upgrade to 44 (most recent) and crashahola. I downgrade to 41 and… worse. I also installed the second patch, but this was happening before, and after, that.

I’m curious. What Nvidia drivers are you running if RoN works (for those with GeForces) and for those of you who have problems with RoN, what drivers are you using? I’m going to roll back to the older one’s, regardless.

PS: I moved the sound card as Denny suggested and defragged as Loyd suggested. It’s helped my sound stutter problem by about 70%. It still does it, but not as much. Oh, I noticed there’s one of those 2 slot USB things in there. Not a PCI card, the kind that plug into the motherboard with a… plug. Someone once told me not to use those. Could that be a contributing problem?

At least under ME, I’ve found the RoN doesn’t work with recent Nvidia drivers. 30.30 and 29.42 work fine–even though RoN dsicourages their use at boot. The more recent ones tend to crash the program instantly.


Latest Nvidia drivers here under XP, with a Ti4600. I’ve only had two RON crashes in the entire time I’ve had the game, both crashes to desktop.

The USB connector’s not going to hurt anything, and whoever told you not to use those was talking about their (non-mouth orifice).

Given the onset of stability problems and the sound card problems, I’m starting to wonder if perhaps your power supply is starting to go south…

That’s odd Denny.
I’m using a Ti4600 as well and have had nothing but problems with those drivers (GTA III VC started crashing too).

5800 Ultra (hoover removed), 44.03 drivers and no problems here.

I am using 43.45 with my Ti4600 and RON has been very stable so far.

FWIW installing the RON 1.02 patch locked me entirely out of windows due to an authentication problem after reboot.

I did a “repair” install and it fixed it, but DAMN!


I’m running XP, a Ti 4200 and version 30.87 driver and it works great. Not a single problem (except my processor is only 1 Ghz). :(

Anyway, I had switched back to the 30.87 before RoN was even released when the latest driver was giving me compatiblity problems with Combat Mission. It works great for both. It ain’t broke, so I ain’t fixin’ it.

edit - I have not installed the version 1.02 patch yet however.

I’m thinking it was a bad patch on my part. I went back to 44whatever. The newest drivers. Then uninstalled the whole shebang and reinstalled. Reinstalled both patches and, thus far, no problems.

Hi Andrew, et al–

That’s the correct solution: reinstall and repatch. Apparently those who got the second patch in the first day or two it was up (which is unfortunately a lot of our most hard core fans) have been experiencing these stability problems because of a missing file or file(s). The problem is solved by reinstalling and repatching.


Brian, I still have a problem where it crashes pretty hard when I try and exit a direct IP multiplayer game, or one that fails to connect. Luckily, I can “three-finger” my way out of it, oftentimes.

Thanks for posting on this forum, btw.