Shroud of the Avatar: Forsaken Virtues


#323

Yes, and unfortunately the single player part is way behind the online part, and likely will continue to be so. So, the selective part is not really very selective, if you want to experience the game. Last I played, they were two very different games, where one had gotten all the developer updates and attention, and the other didn’t.

On top of that - Even though you are supposed to be able to play it as a single player, offline, rpg, you really can’t, since the entire game is designed as a multiplayer experience, with obvious MMORPG mechanics.

Quite a lot of us backed the game because of the single player, offline rpg experience - Sadly, we don’t contribute the same money that the online whales did, and still do, so thats where the focus is, and will remain.


#324

That’s interesting that online/offline are so disparate. I wonder if I was online or in SP when I fired it up the other day.

EDIT: I must have played online. From the menu, I assumed the Offline option was disabled/greyed out, but it can still be selected. If the offline stuff lags seriously behind what I saw in the Online mode… egads.


#325

Wait…so the Single player is a totally different game from the multiplayer? I was under the impression single player and multiplayer were the same and you can switch between them?


#326

Well, there is single player Online, and single player offline. Online is a bit more like the multiplayer, but of course, since Multiplayer depends on you paying real money for housing for instance and the like, there are differences. Also, they turned off monster spawning in single player in some areas…well, at least they did when I played a few months ago. Its a bit of a mess.


#327

How does online multiplayer depend on “you” paying real money for housing…exactly? I think that is highly optional unless I am amiss in a weird way. For instance, does a quest require it?


#328

Ah, thats just me not being eloquent enough in english. Its a complex situation actually. What I meant was - in the online multiplayer part, you have people who have bought entire villagers, even some who are named Lords because of the packages they bought for real money. SOME of these housing options, deeds for land and so on are purchasable by in-game gold as well, in the online multiplayer sessions.
This means, that, seeing that this IS an online game, with lots of players, it has to be expesnive, and require a lot of gold, which requires a lot grinding , selling to other players and so on, to be able to amass this gold.
These housing options are available in the single player online and offline economy as well, but here, you CANNOT sell to other player, you CANNOT grind several places, because monsters don’t respawn in the same way and so on.
So - the economy is more or less broken, and showcases some of the difficulty you have with smashing together these three kind of different playstyles.

There is a lot more to it, but, basically - The game isn’t very good. That is aside from the horrible UI, the messy combat, the poor animations, but on TOP of all those things you have stuff like the economy which is just bonkers. Unless of course you have 100 hours to grind in your single player rpg, so you can purchase a cottage.

I am exaggeting some things slightly, but this is more or less the situation the game was in a few months ago, and has been for quite a while - I seriously doubt that will change much.

I hope this makes more sense! Oh, and no, you are NOT required to purchase any housing!


#329

I tried the free version of Shroud of the Avatar. Anyone can grab the client and play for free, with some limitations on max skill, trading with players, etc.

https://www.shroudoftheavatar.com/?page_id=69568

I played for about three hours. I finished the tutorial, explored the world map, entered a player town, checked out some random adventure zones, ran some initial quests, and got into some fights.

Overall my impression is mixed. Best part? Seems like a big world to explore, and skills etc seem deep. Its detailed and challenging. Worst part? As stated above, the animations, walking and combat are decidedly old school and it doesn’t run great. I am a bit surprised to hear they are releasing chapter one in late March. It feels like a game from 2009.

I enjoyed the old school aspects. I was expecting somewhere between Wurm Unlimited and Elder Scrolls Online, and its way closer to Wurm. Text-based NPC chats with a text parser with highlights. NPCs names are unknown to you until you ask them their name. ;-) No quest or NPC markers on the map, although it does show quest directions in the compass. You can get confused and lost and have no clue where to go, unless you are paying attention. Its entirely possible to wander into an adventure zone that is over your level and die quickly. All of this means you need to pay attention.

What are “adventure zones”? Well, in the strangest design decision its a split over-world / local map. The over-world shows strategic locations like mountains, NPC cities, player towns, river crossings and places to explore and gather and fight. But you need to enter the local zones to actually do anything like interact with NPCs, chop trees, kill stuff, run quests, etc. The local zones are pretty big so it doesn’t feel constrained - but this is not “one big world” its a bunch of separate, unconnected zones.

The inventory, gear, loot, and merchants are all detailed and old-schooly. Its got item decay, repair, resting, mana and health management, etc. This is either fun in a nostalgic way or maddening that they are skipping twenty years of MMO refinement.

I was OK with the walking. Most combat is OK. The fact that differently-aligned NPCs will fight opens up some tactical options, like waiting until the spiders have wounded the evil elf mages enough do you can finish them all off. I ran into a main quest town that was under siege alongside the town guards who did most of the fighting. I looted corpses the NPC guards killed.

But there are positioning, teleportation and animation issues. It feels a little stilted. I don’t know for sure, but it feels like they do all location tracking server-side, which means lagging players will jerk jerk jerk across the map. NPCs slide past you. Enemies will warp in close.

The apparent depth, player economy, detail, difficulty and pedigree are all appealing. I may put some more time in. Or I might look at the calendar, remember its 2018 and play something that fits with my limited adult schedule.

I will report back if things change.


#330

Did you play online solo, or with full multiplayer? Or offline? It sounds like you played online solo. Otherwise I’d have thought you commented on how the first town looks these days.


#331

Online full multiplayer. There was a small (6-10) but steady amount of people in the starting zone - Hightower? The Courage quest line.


#332

Well, it can have changed, but when I played, the town was full to the brim with weird houses, with people selling stuff out front, stocked to the brim with strange decorations from various events held over the early access period - It looked insane, and nothing like any kind of real town, but more like a MMO nightmare with full housing.

That’s when I immediately changed into offline mode, and saw the rather large differences how the world acted and looked.


#333

The player town I walked into looked “normal”. It was pretty cool.


#334

I know the game is clunky and there are a number of things I’m not a huge fan of, but it does at times really appeal to my inner (or not so inner!) Ultima nerd. The ankh is present, the Shrine of Love has a candle etched on it, the use of the runes, etc. I’m actually… sort of looking forward to this? Hopefully the single player will be reasonably fleshed out, as that’s likely all I’ll play. Not really interested in multi-player and no way I’m paying more than I already have.


#335

Yes, agreed. I walked into the first large player town I saw on the world map. It was very well done. Lots of high quality housing, all filled with furniture and NPC merchants. There were lots of NPCs and merchants in the streets, waking about. There were some non-merchant flavor NPCs you could interact with. In the middle of town was a large keep with multiple levels. I walked up the inner stairs to the roof and looked out over the city.

Steam and Reddit are not complimentary. A few of the issues appear to be silver drop rates versus RMT rates, implying it was not practical to purchase property without using real money. Can anyone comment on this?

The player economy appeals to me … if done well.


#336

An anecdote that sums up my experience.

I was on the first major quest I came across outside of the tutorial area. It was Highvale, I think you go here if you are on the Courage path. The quest was to retrieve some supplies from a village that was under attack.

I went at night. It was super intense. In the distance I could see frost creatures attacking everything that moved. Small groups of guards would run in, sometimes accompanied by players, and the frost and ice attacks would arc across the village. I ran in like 3 or 4 times, and tried to run back when my health was too low.

I died once, which meant turning into a spirit and flying back to the resurrection point which was a few minutes away. You then reappear with all of your equipment. It was painless enough. You can tell it’s old school because on the walk back down to the road I was attacked by a set spawn of NPCs. :-)

The quest was to grab 3 bedrolls and 3 grain sacks. By the time I returned it was daylight … and the attacks has stopped! A few evil elves would still appear to attack you solo, but not en mass and without the frost creatures. It was a lot easier. I found the quest items in a small building and grabbed some.

The quest said 3 of each, I grabbed 5 just to be safe.

It was a 5 minute walk back to the quest giver. It’s a nice walk, up two well animated semi-open wooden elevators that give a view across the whole zone. I tried to turn in the items but … nothing happened.

Remebering to type the keyword “help” was easy enough. When I tried to give them the stacks of 5 each the “complete” button did not light up. I tried shift-click which is default to split stack. I tried control-click which is default to take one from stack. I tried to trade them away. I tried to sell one. Nothing worked - it was a special quest item stack that was labeled [5] and did not behave like separate items.

I eventually had to delete them. I logged off then. I didn’t have time for the 10 minute return trip plus maybe arriving at night and having to try my luck or wait until daylight.

Later on I checked the website. Under patch notes and “known issues” was:

“Quest NPCs will not accept inexact stacks of quest items. Items must be exact quantity requested at time of turn-in to be recognized as valid.”

I was glad it was acknowledged, frustrated it wasted my time, confident I could go back and do it right, but confused if I wanted to.

The glimpses of depth and the feeling of exploring the unknown are tantalizing. It’s like a well populated Wurm Server with better quests, or a huge Neverwinter custom world with many zones. It’s amateurish and ambitious. It’s the opposite of what a successful MMO in 2018 should be. I will stick with it a bit longer.


#337

This is why this remains the only Kickstarter that I pulled my money from during the campaign. The more they described the game the more I realized they did not have a clear vision of the single-player campaign and instead would focus on the multiplayer.


#338

Garriot has been on this path for a very long time. I saw him give a presentation at E3 in like, 1998, in the run-up to the U9 release where he talked effusively about melding single-player type gameplay with multiplayer persistent worlds. He believes in it. Question is whether he and his team can deliver on that vision.


#339

Yeah, with acknowledgment to the importance of Ultima Online, I’ve always been a bit sad that his brass ring is in multiplayer. I feel like Elder Scrolls and Piranha Bytes games better captured the spirit of what the original Ultimas were about.

I have nothing against MMOs (WoW is one of my all time favorite games) but in the end I think they’re very different from single player RPGs. The illusion of any kind of fantasy world is being constantly broken.


#340

Thanks for jogging my memory! That was my third point of reference for how the game feels now: it’s like a PB Games MMO. (Blended with Wurm Unlimited and NWN PWs.)


#341

I played another 2 hours. I had a good time.

Negative stuff first, the graphics don’t run well. Its a specific problem with shadows. Enable them and lose 10-15 FPS (I have a GTX 980 and an i5 7600), which drops indoor scenes down to 20 FPS and outdoor scenes to 40 FPS. Disable shadows and the outdoors runs at 60 FPS, but without shadows everything looks fake. I chose to keep them on and take the hit. None of the other graphics options have a noticeable penalty.

I went back and finished the bugged quest from above, and made sure to collect only 3 of the quest items. That worked fine and I was able to continue. I completed another 3-4 quests in that chain, some minor run and talk errands and some minor kill stuff requests. There is a story around all of it, it was OK not great.

One cool moment was exploring an old church tower where the floors kept crumbling underneath me, and I had to keep track of where I was in the ruins. Climbing up and down ladders and occasionally falling through floors (and taking damage) was disorienting but fun. There were mobs to kill and some minor stuff to find and collect along the way.

One part of it felt like a giant environmental puzzle. I managed to get on the side of the rocky outcropping next to the towers and climbed down until I got to a lower level that was not directly connected. It must have been designed that way, but it felt cool like I was discovering something.

After those quests I wandered around a bit in the same zone. I found a lake with a magic boat that took me on a little tour. I noticed a path with some rope bridges high overhead. I managed to find my way up, connected back to a backdoor to the main quest area I had not noticed, then wandered into an unmarked mine.

The mine was filled with mine-like creatures, and some ore nodes, and some ore nodes that were really monsters. There were a few environmental hazards like falling stalactites or rooms that were too cold. It was fun to slowly explore and clear. Luckily I had made room in my inventory before I went exploring!

After that I continued to the far side of the mountain path and found myself on the opposite side of the village that was under constant attack. It was night-time so the dangerous creatures were out. I had some quests related to them, so I waited until the guards killed a few (and were killed themselves) and ran to loot the quest items before I took too much damage.

The skills and combat system continue to have a lot of depth. Its not pretty combat, it maybe looks equivalent to EQ2, but there is a lot going on in the background like glancing blows due to armor and an “overheating” system that allows you to skip past cool-downs for a large mana penalty.

So far for a free MMO its feels OK. Its not modern. Sometimes that is annoying, but it also makes some parts fun because its hard, completely unknown and I have to think and experiment and pay attention.

I still think it deserves all of the unkind comments it gets on Steam and Reddit. I can see why people bounce off it hard. However, I plan to explore it a bit more!


#342

Thanks for your feedback and thoughts, @milspec. You have done a good job of summarizing my experiences with the game also.

I plan to play again sometime at or near release and try the Path quests. I haven’t touched those yet so that I can experience them as they are intended when they are completed.