Slow gameplay

Hope this finds everyone doing good…and was wondering if anyone could provide some advice.

I have a system that is around 1.5 years old. It still has decent hardware however.

When playing many games, I get alot of “lag”, as in…it is not very smooth to look around the screen. I was just playing Doom 3 (which defaults my system to ultra high) and it was doing it. Same with alot of shooters. STALKER is outright killing me (playable, but hard to watch). The graphics remain great, but just very slow.

I have of course adjusted my setting, going as low as medium, cutting anti-aliasing, etc. I have also checked to make sure that no extra programs were running, and have done the usual defrag, etc. I have also run DxDiag and everything seems ok.

Could it be possible that I have a setting on the PC somewhere that is messing me up? Do any of you know a way to optimize my system?

Included here are my specs:

AMD Athlon™ 64 Processor 4000+, MMX, 3DNow, ~2.4GHz
2048MB RAM
DirectX 9.0c
Dual NVIDIA GeForce 7800 GT in SLI configuration
SB Audigy 2 ZS Audio (but using Plantronics headset…another problem there…if the headphones are on, it won’t let me use Soundblaster)
Hard Drive is only 13% full


Well to solve your headset problem (I’m assuming it’s USB), just make sure you set your default sound to your soundblaster in your Sound options for windows. You’ll have to do that each time you plug in the USB headset, so my suggestion would be to just leave it plugged in all the time.

Set and forget!

As for your choppiness the only things I can think of are vsync, like that was mentioned, or your HD is churning a lot for some reason (maybe set a static pagefile size of 2048 or something). Unless of course you have a virus scanner running in the background at the time?

Is this something that has crept up recently, as in the past few months?

Does it flat out ‘stall’ sometimes or is performance consistent and smooth, just slow?

If it is stalling or stuttering, then your hard drive is going bad.

It doesn’t flat out stall…I think I will check the vsync next.

Thanks for all of the help.

For setting the default to Soundblaster…there is no sound if I do that. I have to set it back to Plantronics to get anything.