Sound issue with games in anything other than fullscreen

So, as some of you may remember, I bought a new computer back in february, and am very happy with it.
(new computer stats)

  • Intel Core i5 13600K (13. Gen) / 3.5 GHz Processor - LGA1700
  • ASUS TUF Gaming GeForce RTX 4080 OC 16GB GDDR6X - Grafikkort
  • Gigabyte H610M H DDR4 - bundkort - micro-ATX - LGA1700 sokkel - H610
  • Windows 11 Home - OEM Licens 1 PC (Multi sprog)
  • Team Group ZEUS &#45 32GB Ram: 2x16GB &#45 DDR4 &#45 3200MHz - DIMM 288-PIN - Ikke-ECC - CL16 (Bulk)
  • CORSAIR RMx Series RM850x &#45 strømforsyning &#45 850W
  • NZXT Kraken Z53 - processors flydende kølesystem
  • Kingston NV2 &#45 2TB - PCI Express 4.0 x4 (NVMe) - M.2 Card
  • ASUS PRIME Z690-P D4 - LGA1700
  • Cooler Master Silencio S600 - Sound-Dampened Steel - tower - ATX

Except for one single issue - sound in games not running in fullscreen.

I have this issue in both new and old games, where, if I run the game in anything other than fullscreen (which defeault to my samsung tv’s audio at 3840 x 2160, there is no sound. IF I take the same game, and make it run fullscreen, the audio is just fine.

Its not all games, but quite a few. For instance, Lord of the rings online, where 4K is a horrible resolution to run the game in, because all text and inventory is supersmall.

Recently, games like Remnant 2 has the same issue, and its driving me crazy.

Anyone that can help point in the right direction of any kind of solution? It does seem its something to with the game not being in focus when in anything other than fullscreen, but I have no idea why that would be.

THANKS in advance!

Make sure your sound drivers are up to date for your motherboard (assuming you don’t have a soundcard). It looks like you have two motherboards listed in your specs, so I am a little confused.

Is the correct sound source selected in Windows when you are not in full screen?

Can you test this with a regular monitor rather than your TV?

I’d also look at the notes for any updated BIOS versions for your mobo to see whether sound issues are listed. If so, a BIOS update would be a good idea if other basic troubleshooting has failed.

I’ve found that some games can do wonky things with your set default output devices. Diablo 4, in the beta, kept trying to use the wrong sound device and it kept crashing. We fixed that by deleting all of the sound output devices we did not want/were not going to use. If your system default is your TV, it’s possible these games are for some odd reason not liking that as an output device and are on their own switching to something bizarre like the built-in Realtek audio or other motherboard audio outputs. Just a thought.

Yeah, try disabling anything other than your primary sound output in WIndows sound settings and also double checking that non shenanigans are going on with certain apps not being set to the ‘default’ output.

Ah for the days of slapping in your SoundBlaster or AdLib board and calling it a day!

Of course, it was never that easy…

Oh man, the day I bought my first SoundBlaster card with joystick port, a cheapo “flight” stick, and the Wing Commander speech pack. Happy, happy day.

Are you running OBS while the issue is happening by any chance?

@barstein No OBS no.

Thanks @sharaleo Lots of excellent suggestions here - I’ll give all this a go tomorrow.

@Freezer-TPF Also great ideas - A few questions though. How does one test what source is selected when not in full screen? That would require alt-tabbing, and then sound works again. Its only when I am running…well, full screen that ISNT 3840 x 2160 that there isn’t any sound, in all my games.
Native fullscreen I assume its called, doesn’t have any issues. If I run the game windowed at say 2560 x 1440 the game has sound again.

As I write this, I realize the headline and my description is off - sorry about that.

Its such a weird thing - If the game is set at 2560 x 1440 and fullscreen, there isn’t any audio. Then I press the windows key to bring up windows and the game gets set to background, and the audio is there. I alt-tab back, and the sound is gone. This is the same in all the games affected by this.

Sound drivers is just Nvidia HDMI driver running. The Bios idea is good - I’ll look into this!

I only have two sound outputs - And the other one I set to not use. I am unsure where to delete it though?