Sound issues

I just played the X-COM demo see if the game would work on my rig. I already know I want it, so the demo was more of a stability-test than anything else.

I was a bit surprised that everything worked, except there was no sound. None.
First I thought I had my settings or drivers wrong, but all my other games work fine and all my drivers are updated. A reboot did nothing. :(

I really want to buy this one, but I’d like to make sure that the sound works first.
Any advice?

My system data:
Windows Vista 64 bit, 8 GB ram
Intel Core2 Quad CPU Q9550 @ 2.83 GHz
NVIDIA GeoForce GTX 260 / 4GB
SB X-Fi Xtreme Audio

Does your motherboard have built-in sound? Is it disabled, or does Windows still see it? It might be “numbered” (Windows keeps active sound devices in an ordered list internally AFAIK) with a higher priority than the “default” device, so if XCOM for some reason isn’t obeying the default choice, then it’d go for the internal card first on accident.

At which point disabling it in Device Manager should solve it. Probably :)

Interesting. Where would I look to see if Windows still “sees” my motherboard’s sound systems?

To say up front, I’ve got a similar setup (SB X-Fi Xtreme Gamer, IIRC, plus onboard audio). Not entirely as sure on Vista, but in 7, I right click on the volume icon in the taskbar, then choose Playback Devices. Your Soundblaster should have a check by it, denoting it’s a default device, but if it has multiple output formats (for instance, mine has Stereo and SPDIF) or if you have multiple recognized devices (I also see an entry for Reltek High Definition Audio") there will be other options there.

Disabling them can be done through Device Manager in Control Panel (again, not entirely sure on the fastest way to access it on Vista as I’ve never used that OS for more than a couple of minutes at a time on friend’s PCs).

Interestingly, I find having two audio devices handy. 7’s “Default Device” switcher overrides MOST program’s on the spot, so I keep my 2.1 system hooked up to the Soundblaster and my Sennheiser headphones to my onboard sound. Switching default device in that Playback Devices dialog immediately sends all ongoing audio signals to the newly chosen option, so I can switch between rocking out while home along to quietly gaming when the lady comes up. It’s nice!

But if it causes issues with XCOM, you might have no choices.

Finally, to conclude, this might be nearly a thousand words of text all told for nothing because it is TOTALLY probable that your problem has nothing to do with this :D

Thanks!

I have exactly the same setup as you, with headphones and speakers. And I also switch via “playback devices”.

But, alas, I tried all three different choices I have (speakers, digital through SB, and headphones), but to no avail.
It’s wierd. Every other game I have works.

What are the odds that this is just a thing with the demo, and the full game will be fine? I haven’t preordered yet…

I’ve heard that the demo contains more content than it appears to, which suggests it could easily run the full game if given additional commands to continue on. It is, necessarily, an earlier build of the game (they’ve said bugs in it will be fixed in the full release), but it might be worthwhile to shoot something to their tech support prior to release to see if they’ve run into the issue in QA and can conclusively state it’s been fixed now. Otherwise, I fear it might continue :(

No idea what it is for you, but these are the last 2 sound problems I had to deal with -

  1. graphics card audio-over-HDMI driver fucking shit up, needed to be disabled in device manager

  2. certain audio from a game not playing at all, had to drop the output from the sound card control panel to 16/44.1 to make it work.

I dropped the sound card to 16/44.1, no effect. :( I didn’t reboot afterwards though, so I’ll try that tonight.

I looked in the device manager for the graphics card for any setting to disable sound over HDMI, but I couldn’t find it. Where did you find yours?

Under sound, video and game controllers in the windows device manager.

It often won’t show up under the Playback Devices tool unless you’ve actually got a sound-capable device (like a TV) hooked up to your GPU via HDMI. Should still be in Device Manager like djote says, though.

It’s been a while since i worried about separate sound cards (i do have one for music creation though) for gaming. Have you tried simply plugging your speakers in at the motherboard sound output port (often a green/lime coloured output) in place of your sound cards port?

Thanks for all your advice.

I tried the various sound output ports, including the motherboard one.
They’re all silent. And only for XCOM, everything else works fine.
I don’t have a sound-capable monitor, so, as Armando said, I have no sound-through-HDMI setting to disable.

I beginning to think it’s simply something weird with the demo.

Ah, f*ck it. I’ll just buy the damn thing anyway. I’ll play in silence if I have to.
But if any of you would stumble over anything that sounds like a solution to this problem, could you please PM me? Thanks again.

This might be painfully obvious and even be perceived as rude of me to even ask about. . . but you have emailed the devs/submitted a ticket/noted the bug in their forums, right?

Rude? Never!
You’re at the top of my short list of Helpful People for XCOM Sound Issues.
Very prestigeous list, that.

I have emailed 2KGames. I’ll let you know what answer I get. Should I email Firaxis as well?

Yeah, honestly. Dunno how much the support drones at the publisher will have access to pre-release, TBH.