Steam running in compatibility mode

When I shut down Steam last night windows told me “blah blah we set compatibility settings on steam.exe”.



Where are these compatibility settings and how do I disable them!

I had the exact same bug, but for some reason while troubleshooting Civ 5 I’d turned on run as administrator. Unchecking that made the warning go away and steam run normally. I don’t know what that means in your case.

Yeah, that seems a little odd. It’s true that Steam doesn’t want you to run it in Admin mode or in any compatibility mode, but I’ve never seen that message when it was about a particular game. You might want to consider a repair installation of Steam just to make sure there’s nothing wrong in the main program.

Does overwriting an executable file cause Windows to reset compatibility configuration for that file? I’m guessing the compatibility settings are identified by pathname and stored in the registry.

Overwriting the executable doesn’t, but moving it does, since as you suspected, the compatibility settings are stored in the registry and indexed by the full pathname. Look under HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers and see if you can see anything Steam-related.

It’s also possible that it’s picking up the flags from a shortcut to Steam rather than the Steam executable itself, depending on how you launch it.

Ah. I’m launching from my taskbar shortcut. Is that the same shortcut as appears in the start menu proper?

EDIT: Actually, the screenshot above is from me launching the game directly. There is no shortcut funny business going on.

I had that. I think I just ended up hitting cancel, and I haven’t had any trouble since.

Which…probably isn’t very helpful. Sorry.