Stuttering in games

I was just wondering if this would be a problem for not having enough memory. It seems that in all the games that I’m playing right now (Ron, BFME2, at some point GW) if I move around alot either thru the map or a character the game stutters a bit, I still have perfect control over the mouse cursor, but the game stops and starts.

I have one gig of memory, not 3200 in this machine, and I was just wondering that with the memory I’m going to use in my new computer (2 gig 3200 kit) would this problem go away?

Could be your graphics card and its memory.

Yeah, a gig of RAM shouldn’t cause stuttering in most games. Go you have a card with 128MB, like a 6600GT? If so, it might be swapping video memory in and out.

A gig of RAM should certainly be adequate for those games. What’re the rest of your system specs?

Watch the hard drive light, and see if it flickers in coicidence with the pauses. If so… kill it with fire. Or, alternately, move the swap file to a different drive, get a faster drive with more cache, etc.

You can try defragmenting your harddrive.

Also, set your virtual memory manually to a big contiguous block:

  1. Defragment
  2. Disable virtual memory
  3. Reboot
  4. Set virtual memory to minimum 1 GB, max unlimited (or some high number)

Lastly, make sure your motherboard and sound card drivers are up to date.

pfreak, it sounds like something is interrupting your file accesses. Do you have some abnormally thorough anti-virus checking? Are you running anything that you can think of that could be influencing the speed at which your games are accessing their data files?

If it’s in the game’s FMV, mabe it was amateur actors? Or maybe the game character is supposed to stutter! Have you ever considered this?

Naw, I have no idea. I have learned to live with stutters.

Also, set your virtual memory manually to a big contiguous block:

  1. Defragment
  2. Disable virtual memory
  3. Reboot
  4. Set virtual memory to minimum 1 GB, max unlimited (or some high number)

Isn’t that ordered incorrectly? I would think it should be:

  1. Disable virtual memory
  2. Reboot (which kills the old swap file)
  3. Defragment
  4. Set virtual memory to minimum 1 GB, max unlimited (or some high number)
  5. Reboot (establishes the new swap file)

…and you should also set the min and max on the swap file to the same value. This will keep Windows from resizing it when thinks it needs more or less space.

I have radieon 9600 pro card. I disabled virus protection before I run a game. I do have norton 2005 antivirus installed. Under the task manager it says when I’m about to run games I have a commit charge of 276 M/1505.

Ok I know where to go for defraging, how do I disable virtual memory ?

I found my paging file and it’s set at 1024 mb min and max.

I just tried Ron, and once the game loads the little orange light under my power light continues to blink while I’m running the game. I haven’t defrag in maybe 2 months.

So what does the warning mean if I set it to 0 paging file, and it says that it will not be able to debug if a stop error occurs?

Just that it won’t be able to do a memory dump or send any useful info to MS’s error reporting site if a Blue Screen Of Death occurs. Not really a big deal if you’re not regularly running into BSODs and needing them fixed.

(cue the whole swap-vs-no-swap debate)

Best tip I have wrt swap filess:

Sepparate physical hard-drives from the boot/system drive.
More than one large one, on separate hard-drives.

I noticed a performance boost, might have imagined it, but it was still there, when I put up 3 x 1.5GB Swap files on 3 sepparate physical hard-drives. As opposed to 1 3.5GB one.

Oh the performance boost is there if you’ve got your swap and game install on different IDE ribbons. The reason being that one IDE channel can be mastubating with the swap file while the other one is loading game data, and they don’t have to wait for each other.

Ok so I set it to no page file, reboot, then run defrag then set page file to what I had it at?

That isn’t an option for me right now. I’m running off of one drive my 100 or so gig drive, I have a sata drive that I’m going to install in my new computer and make this one my secondary.

much simpler way to defrag the pagefile http://www.sysinternals.com/Utilities/PageDefrag.html

I’d also make sure you’re not running wierd crap in the background, like p2p or anything like that. Antivirus proggies can cause slowdowns like that too, though the newer ones usually don’t.

System heat can do it too, though that isn’t usually an issue, it can be.

I suspect this is the main bottleneck. I’d spend money upgrading this card before I went to 2 GB of memory, or worried about 2700 vs. 3200 memory.

For what it’s worth, I have 1 GB 3200 memory and a 6600 GT graphics card (128 MB). I did create a separate partition on my hard drive just for XP’s operating system, but haven’t messed with any swap file settings for the last couple years – I wasn’t seeing any noticeable gain. I get a slight stutter in Rise of Nations when I load a saved game, but haven’t noticed any slowdown or hiccups in gameplay. None in Guild Wars either, if that’s what the GW in your original post refers to.