Subnautica - SCUBA, Unknown Worlds, drowning


What is this clearing cache thing? Maybe it is the issue because when I first started playing, I didn’t have any of these issues. The longer I play, the worse it gets. By longer I mean total play time, not session play time.


The save slots are huge and include a ton of cached content. Certain areas in the game world rely quite heavily on these caches and create performance issues after a while. Parts of the Kelp Forest are at the top of that list.

Go to \Steam\steamapps\common\Subnautica\SNAppData\SavedGames\yoursaveslot (replace the last with the actual folder name) and delete these folders: CellCache and CompiledOctreesCache. Might want to back up the save first.

I do this whenever the game begins to stutter or slow down in any way, and it seems to help. Dialing down the visual settings also helps a lot in my case.


That sorta of worked, or maybe totally worked and then I found some other bug.
So I delete the cache files and start my game. Everything looks good, but I have some seaweed and sand in my base now. I take of in my seamoth to the kelp forest that was laggy as hell and everything as smooth as silk.

I then go to the aura to go through the sealed door. I do that, scan some prawn suits and go upstairs and this is where things get weird. I see a room with no floor. I can see shelves and stuff, but no floor. I save my game up top just in case I fall though the ship when stepping through the door. I then go through the door and indeed fall through the floor. I swim around a bit in this hollow area in the aura with no geometry. I then reload my game and this time I see the full room with a floor in-front of me. I explore this area and then leave the auroa and get back in my sea moth and head back to escape pod 5.

At first I do not notice anything odd, the water is normally deep where I left the auroa, but then I get to the escape pod and there is no ground anywhere. Just an endless deep ocean. This is bad. I exit the game and reload and it is still just an endless ocean, no ground, no fish, no nothing.

My game is hosed. I think Ill just wait until subnautica is finished before I play again.


The big problem with this is it resets every item. So every diagram, farmed item, piece of whatever is recreated. So it is sadly a huge cheat for the game. One we need unfortunately because the devs keep putting off the “optimize” part of the game.

DeeptT - if you go to official forums there is a way in the future to not end up with stuff in your base by avoiding that cell location when you clear cache. It’s a pain.


I think Ill wait until clearing the cache is no longer needed. Perhaps that is what destroyed my world or perhaps it was another bug. Either way, my urge to explore the world of subnautica has been quelled for the time being. Hopefully it will not pick up my interest until it is actually finished.


I have no idea what happened to DeepT’s game. I’ve never experienced that myself, and I’ve removed caches a few times. But good call on mentioning that cell location idea.

My guess is the optimization stuff is somewhat dependent on feature changes and that they’re waiting for the right time. It would suck to announce that the game is now better optimized only to have, down the road, another feature change somehow trigger the same issues again.


Cyclops parked in a convenient spot while checking out the new stuff. Rare surface perspective.


Finally completed a vent-powered base. The real achievement was actually getting all the various fragments. Hard to find, and I’m absolutely terrified of the deeper/scarier areas. Very rewarding.

Aquarium on the left, bedroom/office in the back, workroom at the center, power on the right (note the adjacent lava vent). Seamoth moonpool on the left, PRAWN on the right. Scanner Room top and center, Observation Room beneath it.

Just as I was posting this, the little guy below somehow ended up inside my base. Not only had I never seen the species before, he was swimming around the halls, through the air, when I caught him. Surely a bug.

Still have a bunch of fragments to find: mod station, vehicle mod station, and vehicle upgrades. Based on the wrecks I’ve explored so far, I’m fairly certain these are going to be even more remote and scary to get to.


Castles and Coffee Update is now live! Looks like some neat additions, plus stability and optimization updates.

Edit: I hadn’t seen this before but just saw it posted on Twitter, the Subnautica roadmap.


Thanks for the heads-up. I booted this back up last night to see if my new cooling config in my system had any effect on the game’s tendency to crash on me, and… not so much. I’m hoping today’s patch will do the trick, because I really enjoy the game so far.


I hope they get to fixing the frame-rate issues that eventually crop up after you have been playing for a while. I do not mean in a single session, but the one where the fix is to nuke the caches.


That sounds like what I’m experiencing. Do you have a link to the cache-deleting instructions?


I had an issue where I did this, and at first everything seem fine, only I had some sand and ocean floor in my main base.

However, at some other point I went into the Aurua, and was exploring and opened a door and found some messed up geometry. I saved my game and then went to explore and fell through the floor. I was trapped and reloaded my game. The messed up room was no longer messed up. I finished exploring and then when I left the Aura, and headed back to my main base I noticed the ocean floor was gone. Everything was gone but the starting rescue pod and the Aura.

Maybe this had nothing to do with cleaning my cache or maybe it did. So I have decided to wait until the game is done before playing it again.


Its on the roadmap to be fixed in the February update.


I.e. removing the terraforming feature. Hopefully some of the game is left once they’re done making it run well enough! ;)


I expect there will be a bunch of people picking this up because of the humble bundle (like me). Is it worth playing now? Is it so buggy that it’s not worth showing my daughter who will get frustrated if it crashes?


The next patch is supposed to fix performance of save games after 10 hrs, where the slowness starts to appear.

Game is still on track for May 2017 , version 1.0


Oh boy that’s a hard one. On the one hand I wish I’d waited. On the other hand I loved the game until its performance caved late in game time. I’d say dabble. Don’t play for real, get a taste and play around for 10-15 hours but wait for final to play for “real” since there’s a whole bunch of story stuff going in yet. So for now get a base going, explore a couple wrecks, sight see. You won’t spoil anything doing that. I have 66 hours in and should have stopped at the 30 hour mark to not spill so much of what was coming as I’d explored too much.


Interesting sense of time. For me a 15hrs investment into a game is more than just dabbling, let alone playing an unfinished game for 30hrs. But thats obviously all relative…

(This is not a criticism of you Jeff, just a general point about the relativity of gaming time. Also the reason I just don’t understand MMOs where people play for hundreds of hours grinding away to get a matching set of armour or something)


I spent a LOT of time just kicking back and sight seeing, the sun set etc fishing and watching said beahvoirs. Just going super slow. I play it via Steamlink on my living room tv which gave it a much more relaxing feel vs. sitting at my PC.