System Restore does not work - Windows 10


#1

As I struggled with issues on my laptop as I’m traveling for a couple of weeks (and did not bring the USB drive I do my backups on) I tried doing a simple system restore, Picked a restore point, let it do its thing but when it restarted I get the error that system restore was not able to complete, somethingsomethingsomething winapps.

I did some googling, saw a lot of people with the problem, MS acknowledging an issue, but no fix that works. It APPEARS to be due to winapps being unreadable or writeable, but even following a long procedure I found in the CMD window to rename the folder, I still could not get restore to work. (I was nervous enough about doing the CMD stuff I wanted to do make a restore point, but of course that would be of no use!)

The exact error:

Details:
System Restore failed while restoring the directory from the restore point.
Source: AppxStaging
Destination: %ProgramFiles%\WindowsApps
An unspecified error occurred during System Restore. (0x80070091)

Anyone have any magic answers that will fix this?


#2

A moment of googling produced this, which according to the comments looks like it works


#3

Yeah, I found that pretty early in my Google searching. And it didn’t work. I found variations of that on other sites, and it worked for some and didn’t work for a lot of people. :(