~The Game Pass Thread~

I went to play it earlier but couldn’t get it to run. It keeps crashing on start-up with a Unity error with a red exclamation point. I tried everything I could think of.

Ah crap. Only this weekend left to finish Omno. I did try Raji briefly. It seems like a nice little game. Maybe I’ll get the chance to spend a little more time to get a better sense of it this weekend.

Apparently Hades is leaving on August 16th. I should try to get back into that.

That shouldn’t be difficult! :)

Does anyone else have issues when first launching a game? First time I try to connect my XBox account to the game I get the same error over and over and over (something like x80190001). This is with my laptop running Windows 10. It’ll ask if the game can connect to my XBox Live account, I say Connect, it grinds for a sec, then it pops up the error with no real explanation.

I have googled the error and I get a bunch of things to try like

  • update Windows
  • update Windows Store
  • update XBox
  • run various troubleshooters
  • repair XBox
  • delete Windows Store cache
  • repair game
  • reset game
    and a bunch of crap like that, with the final step being
  • uninstall and reinstall game

Why is Microsoft so bad at this!!!

The weird part is that once it does this one-time connect, everything is fine. So it’s just that initial point where the app is trying to get my credentials.

I just spent maybe 45 minutes trying to launch Guardians of the Galaxy, and right when I was about to come here and ask for advice, it worked. So yeah, I can get in, but it’s consistently frustrating.

Has anyone seen this issue and managed to fix it on a long-term basis?

I’ve had the error on almost all my initial logins to connect a game - it will fail almost instantly but usually I just try it again right away and that will actually let me authenticate (I have two factor on my account so I know it’s working when it actually brings up an authorization prompt on my phone). I think there was one game where I had to retry more than three times but it eventually just worked.

It eventually “just works“ for me but I typically have to try 10 or 20 times before it lets me in. It’s super aggravating.

It’s hard to troubleshoot problems because sometimes they have something to do with your configuration which MS hasn’t accounted for.

Some suggestions: If you have VPN have you tried turning it off? Does your network have any rules which might be affecting your laptop? Also try powering down your router and restarting it after a few minutes.

Edit: above recommended because they have caused me problems similar to yours.

Kind of curious about all of these, honestly. Not very curious, but kind of curious.

Oh, and good news, rumors of Hades leaving on Aug 15 were not true!

Instead, these are the ones leaving Aug 15:

  • Boyfriend Dungeon (Cloud, Console, and PC)
  • Curse of the Dead Gods (Cloud, Console, and PC)
  • Library of Ruina (Cloud, Console, and PC)
  • Starmancer (Game Preview) (PC)
  • Train Sim World 2 (Cloud, Console, and PC)

Oh man, I’d better try Library of Ruina!

I think it’s one of those 100+ hour games. Better get cracking.

It’s sad that Starmancer is leaving and it’s still Early Access. Maybe if it ever releases, and it’s a good game, they’ll add it back to game pass.

Boyfriend Dungeon, Curse of the Dead Gods, Train Sim World 2, I should install them just to try them out before they leave.

I have to admit, I’ve never heard of Library of Ruina.

I tried it when it came to gamepass, but bounced off of it… it was really weird.

I’m trying to like that tennis game but what’s really annoying about it is that you use the same darn stick (the left one) to move AND to aim your shots. So what ends up happening is that if you’re moving forward into the swing you almost inevitably hit the ball out past the baseline.

What was that tennis game series that they had on the consoles and PC starting about 20 years ago? Those seemed more forgiving.

EDIT: It was Top Spin. I have Top Spin 3 for the 360 on disc, but I doubt it’ll work on my Series X due to player name/image licensing and all that.

Library of Ruina is the first game I understood less after playing the tutorial.

Library of Ruina is in a Humble Bundle right now along with a bunch of other high-quality games for $15. Don’t bother trying to play it on console - it’s clearly designed to be played with a mouse, and the controller interface seems like it was cobbled together at the last minute.

Expeditions Rome has been on my wishlist ever since it came out but just never quite bit the bullet. Glad to see that it’s coming to GamePass.

Hugely anticipating Two Point Campus. Hospital was really well done but a bit too close to the original to hold my interest for long. Hopefully the new setting lets them experiment a bit. Offworld Trading Company is probably my favourite strategy game since Company of Heroes. If you haven’t tried it, do yourself a favour.

When the heck is Judgment gonna come to GP?