Troubleshooting help: Why is my desktop internet so slow?

Hey all, no idea even where to begin here, so I’ll begin at the beginning.

New apartment, new internet, AT&T 300 plan. Super happy with it for the last 10 days while working from a couple of laptops that I own. On Steam I’ve been getting downloads around 20-22 mb/s. Which is great – almost twice as fast as my internet in DC.

So…sweet, I think. When my desktop arrives and I hook that up, that speed boost will be great.

Except…it isn’t there. In fact, my desktop PC does downloads at nearly half the speed rate that I’m getting on my laptops. And to really test it out, I connected the router to a powerline connection so I could use an ethernet cable. I plugged the ethernet into my desktop…and it just kind of chugs. Broadband for sure, but on a steam download (from the same server as my laptops) I’m peaking around 5mb/s. (Yes, I checked UPlay and Origin too. Same deal.) I remove the ethernet cable from the desktop and plug it into a laptop, and it’s nearly 3 times faster across the board, sometimes 3.5 to 4 times faster.

And when I run speed test, again, same connection server, the difference is really insane. This is the same powerline ethernet cable connection, desktop and laptop:

Any ideas? There’s no reason the desktop should be slower than the laptop – it’s a far more powerful computer operating on the same internet network.

I’m stumped. It’s like there’s a “I want slower internet” switch on the desktop that needs to be toggled off.

Have you refreshed the network on the desktop? :)

Try solution 1.

Yeah, I’ve already gone through the canned windows 10 responses from Microsoft.

Have you tried setting up a second user account on the pc, and see if that is faster? Maybe you have some kind of background task running on your main login account?

Did you try rebooting the router and cable modem? I know this is probably the first thing any of us try but doesnt hurt to ask.

Yep and yep.

And again, every other device in the house on that network – two game consoles, two smart TVs, an ipad and two laptops – all operate at expected speeds.

Everything but the desktop.

Maybe try booting into one of those linux-on-a-sdcard systems, and give it a try there? Not a fix, but it might help point to it being either hardware or software.

I assume you’ve tested it in a Safe Mode.

Well, for now we’ll split the credit between Daagar and barstein. :)

Daagar’s post gave me the idea to start back up in Safe Mode, even without specifically suggesting it, his post was the slap across the face of “Hey dummy, try it in safe mode.”

So I did that, and full speed on speed test in safe mode with networking.

So then I restarted again, and vroom vroom. Out of safe mode, also full speed.

And came here to report that whatever Safe Mode did, it seems to have fixed it, and here’s barstein suggesting that very thing. :D

No idea why that worked. But at least for now, it did.

“Have you rebooted the computer yet?”

Hopefully it won’t recur, but if you’re using the motherboard integrated NIC, they’re not all the same. I’ve had systems w/ an integrated Killer Network interface, and while the hardware was fine, the Killer software bundled w/ the drivers caused a ton of speed and reliability issues. Everything worked great once I disabled their ‘value-add’ software.

Heh. I did a number of reboots (regular) before finally doing a safe mode reboot. Weird, weird, weird. But fingers crossed whatever that purged, it worked.

I’m just surprised it wasn’t mentioned in one of the canned Windows 10 responses from Microsoft. :) Glad it all worked out.

Might want to also check the driver situation for your chipset/motherboard. If it’s working I’d leave it alone, but if it comes back, maybe install the newest driver (or if you already have the latest version, re-install it). This sounds like it was a driver issue.

What NIC is it?

Hah, safe mode was the much smarter and more obvious choice. Not sure why my brain didn’t go there first - glad you were smart enough to do so!