Web site help

Quick favor request. I can’t access my website at the moment (I can through ftp, but not http). My provider’s tech guy says he can. Can a few people please go to and post here or e-mail me () if you can (or can’t) see the front page? (Not trying to snarf traffic - I’ll delete the link after I resolve the problem).

Thanks,
Phil

Works fine for me (from domain uiuc.edu).

Can anybody think of a reason why this would NOT work from 2 different computers at my house (using charter) but work for mouselock and my host’s tech guy? Perhaps my DNS server has bad data (so it can’t resolve the URL)? Any other possibilities?

Does a tracert get you to your websites IP address?

My tracerte got routed through LA which was a bit odd; any reason that traffic should be hitting LA instead of hopping to Chicago and down to somewhere a bit nearer to St Louis?

Have you tried using direct IP address (http://xxx.xxx.xxx.xxx) to get there? (That works fine for me too.)

My guess is something’s broken at your network connection/DNS level. If the IP address gets you there then it’s the DNS/your .hosts file somehow being mucked up. Any trouble with nameserver elsewhere? (Or I suppose your webhost company/gateway could be running afoul of your firewall somehow and not mine, but that seems pretty unlikely.)

Hy host is Lunar Pages, AFAIK, they’re nowhere near St. Louis, so the geography is not necessarily wrong.

I believe my IP is 216.193.252.61 - correct? If so, that’s not working for me (i.e. http://216.193.252.61 in my browser) either. Doing tracert with that ip (or the URL) at the DOS prompt just times out.

…Rebooted my cable modem and my computer, disabled firewall, still doesn’t work (in I.E. or Firefox). I can see pretty much all other sites (though my.yahoo.com was flakey for me for an hour earlier today). If I go through my ftp program (filezilla), I CAN see the files on my site. Don’t know what problem could cause all those symptoms though…

This doesn’t help, but I like your site design.

looks like there is some sort of fancy redirection going on when you hit the site. Try hitting a file on your web server, other than the default file that displays the page.

For example, if you have a foo.jpg in your image directory at the root of the web server, then try this url instead of the going right to the default page: http://216.193.252.61/image/foo.jpg

Also, change the name of your hosts file from hosts to hosts.sample.

If it is a DNS propogation issue, you can just tell your computer to use the hosting providers DNS for the time being.

Some kind of spyware on the PC? For instance, one which redirects domain.com requests to a different IP via hosts file? It’s not consistant with your FTP working, but maybe you have the IP and not domain.com in your FTP client?

If you go directly to the IP address in FF/IE (as in, type “http://WWW.XXX.YYY.ZZZ” as the URL in your web browser), does it come up? This would help pinpoint if name resolution is involved as the problem.

Try editing your hosts file.

Add

216.193.252.61 www.philsteinmeyer.com

Does that work? if it does, it is a dns issue - your provider may have the bad dns cached from previous attempts. If that doesn’t work, it is a routing issue.

Chet

There’s a known image file here:

http://www.philsteinmeyer.com/phils_uploads/officemax.gif [edited to correct address]

but I can’t see that either.

(Can’t see it this way either http://216.193.252.61/phils_uploads/officemax.gif
)

Tried accessing on 2 different PCs and a Mac, and no dice, so it’s not local to my PC.

Tried switching to my host’s DNS’s
NS4: 216.193.215.4
NS5: 216.193.202.5

but no luck there either…

What is the ‘hosts file’ and where do I locate it?

It’s in
c:\windows\system32\drivers\etc (XP)
c:\winnt\system32\drivers\etc\hosts (NT/2000)
c:\windows\hosts (95/98/ME)

It’s a file named “hosts” with no extension, but you can open it in Notepad.

Someone (you, your firewall, you’re ISP) may have your hosting provider’s IP address range firewalled off for some reason. A large company I worked for had whole ranges of IP addresses firewalled off, because they belonged to residential ISPs or because DDOS attacks originated from there.

I believe my IP is 216.193.252.61 - correct? If so, that’s not working for me (i.e. http://216.193.252.61 in my browser) either. Doing tracert with that ip (or the URL) at the DOS prompt just times out.

This means it’s not a DNS issue in the traditional sense of the word.

Does the tracert literally time out without going anywhere? If so that indicates that your gateway may be mucked up (I believe; basically it indicates that your host has no idea how to get from your IP address to the IP address above, and in fact can’t even get past that first step on the chain.) I’d suspect that your home router/hub/gateway/whathaveyou was screwed up, except you can get other places which makes no sense. But it seems like your system can’t build a routing schedule for that address for whatever reason, which is really, really weird.

OK, I had

>>

comments snipped

127.0.0.1 localhost
<<
in my hosts file, and changed it to

>>

comments snipped

127.0.0.1 localhost
216.193.252.61 www.philsteinmeyer.com
<<

No luck.

It must be on my ISP end or in my cable modem. I’ll see if things flush/reset tonight, and if not start bugging my ISP tech support people.

Thanks for all the help.

Sorry, I missed that earlier you said it was from multiple PCs. This tends to steer away from the hosts file as the issue.

The only thing I can think of, then, is your router/firewall between your ISP connection (cable modem, DSL, etc) and your PCs. If you have a PC with a long enough network cable, can you plug it directly in to the cable modem without the firewall (just for a test)? If so, try that and boot it up. Now, can you browse the net? If so, can you hit also your site? If it works for you now, then something in your router is borked with HTTP requests specifically to your web site/IP.

When I run
tracert www.philsteinmeyer.com
at the DOS prompt, it says
Tracing route to philsteinmeyer.com [216.193.252.61] over a max of 30 hops:

1 1 ms 1 ms 1ms 192.168.1.1
2 * * * Request timed out.
3 * * * Request timed out.
4 * * * Request timed out.
{and so on. Item 1 appears instantly, the timeouts take about 5 seconds each to appear}

{I think the IP 192.168.1.1 is my cable modem}

I’ll try connecting some direct connections in the morning. We’ve got house guests sleeping in the room with the cable modem at the moment.

Do you have a router in between the cable modem and the home network? If so, that IP is more likely the router (at least, that’s how it is in my setup).