Web site help

Chances are the cable modem is the router these days (though if he’s had it a long time…)

At any rate, I suspect that there’s something mucked up in the settings on whatever box sits between you and the network at large. Whether it’s a seperate router, your cable modem, etc. Have you played around with the hardware any time recently, updated drivers, etc…?

I would tend to suspect that a firewall is gobbling up your traffic on whatever ports http requests use. But one would think you’d remember setting up such things and if you didn’t it’s a bit mystifying as to why it did work but has now stopped doing so.

Any recent security/virus/internet program installations?

I can’t see that one either, but I can get to the main page, so there may be a typo or something else wrong with the path.

Doh - it’s supposed to be

http://www.philsteinmeyer.com/phils_uploads/officemax.gif

but I can’t see that either.

How about this: http://216.193.252.61/phils_uploads/officemax.gif

Man, this is one weird problem.

Well if the hosts file doesn’t clear it up and you can’t tracert, it is a routing problem. Some hosts will block a range of ips because of spamming or other issues. Freaking verizon blocked a huge chunk of ours one time.

Go to

Call your host, asking them if they are blocking that ip or range.
Take your site ip, and call your isp and ask if they are blocking that ip or range.

Both sides will normally claim they will never ever block any ips, just press them on it. They all do it.

Chet

So in the end it was kind of one of those ghostly things that just disappeared. More specifically:

This morning, all problems like last night.

My basic config is Cable Modem -> Linksys Switch -> Some computers, plus to another another Linksys switch to my primary computer.

The whole 'net worked except my site, which didn’t work from 3 different computers (one that was one switch from the cable modem, and two that were two switches from it).

Nothing had changed about my config, except my air conditioner causes power surges that sometimes cause wackiness among various devices (yes, I have a UPS/surge protector - doesn’t really help).

So I hooked a PC directly to the cable modem, all worked well (including my own site - I could finally access it).

Tried various rearrangements of computer connections through the switches. Mostly things didn’t work (even the ‘rest of the net’, which had been working before).

Finally put everything back how it had been originally. Suddenly it all worked.

Yes, I had tried rebooting every device in the chain at different points before I even got into rearranging attempts. So ultimately it cleared itself up, but not for any logical reasons.

Also ran a full Norton scan on my primary machine - no sign of anything bad.

Computers - fun fun.

Oh, and thanks to everyone who tried to help me.

Phil