Weird problem with router range extender

Every time I visit my parents they have a tech problem and I spend my time trying to fix it (they’re in their early 80s, and tech challenged.) But this one is really odd.

Long story, but here’s the bottom line: they have a Belkin router and a Belkin range extender in the den (router in the bedroom.) One story house but some brick walls, thus the extender. When I got here a few days ago everything was working normally. Then, yesterday morning,they had bad weather, internet went out, then when it finally came back on they were having sporadic issues (another long story) but the bottom line is, now I can connect my laptop to the wireless router, and I can connect it to the 5GHz signal of the extender, but when I try to connect to the 2.4 connection of the extender, I connect but get no internet connection.

What is odd is that I can connect to that 2.4 GHz connection with my iPad and I DO get an internet connection. I thought it was the extender until I saw that.

I’ve changed nothing on my laptop since it worked a few days ago. I’ve checked and double checked the encryption (WPA2 Personal (PSK) and what I have set on my settings for that connection. Again, I can connect just fine to the extender it just won’t give me internet access. But with the same settings (and they are the same for the 5Ghz connection) I can connect to the router and the 5GHz output of the extender and get internet, just not the 2,4 GHz of the extnder (and my iPad can!) Arghhhh! Hellp!

What about their devices? If the only thing that can no longer connect is your laptop - have you tried just rebooting your laptop?

Yeah, I was convinced it was something with the extender, since it had worked fine until we had a short power outage and internet outage, but everyone’s iPads can connect to the 2,4 GHz output no problem and get internet access, so it is something with my laptop. I’ve rebooted many times, over a couple of days, etc. And I can connect to the 2.4 GHz of the router with no problem and get internet. Just not the 2.4 of the extender. Loggged into the extender setup page, it has the security (WPA2 Personal PSK) and password of the 5 GHz and 2.4 GHz outputs set up the same, and I’ve got them set up the same (in everything I can see) on my laptop. I KNOW it has to be something simple but I cannot figure it out.

One additional data piece: it seems to be stuck on “Identitying Belkin.0ca.ext” - that is the text in the status box ( Currently connected to, etc.)

OK - summary is that I can connect to the router directly (wireless) 2.4 GHz output, ranger extender 5GHz 5 GHz output, and all other devices in the house (iPads) can connect to everything including the extender’s 2.4 output and get internet.

The only thing I CAN’T do is get internet access to my laptop when connecting to the extender’s 2.4 output - it stays stuck in Identifying Network. If that also happened when I was connecting to the same range extender’s 5 GHz output, I’d assume something was up between the extender and my laptop/network card, but why would it connect and give me internet with the 5GHz and not the 2.4 GHz? When they are set up exactly the same on the extender? And I can get internet access wirelessly on 2.4 going directly to the router? Arghhhh!!!

Change the password.

I bet it’s a super long 15 character password with exclamation marks.

I’ve seen devices that don’t accept long passwords with symbols.

Yeah, tried that. But the password is the same on the 5g of the extender, 2.4 of the extender, and the router. Double checked them all. And the iPad connects to it with no problem. Pulling my hair out because there is no logic that fits this!

Nah, the logic I am assuming you’re using some Dell Connect software or whatever to enter the Wifi password in the windows laptop, and that’s what’s having trouble.

Wifi is annoying black magic. It’s like, somehow black hats can haxxors all you stuff but the owner with the legitimate password can’t get in.

Maybe they had a power surge, and it damaged the extender somehow. The signal is marginal, but some devices work. Magic, who knows!! Maybe an external velcroed USB-network wifi card will work.

Maybe you try connecting with built in windows instead of the OEM software.

Not sure I know what you mean by Dell connect? I’m just using the MS default stuff for entering the passwords, etc.

And yeah, it’s voodoo. I’ve tried killing a couple of chickens, didn’t help at all. What is really bugging me is why I have no problem with the extender’s 5GHz connection but do with the 2.4, but I can connect to the router’s 2.4 with no problem. And other devices have no problem. UGH!

This won’t be of any help but I’ve tried Netgear, TPLink and D-Link extenders–they’ve all been shit. These days I’d rather shell out the $200-300 for a better router or go with powerline networking but The Wirecutter has had a low opinion of them:

I think wiseful means that many PC OEMs bundle their own wifi management middleware. Sometimes it’s OEM-branded, sometimes it’s the Intel Centrino/wireless networking driver bundle (can’t remember what it’s called offhand) that see-saws between itself and the built-in MS wireless config stack, making it confusing for the end user.

Could it be something to do with MAC address filtering in either the extender or the router? Your 5GHz and 2.4GHz wireless adapters have different MAC addresses (double check this please).

As a counterpoint to rei, I also read the same article, and ended up keeping my asus N150 router, and buying the netgear EX7000 to extend my range. Most of my devices connect to the extender, because it has better house coverage than the router! Plus the extender is placed behind my first floor TV, letting me hook up all my Playstations and xboxes and PCs using ethernet (less wifi chatter from different devices).

Well, since this is my parents house, I’ve got them up and running so it is only my laptop with the issue, and we’ll be driving home in the next day or so. So at this point it is just an irritating challenge. I hesitate to do a lot of mucking around on my laptop drivers, etc. unless I get home and have problems with my home system.

Well, since this is my parents house, I’ve got them up and running so it is only my laptop with the issue, and we’ll be driving home in the next day or so. So at this point it is just an irritating challenge. I hesitate to do a lot of mucking around on my laptop drivers, etc. unless I get home and have problems with my home system.

Oh, yeah, also no MAC filtering in the extender, and since I can connect to the router I don’t think the issue is there.