Weird slow down in Windows XP (not heat)

I’m posting this for a mate of mine, I’m not ‘fortunate’ enough to have SATA drives yet (or the rest of his computer, RAWR).

He’s got a problem with slowdown in WindowsXP, that is to say whenever he goes into a folder that has ‘Thumbnail’ view his PC has a big cry and ‘Explorer.exe’ goes to 100% and causes his PC to die… As you can guess it’s very annoying. The problem we face however is that it only ever happens when in that view on his SATA drives, not his standard IDE ones. He’s patched Windows to the best he can and had a look around for anyone with similar problems but found no fixes.

His specs are;
AMD XP 3000+
1024Mb DDR Ram
Gf FX6800GT
ASUS A7N8X Deluxe Mobo which has a Silicon Image Sil 3112 SATA Raid chip as the SATA controller… he even bought a new controller card today but it has the exact same chip on it…

Anyone know how he can possibly fix this?

( We have temp fixed it by setting all his folders to not show as thumbnail, but sometimes he actually does use them and it’s hardly a real fix for it )

Any help is greatly greatly appreciated. :D

It’s fixed, hooray… it turned out to be corrupted mpeg files. Something to do with how explorer handles indexing. Why it only affected his SATA drives is beyond me.

I’ve read tips that recommend turning off the fast indexing service. Not worth it for the performance tradeoff.

I find that explorer often crashes when trying to snoop a folder full of divx/xvid files. My indexing service is off.

There’s a fix for that too, novacane.

There’s a timeout bug in the shmedia.dll regarding .avi files.

You can phone (yes, phone) microsoft for a hotfix.;en-us;822430&Product=winxp

Or you can disable shmedia.dll in one of two ways:

  1. . Start, Run, and type: regsvr32 /u shmedia.dll

  2. Goto Start, Run, and type: regedit
    Find the key:

Find the value, and right-click to delete:

Either or both fixes will prevent Explorer from loading shmedia.dll in response to file property queries on these files.