Weird Wi-Fi Problem, Could Use Help/Advice

Hey friends, I’ve got the weirdest issue with Wi-Fi and so far my research has pulled up nothing. We live in an apartment that was built in the 70s, and the router is in the main room in the front of the house. If we go to any other room in the apartment, we start having issues such as:

  • Pages won’t load
  • Apps hang and seemingly get stuck
  • Certain things won’t sync properly

Usually the only way to solve this is turning the wifi off and on again on our phones, which is getting really annoying. I’ve tried to use a Wi-Fi analysis app to choose the best channels for my router (a Netgear router along with a switch), for example, but that did nothing. I also tried getting those plug-in-the-wall Wi-Fi extenders but they also didn’t help at all.

So short of getting a whole new router, which seems ridiculous, might y’all know of anything else I can do to fix this problem?

Thanks for your time.

Your signal analysis app sounds like you are on the right track. You are probably trying to determine whether your signal is just not strong enough to cover your space, or if you are getting interference from other signals in nearby apartments. What analysis app did you use, and what did the channel graph look like? I have used Homedale

or InSSIDer

on windows for this purpose, or this on android

I’m using WiFi Analyzer

And my graph looks like this from the other end of the apartment. LANdo is mine.

This is what it looks like with InSSIder on my laptop in the same room with the router:

That looks good, your signal and several other signals are quite strong everywhere. This is common in dense apartments now, and is one of the problems the addition of the 6Ghz band in wifi6e should help with.

It’s possible that it could be a DFS problem, that’s why most devices don’t want to setup on channels between 48-149. All those channels are ‘available’ but there are other users which have priority over all Wifi, so the specs require any Wifi transmitter on these channels shuts off or changes channels if it detects a non-Wifi signal there. In urban areas there are things like police car or weather “radars” and such using those channels, and I have devices occasionally kicked off of them. Are there any logs or errors that your router lets you see, or maybe you can catch your wifi signal when it switches to another channel?

So in reading that, might setting my router to channel 165 be better?

Edit: Crap, I can’t even do that. The highest it goes is 161. On my app, all the channels between 52 and 140 seem to be strongest.

Looks like a lot of these upper channels aren’t being used by anyone else.

Maybe try one of them? Forgive me, I’m an idiot at this stuff.

Oh also a lot of channels have (DFS) next to them, is that what I should be avoiding?

You can try moving channels around, but everything from 48 to 149 will be possibly affected by DFS.

When everyone is using 80mhz wide channels, 5Ghz Wifi really just has 2 channels that everyone gets packed into. That’s what you have too, with everyone but you crammed into the 36-48 channel, or the 149-161 channel.

Would switching to 2G help alleviate this, do you think?

Hmm, this Wifi Analyzer app says the best channels for a connected AP at 5Ghz are 38, 42, 46 and 50. Oddly none of those are options in my router settings.

You could try it, but your 2Ghz is pretty crowded also. And the speed will be a lot slower.


You might have better results staying in one of the crowded 5Ghz bands if DFS is the problem. Any chance you could move your router to a closer/central location?

Sadly no, we really can’t, this is where the modem is because of the weird way the cable set up in this place.

It looks like nobody is interfering in the highest subchannel. Can you control the channel width on your router? Maybe try setting it to channel 165 and minimum width (20mhz), and see if you can get consistent connection.

Well these are my Wifi options:


But I do have these advanced settings:


Might they be of help?

Also, oddly, I can’t set it to 165, only 161.

Ah, yeah nobody else is using 165 either, understandable.

The smallest “mode” is up to 347Mpbs. The smallest “preamble mode” I can set is “short” whatever that means.


Channel and mode should be all you need to tweak. I would just try going back to channel 36-48 at 1733. If you are still having connection failures there then we know it’s a problem with too many strong signals, and not just DFS wanking kicking you off channels 52-64.

So this popped up when I changed the setting.


Should I set it to 347, do you think?

Different routers enforce things differently. It may work if you select 36/1733 but not 48/1733. What did you try?