Why won't my computer detect my HD?

I’m having the weirdest problem and I thought I’d ask here for help before I send in my computer for repairs.

Basically, when I boot up my computer I get a message that it is scanning for IDE drives. And then after 30 seconds it tells me it can’t find any, and tells me to insert a boot disk.

Now, I’ve checked all the wiring inside and nothing appears to be loose.

I don’t know what’s wrong, I turned off my computer as usual last night, and today it can’t find my HD.

I am completely baffled by this. Does anyone have any experience of this happening to them? Is this a virus? I have no idea.

Hard drive failure?

Check the bios, too, and make sure everything set to “Auto” there.

Double- and triple-check the power cable to the HDD.

From the quick symptoms, I’m afraid your the victim of HDD Failure. Almost incurable.

I’m afraid you’ll have to put it down, and get a new one.

Murph’s probably right. Listen as the computer boots up and see if you can hear the hard drive spinning up; if not, it’s probably a loose/bad power connection. Try another connector. Also try replacing the IDE cable your hard drive is on, and if there’s another device on that same IDE cable, disconnect that device and try rebooting.

In the BIOS, check and see if it is detecting your drive at all. If not, either the drive is dead or the connections are bad. If you have another computer, drop the drive into the other computer and see if it works there.

As a last resort, unplug everything from the HD, then carefully reconnect everything. I can’t tell you how many times everything has looked fine, but disconnecting and reconnecting magically fixed the problem…

One other thing you might want to try: Steve Gibson has a great utlitiy called SpinRite that does a low level format on the drive. If you can detect the drive but can’t access it, Spinrite is a great utility that won’t kill your data. Gibson’s website is www.grc.com.

Good luck!


Was your hard drive making erratic clicking noises before?

Was there a power surge or outage recently?

Can you hear the drive spinning? Does it appear in the BIOS list?

If you can hear it spinning up and it wasn’t clicking… Try the other IDE slot, or another computer. If that doesn’t work, sorry man, your disk is dead. It’d be odd for it to happen without warning signs (poor performance, clicking, constantly trying to spin up, etc.) but that’s not exactly unheard of either.

It doesn’t have to be loose to not work. If you can find a spare IDE cable, try putting that in there first.

I had a machine that would occasionally do this. When I restarted it, everything was fine. I always assumed it meant the disk was getting ready to fail.

Ok, I’ve disconnected and reconnected every cable. I’ve checked the bios, everything set to auto and nothing is detected. I tried installing it as a slave drive on the computer I’m typing this on with the result that none of the hard drives on the computer are detected.

I’ve had absolutely no problems with my HD before.

Will it be worth my money to try to send it in for repairs? If there is any chance of recovering data I would take it. There are unfinished school papers in particular that I would like to get back. If not, bloody hell. I absolutely positively hate doing the big reinstall everything when I’ve got things configured the way I want them, and this time I’d get the added cost of a new HD.

As a last resort I’ll do a straight switch of drives between this computer and my own broken one, but I doubt it will work. The slave install was supposed to save me the hassle of juggling drivers and possibly the XP activation scheme (got XP on the broken drive and a completely different config on the other computer)

Most HD manufacturers have a 3 year warranty on drives. So if it is a Maxtor, WD, or IBM from the last three years (date probably on the sticker with serial number) then definitely call them up and get them to RMA it.

could be a motherboard problem too. but check the hd 1st for any faults(eg. take it back to the maintainence, or put it in another computer), then the cable (just plug in one that has been working)… if this doesnt work, then u might want to check the port on the motherboard…

its tedious and i had that happened to me once… had to get a new mobo… hey, it was time to upgrade anyways :wink:

They switched to 1 year now. Pretty indicative of the quality of the drives. I worry every day about Sony putting a 60 day warranty on my PS2…

They switched to 1 year now. Pretty indicative of the quality of the drives. I worry every day about Sony putting a 60 day warranty on my PS2…[/quote]

Some of the higher end drives (e.g. WD 8 MB cache drives) still carry the 3 year warranty.


I’ll ask around about repairs, but I’m sceptic about it. The warranty was for one year, and that expired five months ago. In the meantime, does anyone have any recommendations for a new HD?

Forgot to log in, last reply was mine.

It very well may be your motherboard. I had a machine here at work that the floppy drive controller failed on. Everything else worked fine and I used it for months but I couldn’t read floppies at all. The same thing can happen with a hard drive controller. Have you tried switching to the second IDE channel with your hard drive?


Tried it today, no luck I’m afraid. Seems like I’ve run out of options. I’ll turn it in for repairs, if only to check what’s wrong, then I guess it’s time for a forced upgrade of whatever hardware that has crashed.

What kind of drive is it? Give me the make, model and serial number.

Have you tried replacing the battery in Tyjenks’ motherboard?


Time to take out the HD again and take a look.

It’s a Fujitsu.

Model: MPG3409AT

Serial No: VH66T1603LD8

This tells me nothing, but if you can make anything of this I’ll be happy to hear it.

Motherboards run on batteries? :D

OK, first things first…

Go to the page voted most popular for links and look in the tech section for anything with hardware/disk drives - and go to the resources

[li]Open up the machine and take the drive out its cage, and prop it on top of the cage
[li]Make sure that its the ONLY device on the IDE cable
[li]Make sure that its the ONLY device connected to the power connector. i.e. if you have it on a split Y, change it for now to a single direct connector.
[li]Disconnect ALL other devices from the power supply, leaving only the HDD, floppy and mobo i.e. disconnect all other hard and/or optical drives.
[li]Fish out your win startup diskette. You do have one, don’t you?
[li]Stick the diskette in the drive, stick your ear close to the HDD and power up the machine

Whilst powering up, you should hear the drive startup. If you do, then the electricals are probably OK. If you don’t hear it, then the drive is probably shot. To be certain, switch the power connectors and try again. If nothing, the drive is dead. Period.

If however, the electricals are OK, then you should grab you latest mobo BIOS, boot from the startup diskette and flash (even if it IS the most recent BIOS you already have) it again. Now press the DEL before the POST completes, go into the BIOS, select all defaults, save, exit - rinse, repeat the above.

At this point, you’ve already determined either that the drive’s electricals are OK or they are not. If you had a bad sector, BIOS would still detect the drive but give you an error. Since BIOS can’t even see the drive, it does not exist. Causes for this are as follows. The first item being the most likely culprit.

[li]Dead drive
[/li][li]PSU running out of juice
[/li][li]IDE cable problem
[/li][li]Drive type (master or slave) problem

Now for the bad news. According to Fujitsu, you have a discontinued drive model. And if thats the case, a drive failure of this type is normal.

BUT before you write it off, download the Fujitsu HDD diagnostic tool and run it from a floppy. In my experience with these tools, they can usually detect the HDD even if the BIOS cannot.

God I hope you have backups.