Windows 11 drops wifi connection, pretends it has never heard of it before..

So Windows 11 on my new machine keeps disconnecting from my wifi network. Either on sleep or inactivity, the connection drops, and the only way I have found to get it back is to re-boot.

  1. Signal strength is AOK.
  2. Driver is up to date.
  3. Power management is set to not drop wifi connection on sleep.

Furthermore, when wifi is inactive, the network adapter pretty much disappears except as a disconnected service. The network itself doesn’t show up under Network&Internet, and I can’t see the network adapter under Device Manager|Network adapters. So even manually restarting the service isn’t an option.

The machine sees the ethernet port just fine, and troubleshooter tells me that my problem is the disconnected ethernet cable. Which it isn’t. The problem is that there’s an up-to-date wifi controller that Windows 11 refuses to acknowledge except on restart.

Super weird. Has anyone else run across this issue? Google searches say yes, but the proferred solutions so far (power management, etc.) haven’t worked.

Do you see anything helpful in your event log? I believe the event source would be “Netwtw08”.

Kiddo’s new laptop had issues with Intel Wifi 6 AX200. Periodically there would be some sort of error triggered (“lso”, whatever that is), and the adapter would “stop working” according to the event log. Reboot would restore it. A couple rounds of updating with drivers directly from Intel rather than Asus seems to have fixed it, but can’t be 100% as their cable internet is also not the greatest.

I couldn’t find anything dispositive in the event viewer (good suggestion, though—thanks!) but I think I found a solution.

The machine was originally set up with an ethernet cable connected. Rolling back network settings to factory with no ethernet cable appears to have convinced Windows that it really needs to concentrate on making wifi work.

I don’t understand why it’s so reluctant to recognize and enable wireless networking when ethernet is its first port of call, but so it goes…

That is another weird one!

I wonder if disabling the ethernet adapter, in the network connections section of control panel, would have forced it to revert to wifi.

Seems reasonable! I like to connect via ethernet when I’m downloading large files, so I’ll be playing with enable/disable at some point, I’m sure.