Windows cannot find host name www.foodnetwork.com using DNS

I wanted to read the associated link about the Alton Brown crazy beef jerky maker and I can’t get it to come up. I got the above error when I tried to diangose the issue. http://www.foodnetwork.com/recipes/alton-brown/beef-jerky-recipe/index.html

Is this a Comcast issue, or an issue with my computer?

Not on comcast, and I can’t get there. Food Network appears to be down right now.

That link works for me right now. Not on comcast.

Ingredients

* 1 1/2 to 2 pounds flank steak
* 2/3 cup Worcestershire sauce
* 2/3 cup soy sauce
* 1 tablespoon honey
* 2 teaspoons freshly ground black pepper
* 2 teaspoons onion powder
* 1 teaspoon liquid smoke
* 1 teaspoon red pepper flakes
* Special Equipment: 1 box fan, 4 paper air-conditioning filters, and 2 bungee cords

Directions

Trim the flank steak of any excess fat, place in a zip-top bag, and place it in the freezer for 1 to 2 hours in order to firm up.

Remove the steak from the freezer and thinly slice the meat with the grain, into long strips.

Place the strips of meat along with all of the remaining ingredients into a large, 1-gallon plastic zip-top bag and move around to evenly distribute all of the ingredients. Place the bag into the refrigerator for 3 to 6 hours.

Remove the meat from the brine and pat dry. Evenly distribute the strips of meat onto 3 of the air filters, laying them in the grooves and then stacking the filters on top of one another. Top these with 1 empty filter. Next, lay the box fan on its side and lay the filters on top of it. Strap the filters to the fan with 2 bungee cords. Stand the fan upright, plug in and set to medium. Allow the meat dry for 8 to 12 hours. If using a commercial dehydrator, follow the manufacturer’s directions.

Once dry, store in a cool dry place, in an airtight container for 2 to 3 months.

And…It’s back for me. So I have nothing to add.

The link and the whole Food Network site works for me on Comcast out of Denver. It may be a local problem.

Assuming you are resolving other sites okay, try flushing your local cache:

From a command prompt run as administrator:
/ipconfig flushdns

If that doesn’t help try using free DNS, OpenDNS would work fine for this, their IP’s are:
Preferred DNS server address= 208.67.222.222
Alternate DNS server address= 208.67.220.220

ipconfig /flushdns works better:)

Bleh … I blame me trying to quit sodas in the afternoon. Thankies for the correction Lorini.

I couldn’t bring subsim’s site up either (same error), but after flushing I now can. Thanks!

Oooh, subsim’ site? Is there something new out or are you still playing SH4?

Oh yea. SH5 preview http://www.subsim.com/radioroom/showthread.php?t=155001