Windows network configuration advice

I run a home network with quite a few machines on it: a primary server, 3 desktops, 4 laptops, and then a host of things like TiVOs, etc. etc.

After last night’s fiasco with master browser elections, I’d like to do something more robust than that. Is there a way to force a single system (e.g. my file server) to be the master browser? Would migrating to a domain based system make things simpler?

I think this would do it;
Preferred Master Browser Tweak

Setting the IsDomainMaster parameter entry to True or Yes makes that computer a Preferred Master Browser which has priority over other computers in master browser elections. Whenever a preferred master browser starts, it forces a browser election. Any computer running Windows NT Workstation or Windows NT Server can be configured as a preferred master browser. If no other condition prevents it, the preferred master browser will always win the election. Set the parameter in the following registry path:

Key: SYSTEM\CurrentControlSet\Services\Browser\Parameters
Type: REG_SZ
Name: IsDomainMaster
Value: True

That only works if all the computers are logging into a Domain from what I remember…
If you don’t have them set to log in and they all come up in workgroups, they do their own thing usually.

The name of the Registry entry is “MaintainServerList” now for XP, not IsDomainMaster.
IsDomainMaster would be used in a server environment where you had domains which most homes networks do not so leave that alone.

Try this:

Value: “Yes”

The Server should be the Browsemaster so that the other machines can log on and be turned off as needed, BTW.

So you would want to check this out (Search “Computer Browser and Browsing Roles”):

Try it and tell us what happens.

Even Easier:

Create a text file, change the extension to .reg, name it as needed (Ex. “Browser Yes.reg”) and add the code needed:

Browser Yes:


Browser No:


Restore Default:


Just assign the machines to their roles so this never happens again.
Make sure at least a few of them stay on Auto or assign more than one machine to Master in case the Server needs to be shut down for any length of time.

Cool, I’ll give that a chance. I’ve set that to “Yes” for my main server, but it seems weird that for my network to work “correctly” all potential clients need to have that set to “No”. You’d think it would be a per-workgroup setting or at least something in control panel!

So according to that site:

Another entry in this registry location, IsDomainMaster, determines whether a Windows XP Professional–based computer can become a preferred master browser. A preferred master browser has priority over other computers in master browser elections. Whenever a preferred master browser starts, it forces an election. The default setting for a Windows XP Professional–based computer is False.

I went ahead and set that to TRUE “just in case”. I have a 24/7 file server that is the logical choice for a master browser, so hopefully this forces the issue.

That really only relates if you have all you machines log in to a domain.
If you set your server to be a domain controller and create a domain, say, and then have all your Networked computers log into that domain, the preferred browser would be the server if you set it as such.

In a Peer Network where all the computers log into a default workgroup like “Workgroup”, all computers are equal, including your server so you simply just tell it that it will be the Master Browser.
Add a machine that gets frequent use as a Master browser as well so you have a back up and you should be all set.

Be careful with the Domain settings.
If you set the computer up to use Domain authentication, you will NEVER be able to log into it unless it is connected to your network.
So if your DNS (Domain Name Server) crashes and you loose your active directory you won’t be able to boot a single computer in the network until you get the server back up and running.

Trust me, Been There, Done That, Own the Ass-wipping from the Boss for that one…
Fool me once, shame on you, fool me twice, shame on me…