Wireless internet suddenly goes on strike

So here’s the deal: my brother, wife and I are visiting my parents for a week. They have an unsecured wireless LAN in their house. For three days, all of us have been here and running fine. We’ve all been hooked up to the net, all at the same time, no issues. We played a bunch of WoW together, we played Left4Dead, etc. No problems.

Today, out of nowhere, my brother’s computer won’t connect. He gets Local Only access. None of us, as far as we know, have changed anything about anything. The WLAN is set up the same, my wife and I still have full access, nobody has changed any settings or installed any software.

Does anyone know what could cause that? I could understand if stuff just didn’t work to begin with, but it seems so bizarre to me that it would just arbitrarily conk out after working fine for three days. Does the Hivemind have any wisdom to offer?

(additional info: we are all running Vista; he can see the network and other wireless networks in his network connection thingy; we can’t try connecting to other WLANs because they’re all security enabled…but we do get the “Wrong password” error when we try.)

It could be a DHCP issue. Have your brother type:
ipconfig /release
in Start > Run

and then after that completes,
ipconfig /renew

If that doesn’t work, assign your brother a static IP address, for the gateway use the IP address of your wireless router, and type 4.2.2.2 as the preferred DNS.

If that doesnt work, set his network back to using DHCP to automatically get ip address and DNS info, because obviously whatever the problem is, DHCP wasn’t it.

Never mind, I am a dumb newb idiot.

Thanks for the info, though, LoK. The Hivemind always triumphs.

What did you do to fix it?

He probably flipped the switch on the front of a lot of portables, the one that Tom had trouble with a few months ago.

Curious. I goggled this IP address and saw others reocmmending it, too. Whose DNS server is this? Why is it better than the DNS server from your own ISP?

  1. It belongs to Verizon.

  2. Two reasons:
    a. It is easier to remember 4.2.2.2 than 208.67.222.222 (OpenDNS’s server)
    b. I’m lazy, and writing “Use 4.2.2.2 as the DNS” is easier than writing instructions on how to poll the router to find out what DNS server your friend’s ISP is actually using. :-)

Can I tap the remaining hivemind energy in this thread before it dissipates?

I still can’t get my wireless to connect with my new router. I’ve set it up as an open, unsecured network to eliminate security as a problem (I’ll deal with that later, and besides nobody is getting past the crocs). My laptop can see the network, full strength (I’m on Vista, btw). When I try to connect it gives me “Connected with limited access” and there’s a ! mark over the network icon. I have no access to the local network, nor the Internet. I can’t even access the router’s admin screen.

On the router’s setup page from my wired PC (which connects fine), I can see the laptop and the IP address that’s been assigned (whether I get DHCP to do it, or set up a static IP makes no difference here). So there’s some communication going on, but that’s it. I’ve reset the router, tried different DNS servers (I used to use 4.2.2.3 on my previous router as a secondary DNS), tried flushing the DNS as per LoK’s suggestion, and still nothing.

I am totally stuck at this point. I had my laptop connecting fine to airport and other peoples’ wireless networks over the past few weeks of traveling, so unless it’s died in the last few days I’m assuming it’s not the laptop’s hardware at fault.

Did you keep the same wireless SSID name? If you did, your laptop might still be using the settings it stored from your old router, because it see the same name and has no idea it’s a new one. To fix this, you have to reintroduce your laptop to the new router:

Try this (you said you’re on vista):

  1. Click Start > Networks > Network and Sharing Center > Manage my Wireless Network.
  2. Remove all the wireless networks listed on that page and then click OK.
    3. Restart your computer.
  3. Try to connect to the router now (it will rescan for wireless networks)

If this works, please name a baby croc after me. :-)

Alas no, and I was looking forward to calling one of my hatchlings “Lunch” as well.

I had changed the SSID name yes, in fact there were about 20 networks stored in that Manage my Wireless Network page. I deleted them all, reset, and… same problem. :( It tells me it’s connected to SmaugNet (!) but not the Internet, but I can’t see any other computers on the same workgroup either, and I still can’t login to the router from the laptop.

Heh, heh. We have a lot in common, but it’s not apparent until you drill down a bit.

I’m out of ideas. Anyone else?

Try this, Krayzkrok:

http://support.microsoft.com/kb/928233

If that doesn’t work, try hardwiring the laptop to the networking equipment to take the wireless out of the equation.

Ok, I got as far as trying to find the GUID for the device. Under the device class guid under properties/details for my wireless adaptor, the number listed doesn’t match any ID in the registry location I’m supposed to look. Where should I be looking for it?

In other news, my PSP also won’t connect to the router wirelessly - it tells me it can’t get an IP address. D-Link support basically reckon the router is faulty and it should be replaced. So that’s where I’m at - a trip back into the city to replace a possibly faulty new router. I really do need the wireless portion as we get a lot of clients in our home office that need net access.

Once you’ve got more than one device having trouble, yeah, it’s the router.

Yeah, the laptop is getting an IP address ok but not going any further. The PSP isn’t even getting an IP address. If I set the PSP up with a static IP then it connects to the router but won’t connect to the net - same situation as the laptop from that point.

Thanks for the help anyway, let’s hope a new one works. If not I’ll have to go with another model altogether. Usually have no problems with D-Link stuff but hey, they don’t make 'em like they used to.

D-Link has become my first choice for N-class hardware, assuming you’re above the $80 USD price point. For G-class, it’s Buffalo WHR-HP-G54 flashed to DD-WRT FTMFW.

I’ve had a bad USB adapter basically jam all the wifi in the house.

Ok, the conclusion to this story. I was just about to return the router this morning when I figured I’d give it one last shot. Factory reset here I come. I did this before and it didn’t work (it appeared to reset, but that was it). But D-Link recommended it on the phone so let’s try it again. I check the manual and there it states in tiny print that I missed last time that you need to hold it in not for one second, not for five seconds, not even for 10 seconds… but for 15 WHOLE SECONDS! This is one of those recessed, can’t reach it without a thin skewer buttons, so 15 seconds seems a bit extreme. Sure enough, after 15 seconds the whole front panel lights up alarmingly, I hear a tiny scream (maybe) and it resets. I feel like I’m about to switch Jurassic Park back on line, Smaug will be out of his electrified enclosure, and hell will break loose. But slowly the lights start coming back on. And that was it, the WLAN now works perfectly.

So yes, 15 seconds. I’ll remember that.