960x540 resolution


#1

I am trying to run Blades of Exile on Windows 7. It seems to work, but the game window was designed for 640x480 resolution, so everything is tiny.

I’ve added a custom 960x540 resolution to my GeForce control panel, but when I switch to it everything looks pretty fuzzy instead of nice and crisp. I thought that if I decreased the resolution by an integer quotient everything would be okay.

How do I get a nice crisp image at that resolution?

	Graphics
		ASUS VS247 (1920x1080@60Hz)
		ATI AMD Radeon HD 7560D (ASUStek Computer Inc)
		2047MB NVIDIA GeForce GTX 750 Ti (EVGA)	36 °C
		CrossFire Disabled
		ForceWare version: 368.81
		SLI Disabled

#2

I don’t think modern PC resolution scaling ever got around to supporting a pixel doubling scheme that would help.


#3

Once upon a time when I had space, I kept a secondary CRT monitor just for that. Not very practical, but pretty much the only way to get a realmy crisp image in such conditions.
Maybe trying to run some emulation box at double or so the screensize, to get big proportionnate pixels? A bit convoluted, and I am not even sure there is such a solution on windows, for windows.
If the game is using directx8, there is a wrapper’that you can run to translate it to directx9, where you get all sort’of resizing dll thingies that could help you, but i suspect blades’of exile might be beyond that reach.


#4

Do you remember any details on this? I guess I could Google. I don’t have an immediate need for it, so I’m mostly just curious.


#5

I am not on my computer, but i will
Provide the links tomorrow, given i find them in my mess of bookmarks!


#6

Try playing around with what actually does the scaling, the geforce card or the monitor. NVidia control panel -> Adjust desktop size and position. You have a few options there that might help.


#7

I was using SweetFX: the advancedCRT filter seemed to let you multiply the resolution output, although I am unclear on what it is really doing. I am fond of scanlines so I used it for that, but I think you may be disable them to simply have a crispier rendering.
The thing has always been very difficult for me to configure properly: it’s like starting from scratch each time I try for some reason.

To allow Directx8 games to use that Directx9 wrapper, I used Boris Vorontsov’s converter. I discovered it while trying to find a way for AGEOD games to use the GPU card on my laptop (they are DirectX8 game and just ignore any GPU choice - and this has never been fixed to this day). The slight issue was that the font rendering was a bit blurry. I discovered you could mix and match that with SweetFX when attempting to find workarounds.


#8

It appears to be a GeForce thing:

https://forums.geforce.com/default/topic/844905/geforce-drivers/integer-scaling-mode/

And there’s a petition:

It seems you can do integer scaling in Linux using the Geforce drivers but not in Windows.

I use VmWare a lot but I don’t think there is such an option.