Dark Souls 1 - why is this not clicking?


#33

Poop!

So the DXfix works on my computer, but when I try to play via Steamlink it doesn’t do anything. Soooo close to being able to play this on my couch :) Any ideas what might be going on?


#34

It’s an injector/hook if I remember correctly so it’s possible it’s being ignored or overridden by other injectors (possibly related to big picture/steamlink, I have no experience with these devices so I don’t know how exactly they work), depending on the startup process. Which part doesn’t work, fps, internal resolution, or nothing at all?


#35

I was very much into the “I don’t get the appeal of Dark Souls” thang, having bounced off it 18 months ago, but then I watched Tom’s Dark Souls 3 streams and it was fantastic watching someone else fail repeatedly… and then finally succeed. Too many YouTube Let’s Plays come from people playing NG++++++ who make it look trivially easy. So discouraging. But Tom being crap, and then slowly becoming not crap, that’s what I needed to see! After that I went back to Dark Souls, took about an hour of not being sure about it (getting used to the controls) and then it just clicked. It would be a pity to miss the experience due to early difficulties, although of course not everyone is going to love it either.

I wonder if Dark Souls 2 will work on my ancient laptop…


#36

Does Tom have an archive of his streams? I’d like to watch that too!


#37

None of it works :(
it sure works good on my computer when steamlink is off though.


#38

He does!

That link is the original post in that thread, it has links to all his streams. You’ll notice he started streaming with a whole week of Dark Souls 3. That’s what me and krayzkrok and others watched, and we all got the Dark Souls bug and we all played through Dark Souls after that. The stream definitely inspired me. Especially the first one where he got past that first boss after so many tries.

Here is a link to his very first session, that I’m talking about:


#39

Ohhhh thanks a ton Rock8man!


#40

Yes, when playing most RPGs I will attack civilians and shopkeepers etc to see what will happen. I also often reload and choose other conversations. I like to explore all the opportunities available to me!


#41

Hahahahaha me too!!!


#42

Well, don’t do that in a Dark Souls game.

And that merchant is very early in the game. You should just start over, knowing what you know it wouldn’t take very long to get back there.


#43

I actually killed the guy, with the encouragement from qt3, but not because I was good, but because he fell off a cliff whilst trying to hit me. He rolled right off!

So to be clear: I didn’t really quit because it was hard (and it was, he killed me a lot), but because the game rules seemed to conflict with what was already established. (I.e. when you die monsters respawn and bosses get their health back, but this angry guy would always stay angry at me, but would not respawn?)

I didn’t understand the game rules so I gave up.

I’m suprised Tom likes the game given that manuals, lack of explanationsand, relying on wiki’s are often ha reason for him not to play a game!


#44

Merchants don’t re-spawn. And if you attack them, along with any other NPC, they have really long memories. There is a way much later in the game to get them to “forgive” you and they will quit chasing you, but once dead, they are dead for good.

In Dark Souls 2 I know that before starting a NG+ game many “experts” tell you to go around killing NPCs to get their objects. The problem is that killing an NPC is considered a sin and too many sins will lead to you getting invaded by guys intent on avenging the NPCs. I don’t know if DS1 works that same way or not.


#45

I hate this thread’s existence! I’ve tried three times to “get” Dark Souls 1. My last attempt was, in my opinion, more than generous, at least a half-dozen hours. I made it past the first boss, and had progressed well into battling some (what I thought to be) tough dudes, feeling all sorts of badassery upon my badass self. But, NAY! No, sir! I was wrong! My pimply, stinky ass was handed to me most unapologetically by all sorts of nasty, horrible, ugly, and downright mean dudes, hating on the progress I’d made, being all Gandalfy with their “You Shall Not Pass” shit, and generally preventing all fun. So, my walk-away decision for Dark Souls (1) was, no thank you.

Now, you all have to post this shit.

Dammit.


#46

The other thing that makes it hard is there’s so much obscure crap and misdirection that will make you frustrated. You’re supposed to post on a forum about it and then we all get to make witty know-it-all comments.

For example, nogwart, you might have wandered into the wrong area or something.


#47

I am in similar predicament. I tried to get into Dark Souls and failed miserably. Then I raged quit and tried again and this time I did quite well. At one point, I did quite well, even able to have a good melee with a few knights. I finally reached the dragon that looked like vagina (Epidragon or something like that) and I think I died like 30 times. I gave up after that especially when my friend discourage me to continue as he said the level after that, with those poisonous mosquitoes, is going to be worse. Now, I am not sure I want to get into the game, having forgotten all about the controls. This thread does motivate me to give it another go. And I will watch the video that @Rock8man posted, so hopefully that will energize me a bit more.


#48

Oh, the Gaping Dragon! I forgot about that one.

Yeah the area after that kind of sucks. People, just play Dark Souls 2 or 3 if you want a change of pace!


#49

Gaping Dragon! That’s it! I hate that boss (insert expletives here!!)


#50

I think you’ve been looking at the wrong vaginas.


#51

How can I miss this… this… attractive thing?


#52

I am ready to attack New Londo Ruins… I know I need 2 hours of silence around me, without distraction… I haven’t found the time yet. So 4 weeks passed without progress… I had a drive, 2-3 hours a night, that was weeks ago… I hate to lose track like that…