Freesync 2020

Finally upgraded my monitor situation with a 32" curved 2K 144Hz ViewSonic of which I may have gotten the last freakin’ one in the country. Anyway. It’s huge and glorious and I lurb it.

Initial game testing has been uninspiring but my guess is that using HDMI is my bottleneck. Windows is only recognizing it as a 60Hz display, so presumably the DX layer ain’t heard of no FRAMERATES, no son.

So, question: Anything I need to do or configure beyond upgrading to a DisplayPort cable?

Obviously my hardware itself may be a limitation, but 2x Radeon 480s and a 3.4GHz i5 should be enough to FRAMERATE the fuck out of like Portal 2 and Skyrim at 1440p, no?

Also make sure you’re not missing a refresh rate setting in the monitor settings itself - sometimes you need to set the monitor to ‘boost’ refresh or some such malarkey.

I did have to set Freesync to On in the monitor’s OSD. It doesn’t seem to have a specific refresh rate setting anywhere.

Sidenote, on the ViewSonic OSD situation – I love the little joystick instead of discrete OSD control buttons. I don’t love the fact that it took me 20 minutes to figure out how to turn off the overlay crosshairs in the middle of the screen (for MAXIMUM GAMING, obviously).

(From neutral with the OSD not displaying, joystick-down toggles crosshairs. Duh!)

It probably is to a degree, but I think you should still get 90Hz at 1440p if you’re not using some really ancient cable.

The Radeon 480 is an HDMI 2.0 card. HDMI 2.0 supports a max of 4k 60Hz, which I think equates to 90Hz at 2k? Also I don’t think 2.0 supports variable refresh rate, which may have something to do with why you’re only seeing 60 (don’t know for sure).


It’s either your HDMI cable, or potentially an issue with running in crossfire since the 480 is meant to support HDMI v2.0 might be an option but getting a displayport cable is your best bet

So! Turns out there’s a Windows setting in the old-school Device Mangler, of all things. Between that and the new cable, I’m FreeSyncing away and it’s pretty glorious. I am super happy with the new display.

Hilariously, if I set the Windows adaptive refresh to true, the Steam client gets all kinds of pissed.

Ooooooooorrrrr it’s some other shit. Down the update rabbit hole we go!

What version are you running?

Oh my graphics drivers were positively antediluvian.

Updated, same problem. Disable Freesync in Radeon, same problem. Monitor to 120Hz, same problem. Disable Freesync on monitor, problem goes away.

Woe is me.

Are you running two 480s? Want to confirm.

I am.

Try yanking one of them.

No dice, same problem in Windows. No issues with anything in-game.

Also I thought I solved it by turning off FreeSync on the monitor, but that’s also not the case.

Issue seems to come up when a new window comes into focus. Even when mousing around the screen and mousing over new windows. Guessing it has something to do with Windows 3D accel.

Switching the Windows control to limit the monitor to 60Hz eliminates the problem, but man, that sucks.

Are you running Windows 10 1909?

I’m on 1903.

Man, Googling for 144Hz Windows screen flickers with modern AMD cards is a whole bunch of staring into the void.

So far I’ve tried forcing the card not to undervolt or clock down at lower usage states, no dice. Disable HDCP, no dice.

I’m stuck at 60Hz until I feel like upgrading to a 2070 or some other card that doesn’t have software written by rabid hyenas, looks like.

You can try 1909.

Maybe try using DDU to do a clean removal of the drivers, then install the latest ones.

Yeah, I didn’t have any trouble with my 480 running at 144hz on my system when I got my 1440p screen.

Thanks. I’ll probably take another swing at it tomorrow.

Ugh, is DDU still a thing? Bleh.

1909 didn’t change any behavior.